summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_%.bbappend
diff options
context:
space:
mode:
authorJérémy Fanguède <j.fanguede@virtualopensystems.com>2019-07-18 17:17:30 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-03-12 18:01:05 +0000
commit51abffddc77897fc266682be16e7f468613c2216 (patch)
tree46b67418c611adda02b7d187f66ba306fef604b8 /meta-agl-bsp/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_%.bbappend
parent9f4f5ba2cf02fd40764a299fbaa7089cece5774d (diff)
meta-rcar-gen3: Add Xen specific device tree for m3ulcb
Provide a specific version of the device tree (appended with -xen) to run with Xen. Only the R-Car m3ulcb board is supported and tested so far. Add also the Xen block device backend support in the kernel, to be able to run block device based DomU. From U-Boot, Xen and Linux Dom0 can be run as follows (assuming binaries are in sdcard first partition): > setenv bootargs > fatload mmc 0:1 0x48080000 xen-m3ulcb.uImage > fatload mmc 0:1 0x48000000 r8a7796-m3ulcb-xen.dtb > fatload mmc 0:1 0x7a000000 Image-m3ulcb.bin > bootm 0x48080000 - 0x48000000 The Linux Dom0 bootargs are hardcoded in the device tree, the rootfs is expected to be on /dev/mmcblk1p2 Bug-AGL: SPEC-2912 Change-Id: Ia86e0789650eaf79d13691cf4f53755c8cb8f06c Signed-off-by: Jérémy Fanguède <j.fanguede@virtualopensystems.com>
Diffstat (limited to 'meta-agl-bsp/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_%.bbappend')
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_%.bbappend11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_%.bbappend b/meta-agl-bsp/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_%.bbappend
index e72dc3df3..6db5af3a5 100644
--- a/meta-agl-bsp/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_%.bbappend
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_%.bbappend
@@ -9,3 +9,14 @@ SRC_URI_append = " file://namespace_fix.cfg \
SRC_URI_append_ulcb = " \
file://0004-ADSP-enable-and-add-sound-hardware-abstraction.patch \
"
+
+# For Xen
+SRC_URI_append = " \
+ ${@bb.utils.contains('AGL_XEN_WANTED','1','file://xen-be.cfg','',d)} \
+"
+SRC_URI_append_m3ulcb = " \
+ ${@bb.utils.contains('AGL_XEN_WANTED','1','file://r8a7796-m3ulcb-xen.dts;subdir=git/arch/${ARCH}/boot/dts/renesas','',d)} \
+"
+KERNEL_DEVICETREE_append_m3ulcb = " \
+ ${@bb.utils.contains('AGL_XEN_WANTED','1','renesas/r8a7796-m3ulcb-xen.dtb','',d)} \
+" \ No newline at end of file