summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-rcar-gen3/recipes-kernel/linux
diff options
context:
space:
mode:
authorAshok Sidipotu <ashok.sidipotu@collabora.com>2022-02-17 18:59:25 +0530
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-05-04 14:56:30 +0000
commit080086bc5062a1eb025b82051884aaa508f50408 (patch)
treebb291b4c2dce25e08af5228dd805b61bc3d0e881 /meta-agl-bsp/meta-rcar-gen3/recipes-kernel/linux
parent00691c280303d633f638b7a8141cc59f9ade4813 (diff)
wireplumber: Create new recipe for policy daemon
-carve out a new recipe for wireplumber policy, so that it can be assigned to the concerned container. -create new packagegroup-pipewire-base capturing the set of packages required to use PipeWire API. -remove the implicit dependencies between different wireplumber recipes, now each of those recipes will have to be included in the top level bb file. -remove the wireplumber-config virtual package. Bug-AGL: SPEC-4100 Signed-off-by: Ashok Sidipotu <ashok.sidipotu@collabora.com> Change-Id: I8ff6834c5dae94b75e07a0709c403b5d7f3b274b Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/27254 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jenkins Job builder account
Diffstat (limited to 'meta-agl-bsp/meta-rcar-gen3/recipes-kernel/linux')
0 files changed, 0 insertions, 0 deletions
l.String.Heredoc */ .highlight .si { color: #3333bb; background-color: #fff0f0 } /* Literal.String.Interpol */ .highlight .sx { color: #22bb22; background-color: #f0fff0 } /* Literal.String.Other */ .highlight .sr { color: #008800; background-color: #fff0ff } /* Literal.String.Regex */ .highlight .s1 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Single */ .highlight .ss { color: #aa6600; background-color: #fff0f0 } /* Literal.String.Symbol */ .highlight .bp { color: #003388 } /* Name.Builtin.Pseudo */ .highlight .fm { color: #0066bb; font-weight: bold } /* Name.Function.Magic */ .highlight .vc { color: #336699 } /* Name.Variable.Class */ .highlight .vg { color: #dd7700 } /* Name.Variable.Global */ .highlight .vi { color: #3333bb } /* Name.Variable.Instance */ .highlight .vm { color: #336699 } /* Name.Variable.Magic */ .highlight .il { color: #0000DD; font-weight: bold } /* Literal.Number.Integer.Long */
--- a/Makefile.orig	2016-04-01 15:50:20.636358716 +0200
+++ b/Makefile	2016-04-01 15:51:58.916361191 +0200
@@ -1,3 +1,9 @@
+INCDIR = $(SDKROOT)/usr/include
+LIBDIR = $(SDKROOT)/usr/lib
+
+EXTRA_CFLAGS=-I$(INCDIR)
+EXTRA_LDFLAGS=-Wl,-rpath-link=$(LIBDIR) -L$(LIBDIR)
+
 OBJECTS = bs_main.o \
     bs_vector.o \
     bs_pointmass.o \
@@ -15,21 +21,21 @@
     bs_profiler.o \
     bs_rubberband.o
 
-CC = gcc 
+#CC = gcc 
 
 DISTDIR = blobsallad-src
 
-CFLAGS = `pkg-config --cflags cairo; sdl-config --cflags`
-LIBS = `pkg-config --libs cairo; sdl-config --libs` -lm -lGL -lGLU
+EXTRA_CFLAGS += -I$(INCDIR)/cairo -I$(INCDIR)/SDL -D_GNU_SOURCE=1 -D_REENTRANT
+EXTRA_LDFLAGS += -lcairo -lSDL -lpthread -lm
 
 all: $(OBJECTS)
-	$(CC) -g -o blobsallad $(OBJECTS) $(LIBS)
+	$(CC) -g -o blobsallad $(OBJECTS) $(EXTRA_LDFLAGS)
 
 map: 
-	gcc -o createmap create_testdata.c -Wall -g -lm
+	$(CC) -o createmap create_testdata.c -Wall -g -lm
 
 octree:
-	gcc -o test_octree test_octree.c bs_octree.c bs_list.c bs_vector.c bs_vector_util.c bs_timer.c bs_array.c -Wall -O2 $(LIBS) $(CFLAGS)
+	$(CC) -o test_octree test_octree.c bs_octree.c bs_list.c bs_vector.c bs_vector_util.c bs_timer.c bs_array.c -Wall -O2 $(EXTRA_LDFLAGS) $(EXTRA_CFLAGS)
 
 GFX_OBJECTS = gfx_main.o \
 	bs_gfx.o \
@@ -41,10 +47,10 @@
 	bs_list.o 
 
 gfx: $(GFX_OBJECTS)
-	gcc -o gfx_main -Wall -g $(GFX_OBJECTS) $(LIBS)
+	$(CC) -o gfx_main -Wall -g $(GFX_OBJECTS) $(EXTRA_LDFLAGS)
 
 .c.o:
-	$(CC) -g -Wall $(CFLAGS) $ -c $<
+	$(CC) -g -Wall $(EXTRA_CFLAGS) $ -c $<
 
 clean: 
 	rm -f *.o; rm -f blobsallad;