summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-rcar-gen3/recipes-support
diff options
context:
space:
mode:
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2018-08-22 04:08:59 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-08-23 12:07:25 +0000
commit6da5cf9ad4871fde608b2454d0119350d0f52a0d (patch)
tree48e6cabbf11b431fe198d56ee52f98aecd36a864 /meta-agl-bsp/meta-rcar-gen3/recipes-support
parent16d03b87304e2bcb01d97a560caf80ecd1d5afda (diff)
[Work-around] Update recipe for ImageMagick to avoid bitbake error
At www.imagemagick.org/download, tarball archives of old patchsets are deleted when a new patchset is created. This causes error when do_fetch(). Offical source repository is in github, so SRC_URI can be set to pull from there. Unfortunately, github repository has tags only after 6.9.5-4. Therefore, updated to the latest stable, 6.9.10-10. For meta-agl/meta-agl-demo, ImageMagick is not mandatory component, but optee inside Renesas BSP requires it (and python-wand). Upstream optee already remove these dependency, so this is just work-around until meta-renesas-rcar-gen3 will be updated. Change-Id: I1767e2d7588a35d75009843312c484d3d63553ae Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Diffstat (limited to 'meta-agl-bsp/meta-rcar-gen3/recipes-support')
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-support/imagemagick/imagemagick_6.9.10.bb (renamed from meta-agl-bsp/meta-rcar-gen3/recipes-support/imagemagick/imagemagick_6.9.2.bb)11
1 files changed, 4 insertions, 7 deletions
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-support/imagemagick/imagemagick_6.9.2.bb b/meta-agl-bsp/meta-rcar-gen3/recipes-support/imagemagick/imagemagick_6.9.10.bb
index baf699a5f..f33212d53 100644
--- a/meta-agl-bsp/meta-rcar-gen3/recipes-support/imagemagick/imagemagick_6.9.2.bb
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-support/imagemagick/imagemagick_6.9.10.bb
@@ -1,20 +1,17 @@
SUMMARY = "ImageMagick is an image convertion tools"
SECTION = "console/utils"
LICENSE = "ImageMagick"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=0887b670be7ef0c3cb37092b64d57514"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4c223567f4c3b26a08c56aa59b346ca5"
# FIXME: There are many more checked libraries. All should be added or explicitly disabled to get consistent results.
DEPENDS = "lcms bzip2 jpeg libpng librsvg tiff zlib fftw freetype"
# Important note: tarballs for all patchsets within a version are deleted when
# a new pachset is created. To avoid multiple patches for each patchset, try to
# update to the last pachset of a version
-PATCHSET = "0"
-SRC_URI = "http://www.imagemagick.org/download/releases/ImageMagick-${PV}-${PATCHSET}.tar.xz \
+PATCHSET = "10"
+SRC_URI = "git://github.com/ImageMagick/ImageMagick6.git;protocol=https;tag=${PV}-${PATCHSET} \
"
-SRC_URI[md5sum] = "99471c8c3f38c9264faf5c4ca7a31287"
-SRC_URI[sha256sum] = "07a2de28f7f9ab888ef47c02eb7e10cc3e0dd0e9797c5d71d6e71d19f842399e"
-
-S = "${WORKDIR}/ImageMagick-${PV}-${PATCHSET}"
+S = "${WORKDIR}/git"
inherit autotools pkgconfig update-alternatives
82' href='#n282'>282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350
/*
 * Copyright (C) 2020 Konsulko Group
 *
 * Licensed under the Apache License, Version 2.0 (the "License");
 * you may not use this file except in compliance with the License.
 * You may obtain a copy of the License at
 *
 *      http://www.apache.org/licenses/LICENSE-2.0
 *
 * Unless required by applicable law or agreed to in writing, software
 * distributed under the License is distributed on an "AS IS" BASIS,
 * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
 * See the License for the specific language governing permissions and
 * limitations under the License.
 */

#include <QDebug>
#include <QJsonArray>

#include "callmessage.h"
#include "eventmessage.h"
#include "messagefactory.h"
#include "messageengine.h"
#include "guimetadata.h"

GuiMetadata::GuiMetadata(QUrl &url, QQmlContext *context, QObject * parent) :
	QObject(parent),
	m_mloop(nullptr)
{
	m_mloop = new MessageEngine(url);
	m_context = context;
	QObject::connect(m_mloop, &MessageEngine::connected, this, &GuiMetadata::onConnected);
	QObject::connect(m_mloop, &MessageEngine::disconnected, this, &GuiMetadata::onDisconnected);
	QObject::connect(m_mloop, &MessageEngine::messageReceived, this, &GuiMetadata::onMessageReceived);
}

GuiMetadata::~GuiMetadata()
{
	delete m_mloop;
}

// Qt UI Context

void GuiMetadata::clearMetadata()
{
	m_type = "";
	m_title = "";
	m_subtitle = "";

	m_bodyText = "";
	m_bodyImageSmallUrl = "";
	m_bodyImageMediumUrl = "";
	m_bodyImageLargeUrl = "";

	m_weatherCurrentTemperature = "";
	m_weatherCurrentWeatherIconSmallUrl = "";
	m_weatherCurrentWeatherIconSmallDarkBgUrl = "";
	m_weatherCurrentWeatherIconMediumUrl = "";
	m_weatherCurrentWeatherIconMediumDarkBgUrl = "";
	m_weatherCurrentWeatherIconLargeUrl = "";
	m_weatherCurrentWeatherIconLargeDarkBgUrl = "";

	m_weatherLowTemperature = "";
	m_weatherLowTemperatureArrowSmallUrl = "";
	m_weatherLowTemperatureArrowSmallDarkBgUrl = "";
	m_weatherLowTemperatureArrowMediumUrl = "";
	m_weatherLowTemperatureArrowMediumDarkBgUrl = "";
	m_weatherLowTemperatureArrowLargeUrl = "";
	m_weatherLowTemperatureArrowLargeDarkBgUrl = "";

	m_weatherHighTemperature = "";
	m_weatherHighTemperatureArrowSmallUrl = "";
	m_weatherHighTemperatureArrowSmallDarkBgUrl = "";
	m_weatherHighTemperatureArrowMediumUrl = "";
	m_weatherHighTemperatureArrowMediumDarkBgUrl = "";
	m_weatherHighTemperatureArrowLargeUrl = "";
	m_weatherHighTemperatureArrowLargeDarkBgUrl = "";
}

bool GuiMetadata::parseImageMetadata(QJsonObject &imageObj,
				     QUrl &smallUrl, QUrl &mediumUrl, QUrl &largeUrl,
				     QUrl *pSmallDarkBgUrl, QUrl *pMediumDarkBgUrl, QUrl *pLargeDarkBgUrl)
{
	if(!(imageObj.contains("sources") && imageObj["sources"].isArray())) {
		// error
		qWarning() << "Could not find image.sources parameter!";
		return false;
	}
	QJsonArray sourcesObj = imageObj["sources"].toArray();
	bool found = false;
	for(QJsonArray::iterator it = sourcesObj.begin(); it != sourcesObj.end(); it++) {
		if(!it->isObject()) {
			// unexpected, skip
			continue;
		}
		QJsonObject sourceObj = it->toObject();
		if(!(sourceObj.contains("url") && sourceObj["url"].isString())) {
			// error
			qWarning() << "Missing image.sources.url parameter!";
			continue;
		}
		QString url = sourceObj["url"].toString();
		QString darkBackgroundUrl = "";
		if(sourceObj.contains("darkBackgroundUrl") && sourceObj["darkBackgroundUrl"].isString()) {
			darkBackgroundUrl = sourceObj["darkBackgroundUrl"].toString();
		}
		if(sourceObj.contains("size") && sourceObj["size"].isString()) {
			QString size = sourceObj["size"].toString();
			if(size == "SMALL") {
				smallUrl = url;
				if(pSmallDarkBgUrl)
					pSmallDarkBgUrl->setUrl(darkBackgroundUrl);
				found = true;
			} else if(size == "MEDIUM") {
				mediumUrl = url;
				if(pMediumDarkBgUrl)
					pMediumDarkBgUrl->setUrl(darkBackgroundUrl);
				found = true;
			} else if(size == "LARGE") {
				largeUrl = url;
				if(pLargeDarkBgUrl)
					pLargeDarkBgUrl->setUrl(darkBackgroundUrl);
				found = true;
			}
			// else ignore (X-SMALL, X-LARGE)
		}
		// FIXME: Should handle image sources w/o size fields,
		//        parse width/height if present
	}
	return found;
}

bool GuiMetadata::updateMetadata(QJsonObject data)
{
	if(!data.contains("type"))
		return false;

	clearMetadata();

	QString type = data["type"].toString();
	if(!(type == "BodyTemplate1" ||
	     type == "BodyTemplate2" ||
	     type == "WeatherTemplate")) {
		// Show unsupported type message
		m_type = "Unsupported";
		return true;
	}
	m_type = type;

	// All template types have title
	if(data.contains("title") && data["title"].isObject()) {
		QJsonObject titleObj = data["title"].toObject();
		if(titleObj.contains("mainTitle")) {
			m_title = titleObj["mainTitle"].toString();
		} else {
			qWarning() << "Could not find title.mainTitle parameter!";
			return false;
		}
		// subTitle is apparently optional
		if(titleObj.contains("subTitle"))
			m_subtitle = titleObj["subTitle"].toString();
	} else {
		// error
		qWarning() << "Could not find title parameter!";
		return false;
	}

	if(type == "BodyTemplate1" || type == "BodyTemplate2")
		return updateBodyMetadata(data);
	else
		return updateWeatherMetadata(data);
}

bool GuiMetadata::updateBodyMetadata(QJsonObject &data)
{
	if(!data.contains("type"))
		return false;

	QString type = data["type"].toString();
	if(!(type == "BodyTemplate1" || type == "BodyTemplate2"))
		return false;

	// BodyTemplate1/2 have text field
	if(data.contains("textField")) {
		m_bodyText = data["textField"].toString();
	} else {
		// error
		qWarning() << "Could not find textField parameter!";
		return false;
	}

	// BodyTemplate2 has image
	if(type == "BodyTemplate2") {
		if(!(data.contains("image") && data["image"].isObject())) {
			// error
			qWarning() << "Could not find image parameter!";
			return false;
		}
		QJsonObject imageObj = data["image"].toObject();
		if(!parseImageMetadata(imageObj,
				       m_bodyImageSmallUrl,
				       m_bodyImageMediumUrl,
				       m_bodyImageLargeUrl)) {
			qWarning() << "Could not parse image parameter!";
			return false;
		}
	}

	return true;
}

bool GuiMetadata::updateWeatherMetadata(QJsonObject &data)
{
	if(!data.contains("type"))
		return false;

	QString type = data["type"].toString();
	if(type != "WeatherTemplate")
		return false;

	if(data.contains("currentWeather")) {
		m_weatherCurrentTemperature = data["currentWeather"].toString();
	} else {
		// error
		qWarning() << "Could not find currentWeather parameter!";
		return false;
	}

	if(!(data.contains("currentWeatherIcon") && data["currentWeatherIcon"].isObject())) {
		// error
		qWarning() << "Could not find currentWeatherIcon parameter!";
		return false;
	}
	QJsonObject imageObj = data["currentWeatherIcon"].toObject();
	if(!parseImageMetadata(imageObj,
			       m_weatherCurrentWeatherIconSmallUrl,
			       m_weatherCurrentWeatherIconMediumUrl,
			       m_weatherCurrentWeatherIconLargeUrl,
			       &m_weatherCurrentWeatherIconSmallDarkBgUrl,
			       &m_weatherCurrentWeatherIconMediumDarkBgUrl,
			       &m_weatherCurrentWeatherIconLargeDarkBgUrl)) {
		qWarning() << "Could not parse currentWeatherIcon.image parameter!";
		return false;
	}

	if(!(data.contains("lowTemperature") && data["lowTemperature"].isObject())) {
		// error
		qWarning() << "Could not find lowTemperature parameter!";
		return false;
	}
	QJsonObject tempObj = data["lowTemperature"].toObject();
	if(!(tempObj.contains("value") && tempObj["value"].isString())) {
		// error
		qWarning() << "Could not find lowTemperature.value parameter!";
		return false;
	}
	m_weatherLowTemperature = tempObj["value"].toString();

	if(!(tempObj.contains("arrow") && tempObj["arrow"].isObject())) {
		// error
		qWarning() << "Could not find lowTemperature.arrow parameter!";
		return false;
	}
	imageObj = tempObj["arrow"].toObject();
	if(!parseImageMetadata(imageObj,
			       m_weatherLowTemperatureArrowSmallUrl,
			       m_weatherLowTemperatureArrowMediumUrl,
			       m_weatherLowTemperatureArrowLargeUrl,
			       &m_weatherLowTemperatureArrowSmallDarkBgUrl,
			       &m_weatherLowTemperatureArrowMediumDarkBgUrl,
			       &m_weatherLowTemperatureArrowLargeDarkBgUrl)) {
		qWarning() << "Could not parse lowTemperature.arrow parameter!";
		return false;
	}

	if(!(data.contains("highTemperature") && data["highTemperature"].isObject())) {
		// error
		qWarning() << "Could not find highTemperature parameter!";
		return false;
	}
	tempObj = data["highTemperature"].toObject();
	if(!(tempObj.contains("value") && tempObj["value"].isString())) {
		// error
		qWarning() << "Could not find highTemperature.value parameter!";
		return false;
	}
	m_weatherHighTemperature = tempObj["value"].toString();

	if(!(tempObj.contains("arrow") && tempObj["arrow"].isObject())) {
		// error
		qWarning() << "Could not find highTemperature.arrow parameter!";
		return false;
	}
	imageObj = tempObj["arrow"].toObject();
	if(!parseImageMetadata(imageObj,
			       m_weatherHighTemperatureArrowSmallUrl,
			       m_weatherHighTemperatureArrowMediumUrl,
			       m_weatherHighTemperatureArrowLargeUrl,
			       &m_weatherHighTemperatureArrowSmallDarkBgUrl,
			       &m_weatherHighTemperatureArrowMediumDarkBgUrl,
			       &m_weatherHighTemperatureArrowLargeDarkBgUrl)) {
		qWarning() << "Could not parse highTemperature.arrow parameter!";
		return false;
	}

	return true;

}

void GuiMetadata::onConnected()
{
	std::unique_ptr<Message> msg = MessageFactory::getInstance().createOutboundMessage(MessageId::Call);
	if (!msg)
		return;

	CallMessage *tmsg = static_cast<CallMessage*>(msg.get());
	QStringListIterator eventIterator(events);
	QJsonObject parameter;
	QJsonArray actions;
	while (eventIterator.hasNext()) {
		actions.append(QJsonValue(eventIterator.next()));
	}
	parameter.insert("actions", actions);
	tmsg->createRequest("vshl-capabilities", "guimetadata/subscribe", parameter);
	m_mloop->sendMessage(std::move(msg));
}

void GuiMetadata::onDisconnected()
{
	// vshl-capabilities currently has no unsubscribe verb...
}

void GuiMetadata::onMessageReceived(std::shared_ptr<Message> msg)
{
	if (!msg)
		return;

	if (msg->isEvent()) {
		std::shared_ptr<EventMessage> emsg = std::static_pointer_cast<EventMessage>(msg);
		if (emsg->eventApi() != "vshl-capabilities")
			return;
		QString ename = emsg->eventName();
		QJsonObject data = emsg->eventData();
		if ((ename == "render-template") && updateMetadata(data)) {
			emit renderTemplate();
		} else if (ename == "clear_template") {
			emit clearTemplate();
		}
	}
}