summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-renesas/recipes-kernel/s3ctl-module/files/0001-Add-s3ctl-hibernation-code.patch
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-02-14 10:55:35 +0100
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-02-14 10:55:35 +0100
commit317c8a08a6b5943517e67c5ea80b0a9a83a10d63 (patch)
treebf2b27dc9068924b59b46d2e153936c77be954c3 /meta-agl-bsp/meta-renesas/recipes-kernel/s3ctl-module/files/0001-Add-s3ctl-hibernation-code.patch
parentb6dc44f585b839ab1a2f0133b74958037fe1cb64 (diff)
parentc9ce37905acd879db107eafe309678053073e086 (diff)
Merge remote-tracking branch 'agl/sandbox/ronan/rocko' into HEAD
* agl/sandbox/ronan/rocko: (58 commits) Update ulcb conf file Remove unsed gstreamer backport [GEN3] add preferred version on omx package run-(agl-)postinst: Emit progress to console meta-security: Remove unused content Upgrade wayland-ivi-extension Revert "Fix kernel gcc7 issue" remove backport commit Revert "Fix CVE-2017-1000364 by backporting the patches for gen3" Remove fix for optee-os Remove gcc 6 fix Update rcar gen3 kernel bbappend version Update rcar gen3 driver Remove porter machine dbus-cynara: Upgrade to 1.10.20 xmlsec1: switch to meta-security version systemd: earlier smack label switch cynara: upgrade to 0.14.10 Remove smack recipe Integrate parts of meta-intel-iot-security ... Bug-AGL: SPEC-1181 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org> Conflicts: meta-app-framework/recipes-security/cynara/cynara_git.bbappend Change-Id: I9875fcb31e960038ce6c23165c99b52a3bd1a1c0
Diffstat (limited to 'meta-agl-bsp/meta-renesas/recipes-kernel/s3ctl-module/files/0001-Add-s3ctl-hibernation-code.patch')
-rw-r--r--meta-agl-bsp/meta-renesas/recipes-kernel/s3ctl-module/files/0001-Add-s3ctl-hibernation-code.patch101
1 files changed, 0 insertions, 101 deletions
diff --git a/meta-agl-bsp/meta-renesas/recipes-kernel/s3ctl-module/files/0001-Add-s3ctl-hibernation-code.patch b/meta-agl-bsp/meta-renesas/recipes-kernel/s3ctl-module/files/0001-Add-s3ctl-hibernation-code.patch
deleted file mode 100644
index b5d9050b2..000000000
--- a/meta-agl-bsp/meta-renesas/recipes-kernel/s3ctl-module/files/0001-Add-s3ctl-hibernation-code.patch
+++ /dev/null
@@ -1,101 +0,0 @@
-From 03253eae0da9a84e343a8f21c65ac07196369420 Mon Sep 17 00:00:00 2001
-From: Yuichi Kusakabe <yuichi.kusakabe@jp.fujitsu.com>
-Date: Sun, 21 May 2017 23:08:52 +0900
-Subject: [PATCH] Add s3ctl hibernation code
-
-Signed-off-by: Yuichi Kusakabe <yuichi.kusakabe@jp.fujitsu.com>
----
- drv/s3ctl_drv.c | 50 ++++++++++++++++++++++++++++++++++++++------------
- 1 file changed, 38 insertions(+), 12 deletions(-)
-
-diff --git a/drv/s3ctl_drv.c b/drv/s3ctl_drv.c
-index a7b4bee..6640a49 100755
---- a/drv/s3ctl_drv.c
-+++ b/drv/s3ctl_drv.c
-@@ -66,6 +66,7 @@
- #include <linux/ioctl.h>
- #include <linux/slab.h>
- #include <linux/dma-mapping.h>
-+#include <linux/suspend.h>
-
- #include "s3ctl_private.h"
-
-@@ -332,19 +333,10 @@ static struct miscdevice misc = {
- .fops = &fops,
- };
-
--
--static int s3ctrl_init(void)
-+static int s3ctl_initialize(void)
- {
-- int ret;
-- unsigned int product;
-- unsigned int es;
--
-- ret = map_register();
-- if (ret != 0) {
-- printk(KERN_ERR "S3D map_register() NG\n");
-- return -1;
-- }
--
-+ int product;
-+ int es;
- product = S3_PRR_PRODUCTMASK & ioread32((void *)top_prr);
- es = S3_PRR_ESMASK & ioread32((void *)top_prr);
- if (product == S3_PRR_H2) {
-@@ -366,11 +358,44 @@ static int s3ctrl_init(void)
- set_xymodeconf(S3_XYMODE_VAL_NEW);
- } else
- set_xymodeconf(S3_XYMODE_VAL_NEW);
-+ return 0;
-+}
-+
-+static int s3ctl_cpu_pm_notify(struct notifier_block *self,
-+ unsigned long action, void *hcpu)
-+{
-+ if (action == PM_HIBERNATION_PREPARE)
-+ ;
-+ else if (action == PM_POST_HIBERNATION) {
-+ pr_info("%s: hibernation finished: %ld\n", __func__, action);
-+ s3ctl_initialize();
-+ }
-+ return NOTIFY_DONE;
-+}
-+
-+static struct notifier_block s3ctl_pm_notifier_block = {
-+ .notifier_call = s3ctl_cpu_pm_notify,
-+};
-+
-+static int s3ctrl_init(void)
-+{
-+ int ret;
-+ unsigned int product;
-+ unsigned int es;
-+
-+ ret = map_register();
-+ if (ret != 0) {
-+ printk(KERN_ERR "S3D map_register() NG\n");
-+ return -1;
-+ }
-+ s3ctl_initialize();
-
- misc_register(&misc);
-
- spin_lock_init(&lock);
-
-+ register_pm_notifier(&s3ctl_pm_notifier_block);
-+
- return 0;
- }
-
-@@ -379,6 +404,7 @@ static void s3ctrl_exit(void)
- misc_deregister(&misc);
-
- unmap_register();
-+ unregister_pm_notifier(&s3ctl_pm_notifier_block);
- }
-
- module_init(s3ctrl_init);
---
-1.8.3.1
-