summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-ti/recipes-arago/ipc/patches/add-dependency-of-pthreads.patch
diff options
context:
space:
mode:
authorKarthik Ramanan <a0393906@ti.com>2016-11-11 13:42:19 +0530
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-11-13 20:04:21 +0000
commit2380bc09b584ae176f2275c6ac72d94ebfbf7c3b (patch)
treeb042e8eafa078df997d644ce7911bf64c5b3560e /meta-agl-bsp/meta-ti/recipes-arago/ipc/patches/add-dependency-of-pthreads.patch
parent3bd99fb9c93da89564d31cf6579d49213915d2f7 (diff)
dra7xx-evm: add support for multimedia acceleration
TI Jacinto 6 has hardware multimedia acceleration capability. This patch introduces the firmware and IPC components that are needed to control the hardware accelerators. Change-Id: I795c820f9bb87dd77ad227ce7c80f879dd935e54 Signed-off-by: Karthik Ramanan <a0393906@ti.com>
Diffstat (limited to 'meta-agl-bsp/meta-ti/recipes-arago/ipc/patches/add-dependency-of-pthreads.patch')
-rw-r--r--meta-agl-bsp/meta-ti/recipes-arago/ipc/patches/add-dependency-of-pthreads.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-ti/recipes-arago/ipc/patches/add-dependency-of-pthreads.patch b/meta-agl-bsp/meta-ti/recipes-arago/ipc/patches/add-dependency-of-pthreads.patch
new file mode 100644
index 000000000..649eef5b1
--- /dev/null
+++ b/meta-agl-bsp/meta-ti/recipes-arago/ipc/patches/add-dependency-of-pthreads.patch
@@ -0,0 +1,13 @@
+diff --git a/linux/src/transport/Makefile.am b/linux/src/transport/Makefile.am
+index 32f0046..b4d3078 100644
+--- a/linux/src/transport/Makefile.am
++++ b/linux/src/transport/Makefile.am
+@@ -32,7 +32,7 @@
+ ##
+
+ # additional include paths necessary to compile the library
+-AM_CFLAGS = -I$(top_srcdir)/hlos_common/include -D_GNU_SOURCE -Wall
++AM_CFLAGS = -I$(top_srcdir)/hlos_common/include -D_GNU_SOURCE -Wall -pthread
+
+ if KERNEL_INSTALL_DIR
+ AM_CFLAGS += -I$(KERNEL_INSTALL_DIR)/include/generated/uapi