aboutsummaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-ti/recipes-bsp/ti-sgx-ddk-km/ti-sgx-ddk-km/0001-Add-support-for-AGL-toolchain.patch
diff options
context:
space:
mode:
authorPaul Barker <paul.barker@sancloud.co.uk>2019-11-18 20:50:50 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-11-19 22:37:31 +0000
commitef626d3870beba4f7639eaebedf5259d784d6be5 (patch)
tree430149ef0616184920ed1999ef2a9830d29854b4 /meta-agl-bsp/meta-ti/recipes-bsp/ti-sgx-ddk-km/ti-sgx-ddk-km/0001-Add-support-for-AGL-toolchain.patch
parent0bbd4c12cb6c64596607be83884e2352e7c91cab (diff)
Support meta-ti 2019.04 release
* The libgbm recipe has disappeared. "virtual/libgbm" is now provided by ti-sgx-ddk-um. * Update ti-sgx-ddk-km and adapt the AGL toolchain support to fit with the upstream Makefile changes. Change-Id: I2744868b466306cf2c1cb458a6889ab2043f9421 Signed-off-by: Paul Barker <paul.barker@sancloud.co.uk>
Diffstat (limited to 'meta-agl-bsp/meta-ti/recipes-bsp/ti-sgx-ddk-km/ti-sgx-ddk-km/0001-Add-support-for-AGL-toolchain.patch')
-rw-r--r--meta-agl-bsp/meta-ti/recipes-bsp/ti-sgx-ddk-km/ti-sgx-ddk-km/0001-Add-support-for-AGL-toolchain.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-ti/recipes-bsp/ti-sgx-ddk-km/ti-sgx-ddk-km/0001-Add-support-for-AGL-toolchain.patch b/meta-agl-bsp/meta-ti/recipes-bsp/ti-sgx-ddk-km/ti-sgx-ddk-km/0001-Add-support-for-AGL-toolchain.patch
new file mode 100644
index 000000000..93aff157a
--- /dev/null
+++ b/meta-agl-bsp/meta-ti/recipes-bsp/ti-sgx-ddk-km/ti-sgx-ddk-km/0001-Add-support-for-AGL-toolchain.patch
@@ -0,0 +1,30 @@
+From 11131a5e778d19c06eefbcf61447c6efbcee0613 Mon Sep 17 00:00:00 2001
+From: Paul Barker <paul.barker@sancloud.co.uk>
+Date: Mon, 18 Nov 2019 08:47:41 +0000
+Subject: [PATCH] Add support for AGL toolchain
+
+We can use the pre-existing config for arm-linux-gnueabihf, we just need
+to make sure our toolchain is matched against this and not
+arm-linux-gnueabi.
+
+Signed-off-by: Paul Barker <paul.barker@sancloud.co.uk>
+---
+ eurasia_km/eurasiacon/build/linux2/config/compiler.mk | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/eurasia_km/eurasiacon/build/linux2/config/compiler.mk b/eurasia_km/eurasiacon/build/linux2/config/compiler.mk
+index 2ba3e5e..03e86c5 100644
+--- a/eurasia_km/eurasiacon/build/linux2/config/compiler.mk
++++ b/eurasia_km/eurasiacon/build/linux2/config/compiler.mk
+@@ -68,7 +68,7 @@ define calculate-compiler-preferred-target
+ ifneq ($$(filter aarch64-%,$$($(1)_compiler_preferred_target)),)
+ $(1)_compiler_preferred_target := aarch64-linux-gnu
+ endif
+- ifneq ($$(filter arm-%-gnueabihf arm-oe-linux-gnueabi,$$($(1)_compiler_preferred_target)),)
++ ifneq ($$(filter arm-%-gnueabihf arm-oe-linux-gnueabi arm-agl-linux-gnueabi,$$($(1)_compiler_preferred_target)),)
+ $(1)_compiler_preferred_target := arm-linux-gnueabihf
+ endif
+ ifneq ($$(filter arm-%-gnueabi armv7a-cros-linux-gnueabi armv7hl-redhat-linux-gnueabi,$$($(1)_compiler_preferred_target)),)
+--
+2.17.1
+