aboutsummaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-ti/recipes-graphics/libgles/ti-sgx-ddk-um_%.bbappend
diff options
context:
space:
mode:
authorMatt Porter <mporter@konsulko.com>2017-08-03 00:53:23 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-08-04 16:34:54 +0000
commit3b9e113334578cceb1c802966fd99a8f6f232b60 (patch)
treec68e3cf332c7ce3241b8e4491bab1b5aede07574 /meta-agl-bsp/meta-ti/recipes-graphics/libgles/ti-sgx-ddk-um_%.bbappend
parent84f2e448c6353a3987c032d48447a390db120535 (diff)
meta-agl-bsp: meta-ti: add pvr systemd service
dra7xx-evm currently does not initialize graphics correctly because the PVR SGX services are not loaded at the correct time. Add a systemd service which executes the script from the TI DDK before psplash and weston are started. This fixes dra7xx-evm so that HomeScreen comes up on boot. Bug-AGL: SPEC-798 Change-Id: I0649902ac6066062527f345bea5e36e929d19c01 Signed-off-by: Matt Porter <mporter@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/10499 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Thomas Rini <trini@konsulko.com> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-bsp/meta-ti/recipes-graphics/libgles/ti-sgx-ddk-um_%.bbappend')
-rw-r--r--meta-agl-bsp/meta-ti/recipes-graphics/libgles/ti-sgx-ddk-um_%.bbappend18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-ti/recipes-graphics/libgles/ti-sgx-ddk-um_%.bbappend b/meta-agl-bsp/meta-ti/recipes-graphics/libgles/ti-sgx-ddk-um_%.bbappend
new file mode 100644
index 000000000..21142df59
--- /dev/null
+++ b/meta-agl-bsp/meta-ti/recipes-graphics/libgles/ti-sgx-ddk-um_%.bbappend
@@ -0,0 +1,18 @@
+FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+FILES_${PN} += "/etc/ti-sgx/"
+
+SRC_URI_append = "\
+ file://pvr.service \
+"
+
+inherit systemd
+
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "pvr.service"
+
+do_install_append() {
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0755 ${WORKDIR}/pvr.service ${D}${systemd_system_unitdir}
+ install -d ${D}/etc/ti-sgx
+ install -m 0755 ${D}/etc/init.d/rc.pvr ${D}/etc/ti-sgx
+}