summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-ti
diff options
context:
space:
mode:
authorKarthik Ramanan <a0393906@ti.com>2017-03-21 14:40:35 +0530
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-03-29 16:14:45 +0000
commit29f5c9b429686c1d41b7b5e653fdfe648a803ebb (patch)
treedcd0be11e20739db89a5eed9cac7b51d6ee6387e /meta-agl-bsp/meta-ti
parent3baba8d7cb4f28981c2b4477d4ff2f42cc34e501 (diff)
dra7xx: u-boot: Remove patch for compilation fix
The patch has been integrated into u-boot git repo Change-Id: I540db7bd3658300a3dffc218d228d43e7e87a2b8 Signed-off-by: Karthik Ramanan <a0393906@ti.com>
Diffstat (limited to 'meta-agl-bsp/meta-ti')
-rw-r--r--meta-agl-bsp/meta-ti/recipes-bsp/u-boot/files/fix_builderror_gcc5.patch26
-rw-r--r--meta-agl-bsp/meta-ti/recipes-bsp/u-boot/u-boot-ti-staging_%.bbappend4
2 files changed, 2 insertions, 28 deletions
diff --git a/meta-agl-bsp/meta-ti/recipes-bsp/u-boot/files/fix_builderror_gcc5.patch b/meta-agl-bsp/meta-ti/recipes-bsp/u-boot/files/fix_builderror_gcc5.patch
deleted file mode 100644
index c462191ae..000000000
--- a/meta-agl-bsp/meta-ti/recipes-bsp/u-boot/files/fix_builderror_gcc5.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Fix the following build break:
-
-drivers/usb/host/xhci-omap.c:35:5: error: ‘board_usb_init’ aliased to external symbol ‘__board_usb_init’
- int board_usb_init(int index, enum usb_init_type init)
- ^
-
-Signed-off-by: Felipe Balbi <balbi at ti.com>
----
- drivers/usb/host/xhci-omap.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/drivers/usb/host/xhci-omap.c b/drivers/usb/host/xhci-omap.c
-index 104e7a7282cf..fd19f79f0fc5 100644
---- a/drivers/usb/host/xhci-omap.c
-+++ b/drivers/usb/host/xhci-omap.c
-@@ -27,7 +27,7 @@ DECLARE_GLOBAL_DATA_PTR;
-
- static struct omap_xhci omap;
-
--inline int __board_usb_init(int index, enum usb_init_type init)
-+__weak int __board_usb_init(int index, enum usb_init_type init)
- {
- return 0;
- }
---
-2.5.3 \ No newline at end of file
diff --git a/meta-agl-bsp/meta-ti/recipes-bsp/u-boot/u-boot-ti-staging_%.bbappend b/meta-agl-bsp/meta-ti/recipes-bsp/u-boot/u-boot-ti-staging_%.bbappend
index 6cbb28edc..d1b9b2704 100644
--- a/meta-agl-bsp/meta-ti/recipes-bsp/u-boot/u-boot-ti-staging_%.bbappend
+++ b/meta-agl-bsp/meta-ti/recipes-bsp/u-boot/u-boot-ti-staging_%.bbappend
@@ -1,7 +1,7 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-# This applies to the JACINTO 6 vayu board ... essentially it is dra7_evm.
-SRC_URI_vayu += "file://fix_builderror_gcc5.patch"
+PR_append = "_agl"
+
SRC_URI += " file://${UBOOT_ENV_BINARY}"
UBOOT_ENV = "uEnv"