summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/recipes-kernel
diff options
context:
space:
mode:
authorzheng_wenlong <wenlong_zheng@nexty-ele.com>2017-09-14 17:43:18 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-09-18 03:46:30 +0000
commitefed2d255dccafb8ae44f7d71b92b937ad5c42d8 (patch)
tree3024648c65f807397836edf874f4e5f623402075 /meta-agl-bsp/recipes-kernel
parente48cb247218a9274faa78c535c95d0e0dbaa4686 (diff)
Add uvc.cfg for usb video class kernel configure
Add uvc.cfg into meta-agl-bsp/recipes-kernel, Then include this cfg in each board bbappend. See: https://gerrit.automotivelinux.org/gerrit/#/c/10803/ Change-Id: I5faebefef3560a27496103e1ad4a1ca70377a1ba Signed-off-by: zheng_wenlong <wenlong_zheng@nexty-ele.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/10893 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-bsp/recipes-kernel')
-rw-r--r--meta-agl-bsp/recipes-kernel/linux/linux-%.bbappend1
-rw-r--r--meta-agl-bsp/recipes-kernel/linux/linux/uvc.cfg4
2 files changed, 5 insertions, 0 deletions
diff --git a/meta-agl-bsp/recipes-kernel/linux/linux-%.bbappend b/meta-agl-bsp/recipes-kernel/linux/linux-%.bbappend
index f5e01e2f3..04aeb944b 100644
--- a/meta-agl-bsp/recipes-kernel/linux/linux-%.bbappend
+++ b/meta-agl-bsp/recipes-kernel/linux/linux-%.bbappend
@@ -3,4 +3,5 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/linux:"
# Extra configuration options for the AGL kernel
SRC_URI_append = " file://can-bus.cfg \
file://usb.cfg \
+ file://uvc.cfg \
"
diff --git a/meta-agl-bsp/recipes-kernel/linux/linux/uvc.cfg b/meta-agl-bsp/recipes-kernel/linux/linux/uvc.cfg
new file mode 100644
index 000000000..7cfc377d4
--- /dev/null
+++ b/meta-agl-bsp/recipes-kernel/linux/linux/uvc.cfg
@@ -0,0 +1,4 @@
+CONFIG_VIDEOBUF2_VMALLOC=y
+CONFIG_MEDIA_USB_SUPPORT=y
+CONFIG_USB_VIDEO_CLASS=y
+CONFIG_USB_VIDEO_CLASS_INPUT_EVDEV=y