summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/virtualization-layer/recipes-kernel/linux/linux-yocto_6.6.bbappend
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-07-08 12:51:15 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-07-09 09:35:22 +0000
commit70e0062706360c22adf89577361bd9308eab7b33 (patch)
tree66d3df3397169e1a366582d4ccaec1b1804c6615 /meta-agl-bsp/virtualization-layer/recipes-kernel/linux/linux-yocto_6.6.bbappend
parentad8b90c7b3bddcd1e51e88d4f3af3aa0c267308d (diff)
Rework virtio-aarch64 machine definition
Start on potentially removing separate virtio-arch64 machine by simplifying it and moving as much of its virtio kernel configuration over to our generic kernel configuration scheme. From some experimentation, it is not obvious that genericarm64 or qemuarm64 are directly reusable as guest MACHINEs as is, so further investigation is required on whether maintaining our own machine and potentially custom kernel metadata cache is perhaps worthwhile. Changes: - Update virtio-aarch64 linux-yocto bbappend for new version in scarthgap, and drop its use of a custom kernel metadata cache for reusing qemuarm64's BSP as a starting point for now. - Move the various virtio-*.cfg kernel configuration fragments over to meta-agl-core, using a new "agl-virtio-guest" AGL_FEATURES flag to control whether they are used. The aim is to make it more obvious where any virtio kernel configuration comes from and hopefully make it more easily reusable. Bug-AGL: SPEC-5137, SPEC-5201 Change-Id: I861cd1f80643aca632a5ab103eae2cc46de3922e Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/30098 ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jenkins Job builder account
Diffstat (limited to 'meta-agl-bsp/virtualization-layer/recipes-kernel/linux/linux-yocto_6.6.bbappend')
-rw-r--r--meta-agl-bsp/virtualization-layer/recipes-kernel/linux/linux-yocto_6.6.bbappend21
1 files changed, 5 insertions, 16 deletions
diff --git a/meta-agl-bsp/virtualization-layer/recipes-kernel/linux/linux-yocto_6.6.bbappend b/meta-agl-bsp/virtualization-layer/recipes-kernel/linux/linux-yocto_6.6.bbappend
index 6952436a3..15cb9ea98 100644
--- a/meta-agl-bsp/virtualization-layer/recipes-kernel/linux/linux-yocto_6.6.bbappend
+++ b/meta-agl-bsp/virtualization-layer/recipes-kernel/linux/linux-yocto_6.6.bbappend
@@ -1,17 +1,6 @@
-FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
-
-# Cannot just append to SRC_URI, as the metadata interferes with the
-# AGL config fragment scheme
-AGL_KERNEL_SRC:prepend:virtio-all = " \
- git://gerrit.automotivelinux.org/gerrit/src/agl-yocto-kernel-meta.git;protocol=https;type=kmeta;name=agl-meta;destsuffix=agl-kernel-meta;branch=kernel-5.15 \
- file://virtio-aarch64-${LINUX_KERNEL_TYPE}.scc \
-"
-
-SRCREV_agl-meta = "4deb7357eab5962b0553a5ad1f11be5ac35f9da9"
-
-AGL_KCONFIG_FRAGMENTS:append:virtio-all = " \
- virtio-drm.cfg \
- virtio-pci.cfg \
-"
-
+# NOTE: Has to be in bbappend itself because BitBake does not fully
+# parse recipes when checking it
COMPATIBLE_MACHINE:virtio-aarch64 = "virtio-aarch64"
+
+# Reuse base qemuarm64 machine to avoid needing our own kernel metadata
+KMACHINE:virtio-aarch64 = "qemuarm64" \ No newline at end of file