summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/virtualization-layer/recipes-kernel/linux/linux-yocto_6.6.bbappend
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-05-01 15:11:07 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-05-02 22:04:23 +0000
commit95051638dc19a49384ee8f0f9f1b468df49aca54 (patch)
tree1e0c903a5cd934c5b5b7626a905e7dfe023c8822 /meta-agl-bsp/virtualization-layer/recipes-kernel/linux/linux-yocto_6.6.bbappend
parent23841bb0e11260b7c2660be55c0de02c7d59f886 (diff)
meta-agl-bsp: update meta-virtualization bbappends
Rename the meta-virtualization dynamically applied bbappends to handle the newer versions in YP 5.0 / scarthgap. To some degree these changes are placeholders to facilitate building the IC EG container demo images, as the configuration for that pulls in meta-virtualization. The virtio support related changes the bbappends apply here need to be reworked to be actually workable for the KVM demo images and potential downstream users. Bug-AGL: SPEC-5123 Change-Id: I473fa4a64837cedd704f8fb2e7cbd52fa2114d21 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/29879 ci-image-build: Jenkins Job builder account Reviewed-by: Naoto YAMAGUCHI <naoto.yamaguchi@aisin.co.jp> Tested-by: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> ci-image-boot-test: Jenkins Job builder account
Diffstat (limited to 'meta-agl-bsp/virtualization-layer/recipes-kernel/linux/linux-yocto_6.6.bbappend')
-rw-r--r--meta-agl-bsp/virtualization-layer/recipes-kernel/linux/linux-yocto_6.6.bbappend17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-agl-bsp/virtualization-layer/recipes-kernel/linux/linux-yocto_6.6.bbappend b/meta-agl-bsp/virtualization-layer/recipes-kernel/linux/linux-yocto_6.6.bbappend
new file mode 100644
index 000000000..6952436a3
--- /dev/null
+++ b/meta-agl-bsp/virtualization-layer/recipes-kernel/linux/linux-yocto_6.6.bbappend
@@ -0,0 +1,17 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+
+# Cannot just append to SRC_URI, as the metadata interferes with the
+# AGL config fragment scheme
+AGL_KERNEL_SRC:prepend:virtio-all = " \
+ git://gerrit.automotivelinux.org/gerrit/src/agl-yocto-kernel-meta.git;protocol=https;type=kmeta;name=agl-meta;destsuffix=agl-kernel-meta;branch=kernel-5.15 \
+ file://virtio-aarch64-${LINUX_KERNEL_TYPE}.scc \
+"
+
+SRCREV_agl-meta = "4deb7357eab5962b0553a5ad1f11be5ac35f9da9"
+
+AGL_KCONFIG_FRAGMENTS:append:virtio-all = " \
+ virtio-drm.cfg \
+ virtio-pci.cfg \
+"
+
+COMPATIBLE_MACHINE:virtio-aarch64 = "virtio-aarch64"