aboutsummaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp
diff options
context:
space:
mode:
authorHarunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>2017-12-22 22:18:01 +0900
committerHarunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>2017-12-22 22:20:48 +0900
commitb43ba2a7419b4a94f36964b542e22dc752d1a2b0 (patch)
tree6c96f20d1ee0372354054b903e0cfc698785d95a /meta-agl-bsp
parent2c7cf28a8b9297648ff195d70cd3b410dff4086b (diff)
weston-ini-conf: Disable kingfisher's 2nd and 3rd output
Kingfisher has tree display output, currently AGL use only one output from micro HDMI. Change-Id: Ife61da4bfd2127a49c50247c26d8a7693960d439 Signed-off-by: Harunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>
Diffstat (limited to 'meta-agl-bsp')
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf.bbappend1
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf/kingfisher_output.cfg8
2 files changed, 9 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf.bbappend b/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf.bbappend
index 78be21187..c934e0c3b 100644
--- a/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf.bbappend
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf.bbappend
@@ -1,6 +1,7 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI += "${@bb.utils.contains("MACHINE_FEATURES", "multimedia", "file://v4l2-renderer.cfg", "",d)}"
+SRC_URI += "file://kingfisher_output.cfg"
do_configure() {
echo repaint-window=34 >> ${WORKDIR}/core.cfg
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf/kingfisher_output.cfg b/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf/kingfisher_output.cfg
new file mode 100644
index 000000000..a194a4a46
--- /dev/null
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf/kingfisher_output.cfg
@@ -0,0 +1,8 @@
+[output]
+name=HDMI-A-2
+mode=off
+
+[output]
+name=LVDS-1
+mode=off
+
177' href='#n177'>177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381
#
# This file is your local configuration file and is where all local user settings
# are placed. The comments in this file give some guide to the options a new user
# to the system might want to change but pretty much any configuration option can
# be set in this file. More adventurous users can look at local.conf.extended
# which contains other examples of configuration which can be placed in this file
# but new users likely won't need any of them initially.
#
# Lines starting with the '#' character are commented out and in some cases the
# default values are provided as comments to show people example syntax. Enabling
# the option is a question of removing the # character and making any change to the
# variable as required.

#
# Machine Selection
#
# You need to select a specific machine to target the build with. There are a selection
# of emulated machines available which can boot and run in the QEMU emulator:
#
#MACHINE ?= "qemuarm"
#MACHINE ?= "qemuarm64"
#MACHINE ?= "qemumips"
#MACHINE ?= "qemumips64"
#MACHINE ?= "qemuppc"
#MACHINE ?= "qemux86"
#MACHINE ?= "qemux86-64"
#
# There are also the following hardware board target machines included for 
# demonstration purposes:
#
#MACHINE ?= "beaglebone"
#MACHINE ?= "genericx86"
#MACHINE ?= "genericx86-64"
#MACHINE ?= "mpc8315e-rdb"
#MACHINE ?= "edgerouter"
#
# This sets the default machine to be qemux86 if no other machine is selected:
MACHINE ??= "ebisu"

#
# Where to place downloads
#
# During a first build the system will download many different source code tarballs
# from various upstream projects. This can take a while, particularly if your network
# connection is slow. These are all stored in DL_DIR. When wiping and rebuilding you
# can preserve this directory to speed up this part of subsequent builds. This directory
# is safe to share between multiple builds on the same machine too.
#
# The default is a downloads directory under TOPDIR which is the build directory.
#
#DL_DIR ?= "${TOPDIR}/downloads"

#
# Where to place shared-state files
#
# BitBake has the capability to accelerate builds based on previously built output.
# This is done using "shared state" files which can be thought of as cache objects
# and this option determines where those files are placed.
#
# You can wipe out TMPDIR leaving this directory intact and the build would regenerate
# from these files if no changes were made to the configuration. If changes were made
# to the configuration, only shared state files where the state was still valid would
# be used (done using checksums).
#
# The default is a sstate-cache directory under TOPDIR.
#
#SSTATE_DIR ?= "${TOPDIR}/sstate-cache"

#
# Where to place the build output
#
# This option specifies where the bulk of the building work should be done and
# where BitBake should place its temporary files and output. Keep in mind that
# this includes the extraction and compilation of many applications and the toolchain
# which can use Gigabytes of hard disk space.
#
# The default is a tmp directory under TOPDIR.
#
#TMPDIR = "${TOPDIR}/tmp"

#
# Default policy config
#
# The distribution setting controls which policy settings are used as defaults.
# The default value is fine for general Yocto project use, at least initially.
# Ultimately when creating custom policy, people will likely end up subclassing 
# these defaults.
#
DISTRO ?= "poky"
# As an example of a subclass there is a "bleeding" edge policy configuration
# where many versions are set to the absolute latest code from the upstream 
# source control systems. This is just mentioned here as an example, its not
# useful to most new users.
# DISTRO ?= "poky-bleeding"

#
# Package Management configuration
#
# This variable lists which packaging formats to enable. Multiple package backends
# can be enabled at once and the first item listed in the variable will be used
# to generate the root filesystems.
# Options are:
#  - 'package_deb' for debian style deb files
#  - 'package_ipk' for ipk files are used by opkg (a debian style embedded package manager)
#  - 'package_rpm' for rpm style packages
# E.g.: PACKAGE_CLASSES ?= "package_rpm package_deb package_ipk"
# We default to rpm:
PACKAGE_CLASSES ?= "package_rpm"

#
# SDK target architecture
#
# This variable specifies the architecture to build SDK items for and means
# you can build the SDK packages for architectures other than the machine you are
# running the build on (i.e. building i686 packages on an x86_64 host).
# Supported values are i686 and x86_64
#SDKMACHINE ?= "i686"

#
# Extra image configuration defaults
#
# The EXTRA_IMAGE_FEATURES variable allows extra packages to be added to the generated
# images. Some of these options are added to certain image types automatically. The
# variable can contain the following options:
#  "dbg-pkgs"       - add -dbg packages for all installed packages
#                     (adds symbol information for debugging/profiling)
#  "dev-pkgs"       - add -dev packages for all installed packages
#                     (useful if you want to develop against libs in the image)
#  "ptest-pkgs"     - add -ptest packages for all ptest-enabled packages
#                     (useful if you want to run the package test suites)
#  "tools-sdk"      - add development tools (gcc, make, pkgconfig etc.)
#  "tools-debug"    - add debugging tools (gdb, strace)
#  "eclipse-debug"  - add Eclipse remote debugging support
#  "tools-profile"  - add profiling tools (oprofile, lttng, valgrind)
#  "tools-testapps" - add useful testing tools (ts_print, aplay, arecord etc.)
#  "debug-tweaks"   - make an image suitable for development
#                     e.g. ssh root access has a blank password
# There are other application targets that can be used here too, see
# meta/classes/image.bbclass and meta/classes/core-image.bbclass for more details.
# We default to enabling the debugging tweaks.
EXTRA_IMAGE_FEATURES ?= "debug-tweaks"

#
# Additional image features
#
# The following is a list of additional classes to use when building images which
# enable extra features. Some available options which can be included in this variable
# are:
#   - 'buildstats' collect build statistics
#   - 'image-mklibs' to reduce shared library files size for an image
#   - 'image-prelink' in order to prelink the filesystem image
# NOTE: if listing mklibs & prelink both, then make sure mklibs is before prelink
# NOTE: mklibs also needs to be explicitly enabled for a given image, see local.conf.extended
USER_CLASSES ?= "buildstats image-mklibs image-prelink"

#
# Runtime testing of images
#
# The build system can test booting virtual machine images under qemu (an emulator)
# after any root filesystems are created and run tests against those images. To
# enable this uncomment this line. See classes/testimage(-auto).bbclass for
# further details.
#TEST_IMAGE = "1"
#
# Interactive shell configuration
#
# Under certain circumstances the system may need input from you and to do this it
# can launch an interactive shell. It needs to do this since the build is
# multithreaded and needs to be able to handle the case where more than one parallel
# process may require the user's attention. The default is iterate over the available
# terminal types to find one that works.
#
# Examples of the occasions this may happen are when resolving patches which cannot
# be applied, to use the devshell or the kernel menuconfig
#
# Supported values are auto, gnome, xfce, rxvt, screen, konsole (KDE 3.x only), none
# Note: currently, Konsole support only works for KDE 3.x due to the way
# newer Konsole versions behave
#OE_TERMINAL = "auto"
# By default disable interactive patch resolution (tasks will just fail instead):
PATCHRESOLVE = "noop"

#
# Disk Space Monitoring during the build
#
# Monitor the disk space during the build. If there is less that 1GB of space or less
# than 100K inodes in any key build location (TMPDIR, DL_DIR, SSTATE_DIR), gracefully
# shutdown the build. If there is less that 100MB or 1K inodes, perform a hard abort
# of the build. The reason for this is that running completely out of space can corrupt
# files and damages the build in ways which may not be easily recoverable.
# It's necesary to monitor /tmp, if there is no space left the build will fail
# with very exotic errors.
BB_DISKMON_DIRS ??= "\
    STOPTASKS,${TMPDIR},1G,100K \
    STOPTASKS,${DL_DIR},1G,100K \
    STOPTASKS,${SSTATE_DIR},1G,100K \
    STOPTASKS,/tmp,100M,100K \
    ABORT,${TMPDIR},100M,1K \
    ABORT,${DL_DIR},100M,1K \
    ABORT,${SSTATE_DIR},100M,1K \
    ABORT,/tmp,10M,1K"

#
# Shared-state files from other locations
#
# As mentioned above, shared state files are prebuilt cache data objects which can
# used to accelerate build time. This variable can be used to configure the system
# to search other mirror locations for these objects before it builds the data itself.
#
# This can be a filesystem directory, or a remote url such as http or ftp. These
# would contain the sstate-cache results from previous builds (possibly from other
# machines). This variable works like fetcher MIRRORS/PREMIRRORS and points to the
# cache locations to check for the shared objects.
# NOTE: if the mirror uses the same structure as SSTATE_DIR, you need to add PATH
# at the end as shown in the examples below. This will be substituted with the
# correct path within the directory structure.
#SSTATE_MIRRORS ?= "\
#file://.* http://someserver.tld/share/sstate/PATH;downloadfilename=PATH \n \
#file://.* file:///some/local/dir/sstate/PATH"


#
# Qemu configuration
#
# By default qemu will build with a builtin VNC server where graphical output can be
# seen. The two lines below enable the SDL backend too. By default libsdl-native will
# be built, if you want to use your host's libSDL instead of the minimal libsdl built
# by libsdl-native then uncomment the ASSUME_PROVIDED line below.
PACKAGECONFIG_append_pn-qemu-native = " sdl"
PACKAGECONFIG_append_pn-nativesdk-qemu = " sdl"
#ASSUME_PROVIDED += "libsdl-native"

# CONF_VERSION is increased each time build/conf/ changes incompatibly and is used to
# track the version of this file when it was generated. This can safely be ignored if
# this doesn't mean anything to you.
CONF_VERSION = "1"

# Add systemd configuration
DISTRO_FEATURES_append = " systemd"
VIRTUAL-RUNTIME_init_manager = "systemd"

# Linaro GCC
GCCVERSION = "linaro-7.2"

# add the static lib to SDK toolchain
SDKIMAGE_FEATURES_append = " staticdev-pkgs"

# Disable optee in meta-linaro layer
BBMASK = "meta-linaro/meta-optee/recipes-security/optee"

# Enable Gfx Pkgs
MACHINE_FEATURES_append = " gsx"
MULTI_PROVIDER_WHITELIST += "virtual/libgl virtual/egl virtual/libgles1 virtual/libgles2"

# for Wayland/Weston
DISTRO_FEATURES_NATIVESDK_append = " wayland"
DISTRO_FEATURES_append = " pam"
PREFERRED_PROVIDER_virtual/libgles1 = ""
PREFERRED_PROVIDER_virtual/libgles2 = "gles-user-module"
PREFERRED_PROVIDER_virtual/egl = "libegl"
PREFERRED_PROVIDER_virtual/libgl = ""
PREFERRED_PROVIDER_virtual/mesa = ""
PREFERRED_PROVIDER_libgbm = "libgbm"
PREFERRED_PROVIDER_libgbm-dev = "libgbm"
BBMASK .= "|mesa-gl"

# Enable Multimedia features
MACHINE_FEATURES_append = " multimedia"

# for gstreamer omx plugins
LICENSE_FLAGS_WHITELIST = "commercial"
# for mmp test program
DISTRO_FEATURES_append = " mm-test"

# for weston v4l2 renderer
#DISTRO_FEATURES_append = " v4l2-renderer"

# OMX H263 decoder library for Linux (RTM0AC0000XV263D30SL41C)
#DISTRO_FEATURES_append = " h263dec_lib"

# OMX H264 decoder library for Linux (RTM0AC0000XV264D30SL41C)
DISTRO_FEATURES_append = " h264dec_lib"

# OMX H264 encoder library for Linux (RTM0AC0000XV264E30SL41C)
#DISTRO_FEATURES_append = " h264enc_lib"

# OMX H265 decoder library for Linux (RTM0AC0000XV265D30SL41C)
#DISTRO_FEATURES_append = " h265dec_lib"

# OMX MPEG2 decoder library for Linux (RTM0AC0000XVM2VD30SL41C)
#DISTRO_FEATURES_append = " mpeg2dec_lib"

# OMX Media Component MPEG4 Decoder Library for Linux (RTM0AC0000XVM4VD30SL41C)
#DISTRO_FEATURES_append = " mpeg4dec_lib"

# OMX Media Component VC-1 Decoder Library for Linux (RTM0AC0000XVVC1D30SL41C)
#DISTRO_FEATURES_append = " vc1dec_lib"

# OMX Media Component DivXD Decoder Library for Linux (RTM0AC0000XVDVXD30SL41C)
#DISTRO_FEATURES_append = " divxdec_lib"

# OMX Media Component RealVideo Decoder Library for Linux (RTM0AC0000XVRLVD30SL41C)
#DISTRO_FEATURES_append = " rvdec_lib"

# OMX Media Component ALAC Decoder Library for Linux (RTM0AC0000XAALAD30SL41C)
#DISTRO_FEATURES_append = " alacdec_lib"

# OMX Media Component FLAC Decoder Library for Linux (RTM0AC0000XAFLAD30SL41C)
#DISTRO_FEATURES_append = " flacdec_lib"

# OMX AAC-LC decoder library for Linux (RTM0AC0000XAAACD30SL41C),
# AAC-LC 2ch decoder middleware library for Linux (RTM0AC0000ADAACMZ1SL41C)
DISTRO_FEATURES_append = " aaclcdec_lib"
DISTRO_FEATURES_append = " aaclcdec_mdw"

# OMX aacPlus V2 decoder library for Linux (RTM0AC0000XAAAPD30SL41C),
# aacPlus V2 decoder middleware library for Linux (RTM0AC0000ADAAPMZ1SL41C)
#DISTRO_FEATURES_append = " aacpv2dec_lib"
#DISTRO_FEATURES_append = " aacpv2dec_mdw"

# OMX MP3 decoder library for Linux (RTM0AC0000XAMP3D30SL41C),
# MP3 decoder middleware library for Linux (RTM0AC0000ADMP3MZ1SL41C)
#DISTRO_FEATURES_append = " mp3dec_lib"
#DISTRO_FEATURES_append = " mp3dec_mdw"

# OMX WMA decoder library for Linux (RTM0AC0000XAWMAD30SL41C),
# WMA decoder middleware library for Linux (RTM0AC0000ADWMAMZ1SL41C)
#DISTRO_FEATURES_append = " wmadec_lib"
#DISTRO_FEATURES_append = " wmadec_mdw"

# OMX AAC-LC encoder library for Linux (RTM0AC0000XAAACE30SL41C)
# AAC-LC encoder middleware library for Linux (RTM0AC0000AEAACMZ1SL41C)
#DISTRO_FEATURES_append = " aaclcenc_lib"
#DISTRO_FEATURES_append = " aaclcenc_mdw"

# OMX Dolby(R) Digital decoder library for Linux (RTM0AC0000XADD5D30SL41C),
# Dolby(R) Digital decoder middleware library for Linux (RTM0AC0000ADDD5MZ1SL41C)
#DISTRO_FEATURES_append = " dddec_lib"
#DISTRO_FEATURES_append = " dddec_mdw"

# OMX Media Component VP8 Decoder Library for Linux (RTM0AC0000XVVP8D30SL41C)
#DISTRO_FEATURES_append = " vp8dec_lib"

# OMX Media Component VP8 Encoder Library for Linux (RTM0AC0000XVVP8E30SL41C)
#DISTRO_FEATURES_append = " vp8enc_lib"

# OMX Media Component VP9 Decoder Library for Linux (RTM0AC0000XVVP9D30SL41C)
#DISTRO_FEATURES_append = " vp9dec_lib"

# CMS Basic Color Management Middleware for Linux (RTM0AC0000JRCMBCV0SL41C)
#DISTRO_FEATURES_append = " cmsbcm"

# CMS CMM3 Backlight Control Middleware for Linux (RTM0AC0000JRCMBLC0SL41C)
#DISTRO_FEATURES_append = " cmsblc"

# CMS VSP2 Dynamic Gamma Correction Middleware for Linux (RTM0AC0000JRCMDGV0SL41C)
#DISTRO_FEATURES_append = " cmsdgc"

# DVD Core-Middleware for Linux (RTM0RC0000XDVDC301SL41C)
#DISTRO_FEATURES_append = " dvd"

# ADSP Driver for Linux (RCG3AHPDL4101ZDO)
# ADSP Interface for Linux (RCG3AHIFL4101ZDP)
# ADSP Framework (RCG3AHFWN0201ZDP)
#DISTRO_FEATURES_append = " adsp"

# AVB Software Package for Linux
#DISTRO_FEATURES_append = " avb"

# Linux ICCOM driver (RCG3ZLIDL4101ZNO)
# Linux ICCOM library (RCG3ZLILL4101ZNO)
#DISTRO_FEATURES_append = " iccom"

# Evaluation packages
#DISTRO_FEATURES_append = " use_eva_pkg"

# Configuration for ivi-shell and ivi-extension
#DISTRO_FEATURES_append = " ivi-shell"

# Configuration for USB 3.0
#MACHINE_FEATURES_append = " usb3"