summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp
diff options
context:
space:
mode:
authorKarthik Ramanan <a0393906@ti.com>2016-11-18 13:23:25 +0530
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-11-21 11:39:46 +0000
commitd68b2906870f459c1ef1dcbcc5be7e0643f3a656 (patch)
tree89d06ea1888059da6fddb71b276de1cb0ff564b7 /meta-agl-bsp
parent698aed6cc037a47d6f709b18881e4ba41a3044e7 (diff)
dra7xx-evm: u-boot: Fix SRCREV + mmc stability fix
The latest u-boot has included some patches that is causing an instability with certain MMC cards This patch fixes the SRCREV to a known commit and includes a stability fix for the MMC Change-Id: I7ba99d36bd713d81409d528e8067e012415b33f0 Signed-off-by: Karthik Ramanan <a0393906@ti.com>
Diffstat (limited to 'meta-agl-bsp')
-rw-r--r--meta-agl-bsp/meta-ti/recipes-bsp/u-boot/files/0001-mmc-disable-the-mmc-clock-during-power-off.patch29
-rw-r--r--meta-agl-bsp/meta-ti/recipes-bsp/u-boot/u-boot-ti-staging_%.bbappend3
2 files changed, 31 insertions, 1 deletions
diff --git a/meta-agl-bsp/meta-ti/recipes-bsp/u-boot/files/0001-mmc-disable-the-mmc-clock-during-power-off.patch b/meta-agl-bsp/meta-ti/recipes-bsp/u-boot/files/0001-mmc-disable-the-mmc-clock-during-power-off.patch
new file mode 100644
index 000000000..3be8dc744
--- /dev/null
+++ b/meta-agl-bsp/meta-ti/recipes-bsp/u-boot/files/0001-mmc-disable-the-mmc-clock-during-power-off.patch
@@ -0,0 +1,29 @@
+From 96d42df4e7cb700bde4bdf5106cfd2753749c4e7 Mon Sep 17 00:00:00 2001
+From: Kishon Vijay Abraham I <kishon@ti.com>
+Date: Fri, 11 Nov 2016 19:59:22 +0530
+Subject: [PATCH] mmc: disable the mmc clock during power off
+
+There is no point in having the mmc clock enabled during
+power off. Disable the mmc clock. This is similar to how it's
+programmed in Linux Kernel.
+
+Signed-off-by: Kishon Vijay Abraham I <kishon@ti.com>
+---
+ drivers/mmc/mmc.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/drivers/mmc/mmc.c b/drivers/mmc/mmc.c
+index c929a1e..84515a7 100644
+--- a/drivers/mmc/mmc.c
++++ b/drivers/mmc/mmc.c
+@@ -2058,6 +2058,7 @@ static void mmc_power_off(struct mmc *mmc)
+ {
+ mmc_set_signal_voltage(mmc, 0);
+ mmc_set_vdd(mmc, false);
++ mmc_set_clock(mmc, 1, true);
+ }
+
+ static void mmc_power_cycle(struct mmc *mmc)
+--
+1.9.1
+
diff --git a/meta-agl-bsp/meta-ti/recipes-bsp/u-boot/u-boot-ti-staging_%.bbappend b/meta-agl-bsp/meta-ti/recipes-bsp/u-boot/u-boot-ti-staging_%.bbappend
index 77b84f990..8f4402bac 100644
--- a/meta-agl-bsp/meta-ti/recipes-bsp/u-boot/u-boot-ti-staging_%.bbappend
+++ b/meta-agl-bsp/meta-ti/recipes-bsp/u-boot/u-boot-ti-staging_%.bbappend
@@ -1,12 +1,13 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-SRCREV = "${AUTOREV}"
+SRCREV = "7e76f5e6781205bbdf4ec53aa6671b30856a33e7"
BRANCH = "p-ti-u-boot-2016.05"
SRC_URI = "git://git.omapzoom.org/repo/u-boot.git;protocol=git;branch=${BRANCH}"
# This applies to the JACINTO 6 vayu board ... essentially it is dra7_evm.
SRC_URI_vayu += "file://fix_builderror_gcc5.patch"
SRC_URI += " file://${UBOOT_ENV_BINARY}"
+SRC_URI += " file://0001-mmc-disable-the-mmc-clock-during-power-off.patch"
UBOOT_ENV = "uEnv"
italic } /* Name.Label */ .highlight .nn { color: #bb0066; font-weight: bold } /* Name.Namespace */ .highlight .py { color: #336699; font-weight: bold } /* Name.Property */ .highlight .nt { color: #bb0066; font-weight: bold } /* Name.Tag */ .highlight .nv { color: #336699 } /* Name.Variable */ .highlight .ow { color: #008800 } /* Operator.Word */ .highlight .w { color: #bbbbbb } /* Text.Whitespace */ .highlight .mb { color: #0000DD; font-weight: bold } /* Literal.Number.Bin */ .highlight .mf { color: #0000DD; font-weight: bold } /* Literal.Number.Float */ .highlight .mh { color: #0000DD; font-weight: bold } /* Literal.Number.Hex */ .highlight .mi { color: #0000DD; font-weight: bold } /* Literal.Number.Integer */ .highlight .mo { color: #0000DD; font-weight: bold } /* Literal.Number.Oct */ .highlight .sa { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Affix */ .highlight .sb { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Backtick */ .highlight .sc { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Char */ .highlight .dl { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Delimiter */ .highlight .sd { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Doc */ .highlight .s2 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Double */ .highlight .se { color: #0044dd; background-color: #fff0f0 } /* Literal.String.Escape */ .highlight .sh { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Heredoc */ .highlight .si { color: #3333bb; background-color: #fff0f0 } /* Literal.String.Interpol */ .highlight .sx { color: #22bb22; background-color: #f0fff0 } /* Literal.String.Other */ .highlight .sr { color: #008800; background-color: #fff0ff } /* Literal.String.Regex */ .highlight .s1 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Single */ .highlight .ss { color: #aa6600; background-color: #fff0f0 } /* Literal.String.Symbol */ .highlight .bp { color: #003388 } /* Name.Builtin.Pseudo */ .highlight .fm { color: #0066bb; font-weight: bold } /* Name.Function.Magic */ .highlight .vc { color: #336699 } /* Name.Variable.Class */ .highlight .vg { color: #dd7700 } /* Name.Variable.Global */ .highlight .vi { color: #3333bb } /* Name.Variable.Instance */ .highlight .vm { color: #336699 } /* Name.Variable.Magic */ .highlight .il { color: #0000DD; font-weight: bold } /* Literal.Number.Integer.Long */ }
#!/usr/bin/make -f
# Copyright (C) 2015 - 2018 "IoT.bzh"
# Author "Romain Forlot" <romain.forlot@iot.bzh>
#
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
# You may obtain a copy of the License at
#
#	 http://www.apache.org/licenses/LICENSE-2.0
#
# Unless required by applicable law or agreed to in writing, software
# distributed under the License is distributed on an "AS IS" BASIS,
# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
# See the License for the specific language governing permissions and
# limitations under the License.

THISFILE  := $(lastword $(MAKEFILE_LIST))
BUILD_DIR := $(abspath $(dir $(THISFILE))/../../build)
BUILD_DIR_TEST     := $(abspath $(dir $(THISFILE))/../../build-test)
BUILD_DIR_DEBUG    := $(abspath $(dir $(THISFILE))/../../build-debug)
BUILD_DIR_COVERAGE := $(abspath $(dir $(THISFILE))/../../build-coverage)
BUILD_DIR_DEBUG_TEST    := $(abspath $(dir $(THISFILE))/../../build-debug-test)
BUILD_DIR_COVERAGE_TEST := $(abspath $(dir $(THISFILE))/../../build-coverage-test)
DEST      := ${BUILD_DIR}

.PHONY: all clean distclean configure build package help

all: help

help:
	@echo "List of targets available:"
	@echo ""
	@echo "- all"
	@echo "- clean"
	@echo "- distclean"
	@echo "- configure"
	@echo "- build: compilation, link and prepare files for package into a widget"
	@echo "- package: output a widget file '*.wgt'"
	@echo "- install: install in your defined DEST directory"
	@echo ""
	@echo "Usage: ./autobuild/agl/autobuild package DEST=${HOME}/opt"
	@echo "Don't use your build dir as DEST as wgt file is generated at this location"

clean:
	@([ -d ${BUILD_DIR} ] && make -C ${BUILD_DIR} ${CLEAN_ARGS} clean) || echo Nothing to clean

distclean:
	@[ -d ${DEST} ] && find ${DEST} -name "*.wgt" -delete
	@([ -d ${BUILD_DIR} ] && make -C ${BUILD_DIR} distclean) || echo Nothing to distclean

configure:
	@[ -d ${BUILD_DIR} ] || mkdir -p ${BUILD_DIR}
	@[ -f ${BUILD_DIR}/Makefile ] || (cd ${BUILD_DIR} && qmake ${CONFIGURE_ARGS} ..)

configure-test:
	@[ -d ${BUILD_DIR_TEST} ] || mkdir -p ${BUILD_DIR_TEST}
	@[ -f ${BUILD_DIR_TEST}/Makefile ] || (cd ${BUILD_DIR_TEST} && qmake ${CONFIGURE_ARGS} ..)

configure-debug:
	@[ -d ${BUILD_DIR_DEBUG} ] || mkdir -p ${BUILD_DIR_DEBUG}
	@[ -f ${BUILD_DIR_DEBUG}/Makefile ] || (cd ${BUILD_DIR_DEBUG} && qmake ${CONFIGURE_ARGS} ..)

configure-coverage:
	@[ -d ${BUILD_DIR_COVERAGE} ] || mkdir -p ${BUILD_DIR_COVERAGE}
	@[ -f ${BUILD_DIR_COVERAGE}/Makefile ] || (cd ${BUILD_DIR_COVERAGE} && qmake ${CONFIGURE_ARGS} ..)
build: configure
	@make -C ${BUILD_DIR} ${BUILD_ARGS} all
build-test: configure-test
	@make -C ${BUILD_DIR_TEST} ${BUILD_ARGS} all

build-debug: configure-debug
	@make -C ${BUILD_DIR_DEBUG} ${BUILD_ARGS} all

build-coverage: configure-coverage
	@make -C ${BUILD_DIR_COVERAGE} ${BUILD_ARGS} all

install: build
	@make -C ${BUILD_DIR} ${INSTALL_ARGS} install

package: build
	@if [ "${DEST}" != "${BUILD_DIR}/$@" ]; then \
		mkdir -p ${DEST} && cp ${BUILD_DIR}/$@/*.wgt ${DEST}; \
	fi

package-test: build-test
	@if [ "${DEST}" != "${BUILD_DIR_TEST}" ]; then \
		mkdir -p ${DEST} && cp ${BUILD_DIR_TEST}/package/*.wgt ${DEST}; \
	fi

package-debug: build-debug
	@if [ "${DEST}" != "${BUILD_DIR_DEBUG}" ]; then \
		mkdir -p ${DEST} && cp ${BUILD_DIR_DEBUG}/package/*.wgt ${DEST}; \
	fi

package-coverage: build-coverage
	@if [ "${DEST}" != "${BUILD_DIR_COVERAGE}" ]; then \
		mkdir -p ${DEST} && cp ${BUILD_DIR_COVERAGE}/package/*.wgt ${DEST}; \
	fi

package-all: package package-test package-coverage package-debug