summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp
diff options
context:
space:
mode:
authorTom Rini <trini@konsulko.com>2017-10-16 20:27:32 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-10-18 13:04:36 +0000
commit193349f450db0b78e6a987d9c979945c48e2a542 (patch)
tree1f7aeac620e51e6d9e68ee321ccf477287d0f77e /meta-agl-bsp
parent321a41a7cae61d074e686cc9966f6774a3f45b9e (diff)
weston-ini-conf: Fix task signatures, mark as machine-specific package
We need to do two things here. First, bitbake does not know to track values that are found and used via getVarFlags() without them being otherwise refernced and tracked in ways that are otherwise caught. Further given that we use multiple levels of varflags here we need to be explicit in their tracking. Add all variables that we use to varflags where they are added to the metadata. This change comes directly from master. The second thing is that we need to tell bitbake/OpenEmbedded that this is a machine-specific package not architecture-generic. Bug-AGL: SPEC-965 Change-Id: I748dbf40f37aaf7f4a6dd6ddd65257fdfcf83098 Signed-off-by: Tom Rini <trini@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/11355 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-bsp')
-rw-r--r--meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston-ini-conf.bbappend1
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf.bbappend2
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf.bbappend2
-rw-r--r--meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston-ini-conf.bbappend2
4 files changed, 7 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston-ini-conf.bbappend b/meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston-ini-conf.bbappend
index e736dddd2..14f4c2736 100644
--- a/meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston-ini-conf.bbappend
+++ b/meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston-ini-conf.bbappend
@@ -7,3 +7,4 @@ SCREEN_fbdev[name] = "fbdev"
SCREEN_fbdev[transform] = "270"
WESTONOUTPUT1[agl_screen] = "SCREEN_fbdev"
+do_generate_weston_init[vardeps] += "SCREEN_fbdev"
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf.bbappend
index 14b858d45..37383c24d 100644
--- a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf.bbappend
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf.bbappend
@@ -2,3 +2,5 @@
WESTONOUTPUT2[agl_screen] ??= "SCREEN_DSI"
WESTONSECTION[WESTONOUTPUT2] = "output"
+
+do_generate_weston_init[vardeps] += "WESTONOUTPUT2"
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf.bbappend b/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf.bbappend
index e46b10ef7..661af2b92 100644
--- a/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf.bbappend
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf.bbappend
@@ -10,3 +10,5 @@ python() {
if "multimedia" in d.getVar("MACHINE_FEATURES", True).split(" "):
d.setVarFlag("WESTONSECTION", "WESTONV4L2RENDERER", "v4l2-renderer")
}
+
+do_generate_weston_init[vardeps] += "WESTONIVISHELL WESTONV4L2RENDERER"
diff --git a/meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston-ini-conf.bbappend b/meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston-ini-conf.bbappend
index 7a54dfbe4..4a049482e 100644
--- a/meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston-ini-conf.bbappend
+++ b/meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston-ini-conf.bbappend
@@ -3,3 +3,5 @@ WESTONOUTPUT2[name] = "LVDS-1"
WESTONOUTPUT2[mode] = "off"
WESTONSECTION[WESTONOUTPUT2] = "output"
+
+do_generate_weston_init[vardeps] += "WESTONOUTPUT2"