aboutsummaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp
diff options
context:
space:
mode:
authortte_zheng_wenlong <wenlong_zheng_za@mail.toyota.co.jp>2017-03-15 13:25:26 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-03-17 21:51:14 +0000
commite1a7d95053b7f19a2a7d9bf4da7625a4154c57e3 (patch)
treea26843266f3701d0a44dfaa346c879a7c4f7228b /meta-agl-bsp
parent2c41fccae6bd195cb035e96f8feda9f0c73cdf1f (diff)
Add kernel config for uart bluetooth device support
Change-Id: Idb61c0f1f52ca9fb6b1afd50e4a397678971f6e5 Signed-off-by: tte_zheng_wenlong <wenlong_zheng_za@mail.toyota.co.jp>
Diffstat (limited to 'meta-agl-bsp')
-rwxr-xr-xmeta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto/hciattach.cfg17
-rwxr-xr-xmeta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto_%.bbappend5
-rwxr-xr-xmeta-agl-bsp/meta-renesas/recipes-kernel/linux/linux-renesas_%.bbappend1
-rwxr-xr-xmeta-agl-bsp/meta-renesas/recipes-kernel/linux/linux/hciattach.cfg9
4 files changed, 32 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto/hciattach.cfg b/meta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto/hciattach.cfg
new file mode 100755
index 000000000..c9c4fe2ed
--- /dev/null
+++ b/meta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto/hciattach.cfg
@@ -0,0 +1,17 @@
+#
+# Bluetooth device drivers
+#
+CONFIG_BT_INTEL=m
+CONFIG_BT_BCM=m
+CONFIG_BT_RTL=m
+CONFIG_BT_HCIBTUSB=m
+CONFIG_BT_HCIBTUSB_BCM=y
+CONFIG_BT_HCIBTUSB_RTL=y
+CONFIG_BT_HCIUART=m
+CONFIG_BT_HCIUART_H4=y
+CONFIG_BT_HCIUART_BCSP=y
+
+#
+# USB port drivers
+#
+CONFIG_USB_SERIAL_CP210X=y
diff --git a/meta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto_%.bbappend b/meta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto_%.bbappend
new file mode 100755
index 000000000..99c9581b2
--- /dev/null
+++ b/meta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto_%.bbappend
@@ -0,0 +1,5 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/linux-yocto:"
+
+# Extra configuration options for the QEMU kernel
+SRC_URI += "file://hciattach.cfg \
+ "
diff --git a/meta-agl-bsp/meta-renesas/recipes-kernel/linux/linux-renesas_%.bbappend b/meta-agl-bsp/meta-renesas/recipes-kernel/linux/linux-renesas_%.bbappend
index 7da3e5c8a..ad297bec0 100755
--- a/meta-agl-bsp/meta-renesas/recipes-kernel/linux/linux-renesas_%.bbappend
+++ b/meta-agl-bsp/meta-renesas/recipes-kernel/linux/linux-renesas_%.bbappend
@@ -11,6 +11,7 @@ SRC_URI += " file://disable_delay_printk.patch \
file://0001-media-r820t-do-not-double-free-fe-tuner_priv-in-r820.patch \
file://0002-media-r820t-remove-redundant-initializations-in-r820.patch \
file://0003-media-r820t-avoid-potential-memcpy-buffer-overflow-i.patch \
+ file://hciattach.cfg \
"
KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/ath9k_htc.cfg ${WORKDIR}/rtl_sdr.cfg"
diff --git a/meta-agl-bsp/meta-renesas/recipes-kernel/linux/linux/hciattach.cfg b/meta-agl-bsp/meta-renesas/recipes-kernel/linux/linux/hciattach.cfg
new file mode 100755
index 000000000..95ee2d7fc
--- /dev/null
+++ b/meta-agl-bsp/meta-renesas/recipes-kernel/linux/linux/hciattach.cfg
@@ -0,0 +1,9 @@
+CONFIG_BT_HCIUART=m
+CONFIG_BT_HCIUART_H4=y
+CONFIG_BT_HCIUART_BCSP=y
+CONFIG_BT_HCIUART_ATH3K=y
+CONFIG_BT_HCIUART_LL=y
+CONFIG_BT_HCIUART_3WIRE=y
+CONFIG_USB_SERIAL=y
+CONFIG_USB_SERIAL_GENERIC=y
+CONFIG_USB_SERIAL_CP210X=y
color: #3333bb } /* Name.Variable.Instance */ .highlight .vm { color: #336699 } /* Name.Variable.Magic */ .highlight .il { color: #0000DD; font-weight: bold } /* Literal.Number.Integer.Long */ }
From 5abb2b497e0153210d41ec3685dc0152587625fa Mon Sep 17 00:00:00 2001
From: Rajendraprasad K J <KarammelJayakumar.Rajendraprasad@in.bosch.com>
Date: Mon, 6 Jan 2020 06:45:11 -0500
Subject: [PATCH] ivi-id-agent: update to weston 7 header files

update the header file path.

Upstream-Status: Submitted [https://github.com/GENIVI/wayland-ivi-extension/pull/110]

Signed-off-by: Rajendraprasad K J <KarammelJayakumar.Rajendraprasad@in.bosch.com>
Signed-off-by: Gowtham Tammana <g-tammana@ti.com>
---
 ivi-id-agent-modules/ivi-id-agent/src/ivi-id-agent.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/ivi-id-agent-modules/ivi-id-agent/src/ivi-id-agent.c b/ivi-id-agent-modules/ivi-id-agent/src/ivi-id-agent.c
index 8f0c199..b80e2a4 100644
--- a/ivi-id-agent-modules/ivi-id-agent/src/ivi-id-agent.c
+++ b/ivi-id-agent-modules/ivi-id-agent/src/ivi-id-agent.c
@@ -26,8 +26,8 @@
 #include <limits.h>
 
 #include <weston.h>
-#include <libweston-6/libweston-desktop.h>
-#include "config-parser.h"
+#include <libweston-desktop/libweston-desktop.h>
+#include <libweston/config-parser.h>
 #include <weston/ivi-layout-export.h>
 
 #ifndef INVALID_ID