aboutsummaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-06-12 15:34:43 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-06-20 10:54:04 +0000
commit7e6f5bb94352ac0b6cd5c5cdd3035eec6c6bc559 (patch)
tree95ce7540453cb447fdde679d54df91694228d732 /meta-agl-bsp
parent45edb36ac263a9c09ab9d3964cc58b648ed82af0 (diff)
Add cubox-i and nitrogen6x i.MX6 machines
Add the cubox-i (covering SolidRun Cubox-i, Hummingboard Gate and Edge), and nitrogen6x (covering Nitrogen 6x and SABRE Lite) machine definitions. Note that support for the Broadcom Bluetooth chipset on the SolidRun i.MX6 SOM is currently missing, as it requires firmware that is not available in either the linux-firmware package or from the firmware packages provided by meta-freescale. Bug-AGL: SPEC-2517 Change-Id: If7bdb9f1af9bb67dba5c1ff836a6d3b04160fefd Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'meta-agl-bsp')
-rw-r--r--meta-agl-bsp/conf/include/agl_cubox-i.inc22
-rw-r--r--meta-agl-bsp/conf/include/agl_nitrogen6x.inc17
-rw-r--r--meta-agl-bsp/meta-freescale-layer/recipes-kernel/linux/linux-fslc_%.bbappend5
3 files changed, 44 insertions, 0 deletions
diff --git a/meta-agl-bsp/conf/include/agl_cubox-i.inc b/meta-agl-bsp/conf/include/agl_cubox-i.inc
new file mode 100644
index 000000000..a82c27cc1
--- /dev/null
+++ b/meta-agl-bsp/conf/include/agl_cubox-i.inc
@@ -0,0 +1,22 @@
+DISTRO_FEATURES_append = " agl-medium-arm-compiler"
+
+# This disables the Freescale/NXP Vivante GPU driver and enables
+# etnaviv support.
+MACHINEOVERRIDES .= ":use-mainline-bsp"
+
+# Include devicetrees for SOM 1.5 and Hummingboard 2 hardware
+KERNEL_DEVICETREE_append = " \
+ imx6dl-hummingboard-som-v15.dtb imx6q-hummingboard-som-v15.dtb \
+ imx6dl-hummingboard2.dtb imx6q-hummingboard2.dtb \
+ imx6dl-hummingboard2-som-v15.dtb imx6q-hummingboard2-som-v15.dtb \
+"
+
+# Disable the meta-freescale weston-init bbappend as it conflicts
+# with AGL's.
+BBMASK = "meta-freescale/recipes-graphics/wayland/weston-init"
+
+# Set CMA size large enough to work with AGL
+UBOOT_EXTLINUX_KERNEL_ARGS_append = " cma=512M"
+
+# Generate WIC image also
+AGL_EXTRA_IMAGE_FSTYPES = "wic.xz wic.bmap wic.xz.sha256sum"
diff --git a/meta-agl-bsp/conf/include/agl_nitrogen6x.inc b/meta-agl-bsp/conf/include/agl_nitrogen6x.inc
new file mode 100644
index 000000000..782e618a2
--- /dev/null
+++ b/meta-agl-bsp/conf/include/agl_nitrogen6x.inc
@@ -0,0 +1,17 @@
+DISTRO_FEATURES_append = " agl-medium-arm-compiler"
+
+# This disables the Freescale/NXP Vivante GPU driver and enables
+# etnaviv support.
+MACHINEOVERRIDES .= ":use-mainline-bsp"
+
+# Disable the meta-freescale weston-init bbappend as it conflicts
+# with AGL's.
+BBMASK = "meta-freescale/recipes-graphics/wayland/weston-init"
+
+# Set CMA size large enough to work with AGL
+UBOOT_EXTLINUX_KERNEL_ARGS_append = " cma=512M"
+
+# Generate WIC image also
+#WKS_FILE = "imx-uboot.wks"
+AGL_EXTRA_IMAGE_FSTYPES = "wic.xz wic.bmap wic.xz.sha256sum"
+AGL_DEFAULT_INITRAMFS_FSTYPES := ""
diff --git a/meta-agl-bsp/meta-freescale-layer/recipes-kernel/linux/linux-fslc_%.bbappend b/meta-agl-bsp/meta-freescale-layer/recipes-kernel/linux/linux-fslc_%.bbappend
index 4fa422136..640f9cfe5 100644
--- a/meta-agl-bsp/meta-freescale-layer/recipes-kernel/linux/linux-fslc_%.bbappend
+++ b/meta-agl-bsp/meta-freescale-layer/recipes-kernel/linux/linux-fslc_%.bbappend
@@ -18,3 +18,8 @@ KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/cfg80211.cfg"
# (lock debugging and userspace firmware loader fallback)
SRC_URI_append = " file://fixups.cfg"
KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/fixups.cfg"
+
+do_install_append_cubox-i() {
+ # Add symlink to work with default Hummingboard 2 u-boot configuration
+ ln -sf imx6q-hummingboard2.dtb ${D}/boot/imx6q-hummingboard2-emmc.dtb
+}