summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp
diff options
context:
space:
mode:
authorJérémy Fanguède <j.fanguede@virtualopensystems.com>2019-07-18 17:15:13 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-03-04 15:24:33 +0000
commit46d255966d4cd76a6b28e3e76618c9ef71f7707c (patch)
tree22cc7f87f3e8278e6eb4c0e187d2327889b2a698 /meta-agl-bsp
parente2f3c097c506fcb6233f76da767c194580560d7f (diff)
meta-agl-bsp: Define Xen recipe
Provide Xen support for Arm64 boards, tested with the R-Car M3 ulcb board. Xen v4.13.0 stable version is compiled. A new binary is deployed, named "xen-${MACHINE}.uImage" that can be loaded and run by U-Boot. v2: rework to split u-boot mkimage part a separate recipe so we can keep the diff of the xen recipe at a minimum. Bug-AGL: SPEC-2912 Change-Id: I68d2af74d31ee310686645c8a5ae11b0201448b2 Signed-off-by: Jérémy Fanguède <j.fanguede@virtualopensystems.com> Signed-off-by: Michele Paolino <m.paolino@virtualopensystems.com> Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-bsp')
-rw-r--r--meta-agl-bsp/virtualization-layer/recipes-extended/xen/xen-mkimage.bb29
-rw-r--r--meta-agl-bsp/virtualization-layer/recipes-extended/xen/xen_git.bbappend6
2 files changed, 35 insertions, 0 deletions
diff --git a/meta-agl-bsp/virtualization-layer/recipes-extended/xen/xen-mkimage.bb b/meta-agl-bsp/virtualization-layer/recipes-extended/xen/xen-mkimage.bb
new file mode 100644
index 000000000..ae8fe71b6
--- /dev/null
+++ b/meta-agl-bsp/virtualization-layer/recipes-extended/xen/xen-mkimage.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Xen hypervisor u-boot image"
+LICENSE = "GPLv2"
+SECTION = "console/tools"
+
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+
+
+
+ALLOW_EMPTY_${PN} = "1"
+FILES_${PN} = ""
+S = "${WORKDIR}"
+
+DEPENDS = "u-boot-mkimage-native "
+
+# Only for aarch64
+COMPATIBLE_MACHINE = "(-)"
+COMPATIBLE_MACHINE_aarch64 = "(.*)"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+do_configure[noexec] = "1"
+do_deploy[noexec] = "1"
+
+do_compile[depends] += "xen:do_deploy"
+
+# Uboot compatible image
+do_compile () {
+ uboot-mkimage -A arm64 -C none -T kernel -a 0x48080000 -e 0x48080000 -n "XEN" -d ${DEPLOY_DIR_IMAGE}/xen-${MACHINE} ${DEPLOY_DIR_IMAGE}/xen-${MACHINE}.uImage
+}
diff --git a/meta-agl-bsp/virtualization-layer/recipes-extended/xen/xen_git.bbappend b/meta-agl-bsp/virtualization-layer/recipes-extended/xen/xen_git.bbappend
new file mode 100644
index 000000000..70c7fd415
--- /dev/null
+++ b/meta-agl-bsp/virtualization-layer/recipes-extended/xen/xen_git.bbappend
@@ -0,0 +1,6 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+XEN_REL = "4.13"
+XEN_BRANCH = "stable"
+SRCREV = "721f2c323ca55c77857c93e7275b4a93a0e15e1f"
+