summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp
diff options
context:
space:
mode:
authorKarthik Ramanan <a0393906@ti.com>2016-11-17 14:40:29 +0530
committerKarthik Ramanan <a0393906@ti.com>2016-11-17 14:43:11 +0530
commit6c0e800ba0589514d77eed0be72deab5e98dc9c7 (patch)
treef34ca689e53d948158cd0d0c88434062afdd337b /meta-agl-bsp
parent9a6b28c8ec3171e2c6852cf73f3f07ecd056c4a1 (diff)
dra7xx-evm: u-boot: Add custom uenv.txt
dra7xx-evm supports multiple LCD panels, to boot the board successfully, the uenv.txt has to specify the correct dtb file. This patch adds the default dtb and specifies one of the LCD panels in it. NOTE: It could happen that the panel that you have is a different panel, in that case you would have to manually edit the same. Change-Id: I0fdbe0ce48ca0654604a5808de684558308582c5 Signed-off-by: Karthik Ramanan <a0393906@ti.com>
Diffstat (limited to 'meta-agl-bsp')
-rwxr-xr-xmeta-agl-bsp/meta-ti/recipes-bsp/u-boot/files/uEnv.txt1
-rw-r--r--meta-agl-bsp/meta-ti/recipes-bsp/u-boot/u-boot-ti-staging_%.bbappend17
2 files changed, 15 insertions, 3 deletions
diff --git a/meta-agl-bsp/meta-ti/recipes-bsp/u-boot/files/uEnv.txt b/meta-agl-bsp/meta-ti/recipes-bsp/u-boot/files/uEnv.txt
new file mode 100755
index 000000000..6ea1abb25
--- /dev/null
+++ b/meta-agl-bsp/meta-ti/recipes-bsp/u-boot/files/uEnv.txt
@@ -0,0 +1 @@
+fdtfile=dra7-evm-lcd-lg.dtb
diff --git a/meta-agl-bsp/meta-ti/recipes-bsp/u-boot/u-boot-ti-staging_%.bbappend b/meta-agl-bsp/meta-ti/recipes-bsp/u-boot/u-boot-ti-staging_%.bbappend
index 629667805..77b84f990 100644
--- a/meta-agl-bsp/meta-ti/recipes-bsp/u-boot/u-boot-ti-staging_%.bbappend
+++ b/meta-agl-bsp/meta-ti/recipes-bsp/u-boot/u-boot-ti-staging_%.bbappend
@@ -1,9 +1,20 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+SRCREV = "${AUTOREV}"
+BRANCH = "p-ti-u-boot-2016.05"
+
+SRC_URI = "git://git.omapzoom.org/repo/u-boot.git;protocol=git;branch=${BRANCH}"
# This applies to the JACINTO 6 vayu board ... essentially it is dra7_evm.
SRC_URI_vayu += "file://fix_builderror_gcc5.patch"
+SRC_URI += " file://${UBOOT_ENV_BINARY}"
-BRANCH = "p-ti-u-boot-2016.05"
-SRC_URI = "git://git.omapzoom.org/repo/u-boot.git;protocol=git;branch=${BRANCH}"
-SRCREV = "${AUTOREV}"
+UBOOT_ENV = "uEnv"
+
+do_deploy_append () {
+ if [ "x${UBOOT_ENV}" != "x" ]
+ then
+ install ${WORKDIR}/${UBOOT_ENV_BINARY} ${DEPLOYDIR}/${UBOOT_ENV_IMAGE}
+ ln -sf ${UBOOT_ENV_IMAGE} ${DEPLOYDIR}/${UBOOT_ENV_SYMLINK}
+ fi
+}