summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-05-19 17:22:34 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-05-24 11:03:49 +0000
commit3235d0f84dafa0a99313a9fb83df8a16ebdb3195 (patch)
tree3f2df0f06f2dbb7b71b12c70d9919f2269a6a583 /meta-agl-bsp
parent2e84e270a00afc440af68baeb99e7c13010893ec (diff)
Add AGL machine template for s32g274ardb2 aka goldbox
This adds the machine template and tweaks to build an image that matches the s32g274ardb2 aka 'goldbox' . Bug-AGL: SPEC-4387 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I90cb5d109d4327147025fa81a70ef0c9adb0c78f Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/27498 Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account
Diffstat (limited to 'meta-agl-bsp')
-rw-r--r--meta-agl-bsp/conf/include/agl_s32g274ardb2.inc29
-rw-r--r--meta-agl-bsp/meta-alb/recipes-bsp/u-boot/u-boot-s32_%.bbappend5
-rw-r--r--meta-agl-bsp/meta-alb/recipes-kernel/linux/linux-s32_5.%.bbappend1
3 files changed, 35 insertions, 0 deletions
diff --git a/meta-agl-bsp/conf/include/agl_s32g274ardb2.inc b/meta-agl-bsp/conf/include/agl_s32g274ardb2.inc
new file mode 100644
index 000000000..bd455f435
--- /dev/null
+++ b/meta-agl-bsp/conf/include/agl_s32g274ardb2.inc
@@ -0,0 +1,29 @@
+# Disable meta-freescale package architecure mangling, as it causes
+# issues with AGL's explicit setting of DEFAULTTUNE.
+INHERIT:remove = "fsl-dynamic-packagearch"
+MACHINE_SOCARCH = "${TUNE_PKGARCH}"
+
+# Disable the meta-freescale weston-init bbappend as it conflicts
+# with AGL's.
+BBMASK:append = " meta-freescale/recipes-graphics/wayland/weston-init"
+
+# do not replace or append YP core recipes at all
+BBMASK:append = " meta-alb/dynamic-layers/core/"
+
+# Avoid needing meta-python2
+BBMASK:append = " meta-alb/dynamic-layers/freescale-layer/recipes-extended/vpp-core/vpp-core.bb"
+BBMASK:append = " meta-alb/recipes-(connectivity|core|devtools|extended/xen|support/rng-tools)/"
+
+# Seems like it might be worthwhile to get dunfell version, but doesn't work?:
+#BBMASK:append = " meta-alb/recipes-bsp/u-boot/u-boot.inc"
+
+PREFERRED_VERSION_rng-tools ?= "6%"
+
+# export?
+RELEASE_BASE = "release/bsp32.0"
+
+# the label needs to be shorter than we would expand to by default !!
+# Defaults to boot-${MACHINE} which happens to be more than 11 chars
+BOOTDD_VOLUME_ID = "boots32g"
+
+AGL_DEFAULT_IMAGE_FSTYPES ?= "sdcard ext4 tar.xz" \ No newline at end of file
diff --git a/meta-agl-bsp/meta-alb/recipes-bsp/u-boot/u-boot-s32_%.bbappend b/meta-agl-bsp/meta-alb/recipes-bsp/u-boot/u-boot-s32_%.bbappend
new file mode 100644
index 000000000..465023c08
--- /dev/null
+++ b/meta-agl-bsp/meta-alb/recipes-bsp/u-boot/u-boot-s32_%.bbappend
@@ -0,0 +1,5 @@
+# Missing from the meta-alb u-boot.inc
+inherit python3native
+
+DEPENDS:remove = "python-native"
+DEPENDS:append = " python3-native"
diff --git a/meta-agl-bsp/meta-alb/recipes-kernel/linux/linux-s32_5.%.bbappend b/meta-agl-bsp/meta-alb/recipes-kernel/linux/linux-s32_5.%.bbappend
new file mode 100644
index 000000000..787ead1ba
--- /dev/null
+++ b/meta-agl-bsp/meta-alb/recipes-kernel/linux/linux-s32_5.%.bbappend
@@ -0,0 +1 @@
+addtask merge_delta_config before do_kernel_localversion \ No newline at end of file