summaryrefslogtreecommitdiffstats
path: root/meta-agl-core-test
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-08-02 17:10:51 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-08-23 11:56:42 +0000
commitdd6fc5dcaa0a027b7651bb365d5dd0f623498f8f (patch)
tree428562251f7033e4d44c848e7258243fb9421a94 /meta-agl-core-test
parent756165e01db655cdbd2788eb134fba79fea7fd90 (diff)
Convert to new override syntax
This is mostly the result of running a slightly customized version of the convert-overrides.py script from poky with additional overrides added. A few minor fixups were done by hand afterwards during a review of the changes. The intent of these changes is to minimize the effort to keep the "next" branch that builds against poky master up to date and tested in preparation for the switch to the next Yocto LTS release in early 2022. Bug-AGL: SPEC-4052 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ia3bf63b7cb1aa1d95ada373d1a3ab56def0a125d Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/26564 Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-core-test')
-rw-r--r--meta-agl-core-test/images/agl-image-minimal-qa.bb2
-rw-r--r--meta-agl-core-test/recipes-test/ebizzy/ebizzy_0.3.bb2
-rw-r--r--meta-agl-core-test/recipes-test/fontconfig/fontconfig_%.bbappend6
-rw-r--r--meta-agl-core-test/recipes-test/freetype/freetype_2.%.bbappend10
-rw-r--r--meta-agl-core-test/recipes-test/glmark2/glmark2_%.bbappend2
-rw-r--r--meta-agl-core-test/recipes-test/himeno/himeno_2.0.bb2
-rw-r--r--meta-agl-core-test/recipes-test/interbench/interbench_0.31.bb2
-rw-r--r--meta-agl-core-test/recipes-test/ipv6connect/ipv6connect.bb2
-rw-r--r--meta-agl-core-test/recipes-test/linus-stress/linus-stress.bb2
-rw-r--r--meta-agl-core-test/recipes-test/packagegroups/packagegroup-agl-test.bb10
-rw-r--r--meta-agl-core-test/recipes-test/trinity/trinity_git.bb6
11 files changed, 23 insertions, 23 deletions
diff --git a/meta-agl-core-test/images/agl-image-minimal-qa.bb b/meta-agl-core-test/images/agl-image-minimal-qa.bb
index b162f2904..a5ec70830 100644
--- a/meta-agl-core-test/images/agl-image-minimal-qa.bb
+++ b/meta-agl-core-test/images/agl-image-minimal-qa.bb
@@ -7,6 +7,6 @@ require agl-image-minimal.bb
LICENSE = "MIT"
-IMAGE_INSTALL_append = " \
+IMAGE_INSTALL:append = " \
packagegroup-ivi-common-test \
"
diff --git a/meta-agl-core-test/recipes-test/ebizzy/ebizzy_0.3.bb b/meta-agl-core-test/recipes-test/ebizzy/ebizzy_0.3.bb
index 08b0425c0..5e993519d 100644
--- a/meta-agl-core-test/recipes-test/ebizzy/ebizzy_0.3.bb
+++ b/meta-agl-core-test/recipes-test/ebizzy/ebizzy_0.3.bb
@@ -7,7 +7,7 @@ SRC_URI = "http://downloads.sourceforge.net/project/ebizzy/ebizzy/${PV}/ebizzy-$
SRC_URI[md5sum] = "af038bc506066bb3d28db08aba62bc38"
SRC_URI[sha256sum] = "77286029d6348f3d9b3f04eae1feadb5ad1ad07b9f688f4d9f002960862467f2"
-INSANE_SKIP_${PN} = "ldflags"
+INSANE_SKIP:${PN} = "ldflags"
do_compile () {
${CC} -Wall -Wshadow -lpthread -o ebizzy ebizzy.c
diff --git a/meta-agl-core-test/recipes-test/fontconfig/fontconfig_%.bbappend b/meta-agl-core-test/recipes-test/fontconfig/fontconfig_%.bbappend
index e8ce1ab78..481dd9ee4 100644
--- a/meta-agl-core-test/recipes-test/fontconfig/fontconfig_%.bbappend
+++ b/meta-agl-core-test/recipes-test/fontconfig/fontconfig_%.bbappend
@@ -1,4 +1,4 @@
-do_install_append() {
+do_install:append() {
install -m 755 -d ${D}/${datadir}/fontconfig-test
install -m 755 ${S}/test/run-test.sh ${D}/${datadir}/fontconfig-test/
@@ -12,7 +12,7 @@ do_install_append() {
PACKAGES =+ "fontconfig-test"
-DEBIAN_NOAUTONAME_fontconfig-test = "1"
-FILES_fontconfig-test = "${datadir}/fontconfig-test/*"
+DEBIAN_NOAUTONAME:fontconfig-test = "1"
+FILES:fontconfig-test = "${datadir}/fontconfig-test/*"
diff --git a/meta-agl-core-test/recipes-test/freetype/freetype_2.%.bbappend b/meta-agl-core-test/recipes-test/freetype/freetype_2.%.bbappend
index 6aa1eabc2..8fc56fa35 100644
--- a/meta-agl-core-test/recipes-test/freetype/freetype_2.%.bbappend
+++ b/meta-agl-core-test/recipes-test/freetype/freetype_2.%.bbappend
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
SRC_URI =+ "${SOURCEFORGE_MIRROR}/freetype/freetype-demos/${PV}/ft2demos-${PV}.tar.gz;name=ft2demos \
file://0001-Makefile-dont-build-gfx-demos.patch;patchdir=../ft2demos-${PV} \
@@ -11,18 +11,18 @@ PACKAGES =+ "${PN}-demos"
B = "${S}"
-do_compile_append () {
+do_compile:append () {
oe_runmake -C ${WORKDIR}/ft2demos-${PV} TOP_DIR=${WORKDIR}/${BPN}-${PV}/
}
-do_install_append () {
+do_install:append () {
install -d -m 0755 ${D}/${bindir}
for x in ftbench ftdump ftlint ftvalid ttdebug; do
install -m 0755 ${WORKDIR}/ft2demos-${PV}/bin/.libs/$x ${D}/${bindir}
done
}
-FILES_${PN}-demos = "\
+FILES:${PN}-demos = "\
${bindir}/ftbench \
${bindir}/ftdump \
${bindir}/ftlint \
@@ -31,4 +31,4 @@ FILES_${PN}-demos = "\
"
# enable pixmap/libpng support to allow color emojis
-PACKAGECONFIG_append = " pixmap"
+PACKAGECONFIG:append = " pixmap"
diff --git a/meta-agl-core-test/recipes-test/glmark2/glmark2_%.bbappend b/meta-agl-core-test/recipes-test/glmark2/glmark2_%.bbappend
index 20dc23296..ab453d8b0 100644
--- a/meta-agl-core-test/recipes-test/glmark2/glmark2_%.bbappend
+++ b/meta-agl-core-test/recipes-test/glmark2/glmark2_%.bbappend
@@ -1,7 +1,7 @@
# Update glmark2
SRCREV = "784aca755a469b144acf3cae180b6e613b7b057a"
# Already in newer version
-SRC_URI_remove = "file://python3.patch"
+SRC_URI:remove = "file://python3.patch"
PACKAGECONFIG = "wayland-gles2"
PACKAGECONFIG[wayland-gles2] = ",,virtual/egl virtual/libgles2 wayland wayland-protocols wayland-native"
diff --git a/meta-agl-core-test/recipes-test/himeno/himeno_2.0.bb b/meta-agl-core-test/recipes-test/himeno/himeno_2.0.bb
index f890e23a4..de1c8d3ad 100644
--- a/meta-agl-core-test/recipes-test/himeno/himeno_2.0.bb
+++ b/meta-agl-core-test/recipes-test/himeno/himeno_2.0.bb
@@ -14,7 +14,7 @@ LIC_FILES_CHKSUM = "file://himenoBMT.c;md5=8e8771ddc01c6d1a795e088e2d6dee78"
DEPENDS = "p7zip-native"
-do_configure_append() {
+do_configure:append() {
7z x -y -o${S} ${WORKDIR}/himenobmt.c.lzh
cd ${S}
sed -i -e 's/CC= gcc/#CC= gcc/' Makefile
diff --git a/meta-agl-core-test/recipes-test/interbench/interbench_0.31.bb b/meta-agl-core-test/recipes-test/interbench/interbench_0.31.bb
index 3e6490374..b6c54cc9a 100644
--- a/meta-agl-core-test/recipes-test/interbench/interbench_0.31.bb
+++ b/meta-agl-core-test/recipes-test/interbench/interbench_0.31.bb
@@ -8,7 +8,7 @@ SRC_URI += "file://interbench.c.patch;striplevel=0"
inherit autotools
-INSANE_SKIP_${PN} = "ldflags"
+INSANE_SKIP:${PN} = "ldflags"
B = "${S}"
EXTRA_OEMAKE = "CC='${CC}'"
diff --git a/meta-agl-core-test/recipes-test/ipv6connect/ipv6connect.bb b/meta-agl-core-test/recipes-test/ipv6connect/ipv6connect.bb
index a8b93716a..0f84a16f9 100644
--- a/meta-agl-core-test/recipes-test/ipv6connect/ipv6connect.bb
+++ b/meta-agl-core-test/recipes-test/ipv6connect/ipv6connect.bb
@@ -8,7 +8,7 @@ SRCREV = "b355b7e1f43a19938895964f314484ffd8a39542"
inherit autotools
-INSANE_SKIP_${PN} = "ldflags"
+INSANE_SKIP:${PN} = "ldflags"
B = "${WORKDIR}/git/ipv6connect"
S = "${WORKDIR}/git"
diff --git a/meta-agl-core-test/recipes-test/linus-stress/linus-stress.bb b/meta-agl-core-test/recipes-test/linus-stress/linus-stress.bb
index 01b3cfce5..aaa4d138c 100644
--- a/meta-agl-core-test/recipes-test/linus-stress/linus-stress.bb
+++ b/meta-agl-core-test/recipes-test/linus-stress/linus-stress.bb
@@ -7,7 +7,7 @@ SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/qa-test-misc;protocol=htt
SRCREV = "87cdfd4626c0cb47fc22f328867e49d6268df85c"
inherit autotools
-INSANE_SKIP_${PN} = "ldflags"
+INSANE_SKIP:${PN} = "ldflags"
B = "${WORKDIR}/git/linus_stress"
S = "${WORKDIR}/git"
diff --git a/meta-agl-core-test/recipes-test/packagegroups/packagegroup-agl-test.bb b/meta-agl-core-test/recipes-test/packagegroups/packagegroup-agl-test.bb
index f3b2c4ff9..57a5d32e1 100644
--- a/meta-agl-core-test/recipes-test/packagegroups/packagegroup-agl-test.bb
+++ b/meta-agl-core-test/recipes-test/packagegroups/packagegroup-agl-test.bb
@@ -11,9 +11,9 @@ PACKAGES = "\
packagegroup-ivi-common-test \
"
-ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY:${PN} = "1"
-RDEPENDS_${PN} += "\
+RDEPENDS:${PN} += "\
bc \
ebizzy \
evtest \
@@ -56,13 +56,13 @@ RDEPENDS_${PN} += "\
# readelf, logrotate, vsftpd, crontab, sar, arp, ftp,
# host, rcp, rlogin, rsh, tcpdump, expect, iptables, dnsmasq,
# pgrep
-RDEPENDS_packagegroup-agl-test-ltp = ""
-#RDEPENDS_packagegroup-agl-test-ltp += " \
+RDEPENDS:packagegroup-agl-test-ltp = ""
+#RDEPENDS:packagegroup-agl-test-ltp += " \
# initscripts-functions bind-utils binutils \
# cronie dnsmasq expect inetutils-ftp inetutils-rsh \
# iptables logrotate net-tools sysstat tcpdump vsftpd \
# "
-RDEPENDS_packagegroup-ivi-common-test = " \
+RDEPENDS:packagegroup-ivi-common-test = " \
packagegroup-agl-test \
"
diff --git a/meta-agl-core-test/recipes-test/trinity/trinity_git.bb b/meta-agl-core-test/recipes-test/trinity/trinity_git.bb
index f0f09a855..eec3381c5 100644
--- a/meta-agl-core-test/recipes-test/trinity/trinity_git.bb
+++ b/meta-agl-core-test/recipes-test/trinity/trinity_git.bb
@@ -16,7 +16,7 @@ S = "${WORKDIR}/git"
inherit useradd
USERADD_PACKAGES = "${PN}"
-USERADD_PARAM_${PN} = "--system --create-home --shell /bin/sh ${PN} "
+USERADD_PARAM:${PN} = "--system --create-home --shell /bin/sh ${PN} "
do_configure () {
./configure.sh
@@ -38,5 +38,5 @@ do_install () {
PACKAGES =+ "${PN}-example"
-FILES_${PN} = "${bindir}/trinity"
-FILES_${PN}-example = "${datadir}/${PN}"
+FILES:${PN} = "${bindir}/trinity"
+FILES:${PN}-example = "${datadir}/${PN}"