summaryrefslogtreecommitdiffstats
path: root/meta-agl-core/recipes-core/systemd/systemd-conf-canbus_1.0.bb
diff options
context:
space:
mode:
authorVasyl Vavrychuk <vasyl.vavrychuk@opensynergy.com>2022-11-02 09:42:45 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-11-23 14:04:52 +0000
commite01f289d60c4f25b5483bc2a5e4d6887f50eb309 (patch)
treeabfc49d43930d573175ed1dd3cd16f6f6855145a /meta-agl-core/recipes-core/systemd/systemd-conf-canbus_1.0.bb
parent50a5f20e1dfe4f9fb6b8ba8dec865e2f8cdaf09f (diff)
meta-agl-core: systemd: Disable `BitRate` setting for `can*` network for VIRTIO.
VIRTIO CAN [1] does not support bitrate configuration, it assumes bitrate configuration is done on backend. Fixes systemd-networkd failure: can0: Failed to set CAN interface configurations: Operation not supported File `canbus-virtio-can.network` is copied from `canbus-can.network` with `BitRate=` setting removed. v2: rework patchset to use own systemd-conf-canbus package to avoid changes in main systemd package. [1]: https://lists.oasis-open.org/archives/virtio-dev/202208/msg00159.html Bug-AGL: SPEC-4597 Change-Id: Idb132203501bb99103e76098eea3bb6394b645da Signed-off-by: Vasyl Vavrychuk <vasyl.vavrychuk@opensynergy.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/28104 Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-core/recipes-core/systemd/systemd-conf-canbus_1.0.bb')
-rw-r--r--meta-agl-core/recipes-core/systemd/systemd-conf-canbus_1.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-agl-core/recipes-core/systemd/systemd-conf-canbus_1.0.bb b/meta-agl-core/recipes-core/systemd/systemd-conf-canbus_1.0.bb
new file mode 100644
index 000000000..33b986245
--- /dev/null
+++ b/meta-agl-core/recipes-core/systemd/systemd-conf-canbus_1.0.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Systemd canbus configuration"
+DESCRIPTION = "Systemd may require slightly different configuration for \
+different machines. This injects configuration for the CAN bus."
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+PE = "1"
+
+SRC_URI = "\
+ file://canbus-can.network \
+ file://canbus-virtio.network \
+"
+
+CANBUS_NETWORK_CONFIG ??= "canbus-can.network"
+CANBUS_NETWORK_CONFIG:virtio-all ?= "canbus-virtio.network"
+
+do_install() {
+ # Install canbus network script
+ install -d ${D}${nonarch_base_libdir}/systemd/network/
+ install -m 0644 ${WORKDIR}/${CANBUS_NETWORK_CONFIG} ${D}${nonarch_base_libdir}/systemd/network/60-canbus-can.network
+}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+FILES:${PN} = " \
+ ${nonarch_base_libdir}/systemd/network/*.network \
+"