summaryrefslogtreecommitdiffstats
path: root/meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-11-02 19:29:39 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-11-04 14:24:24 +0000
commitb1b652ff976655d0c1fcb170fb3f6795e56cd947 (patch)
treec0ef7baf2272a44d60d3cb74abc9b4c0c2be5274 /meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb
parentd468ce3b3d602f7c8a88d67126a32900b76fd433 (diff)
meta-agl-core: Update weston/agl-compositor init
Changes/rework to get weston and agl-compositor starting again: - Since an upgrade to a newer Yocto release is in the near future, update weston-init and associated files to effectively backport the new weston startup behavior added in 3.3/Hardknott as our new base. The changes mean weston or agl-compositor will by default start as a "weston" user that replaces the "display" user that had been added previously in AGL. The goal is that any new work done on top of this base should hopefully work on 3.5/Kirkstone without further substantial rework. - Add new agl-compositor-init recipe that replaces the previous weston-init bbappend in meta-agl-demo. Having it as a separate recipe in core so weston or agl-compositor "just work" in simple test images seems like a better approach. - As part of the above, drop the --log option to agl-compositor in its command-line to address SPEC-4112. - Add SYSTEMD_DEFAULT_TARGET definition to agl-image-weston and in a new core-image-weston bbappend to result in agl-compositor and weston starting automatically in the corresponding images. This is required with the new weston-init behavior until we upgrade past 3.3/Hardknott, when "weston" in IMAGE_FEATURES can be used instead. Bug-AGL: SPEC-4121, SPEC-4112 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ia64894416846569abf8e744006ef26637279a895 Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/26782 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb')
-rw-r--r--meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb b/meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb
index 2156c7839..bdf8dc896 100644
--- a/meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb
+++ b/meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb
@@ -30,7 +30,10 @@ FILES:${PN} = " \
${libdir}/agl-compositor/libexec_compositor.so.0.0.0 \
"
-RDEPENDS:${PN} += " ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin', '', d)}"
+RDEPENDS:${PN} += " \
+ agl-compositor-init \
+ ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin', '', d)} \
+"
FILES:${PN}-dev += " \
${datadir}/agl-compositor/protocols/agl-shell.xml \