summaryrefslogtreecommitdiffstats
path: root/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-02-23 16:28:01 -0500
committerScott Murray <scott.murray@konsulko.com>2022-03-29 15:23:32 -0400
commit09ad500c71a9bbd003c21654bf8fc535d65117a6 (patch)
tree65db7660f1388e70c6459e1d0f84222cd5023497 /meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
parent47bf86a3e5d9015f504de4d64942bd17a643b4e6 (diff)
meta-agl-core: update weston-ini-conf
Update weston-ini-conf recipe to handle weston 9.0 in poky master. The changes are to handle the flip of the meaning of 90 and 270 degree rotations in the transform option in weston.ini, and the rename of its values to "rotate-X" instead of just the number of degrees. Bug-AGL: SPEC-3819 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I2bb316a195f7eb3733ff757a565535317db1da08
Diffstat (limited to 'meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb')
-rw-r--r--meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
index c635d7b2f..c04ff6568 100644
--- a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
+++ b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
@@ -12,6 +12,7 @@ SRC_URI = " \
file://remote-output.cfg \
file://transmitter-output.cfg.in \
file://virtual-0.cfg \
+ file://virtual-90.cfg \
file://virtual-180.cfg \
file://virtual-270.cfg \
"
@@ -21,7 +22,7 @@ S = "${WORKDIR}"
inherit update-alternatives
# Default primary display/orientation fragment
-WESTON_DISPLAYS ?= "hdmi-a-1-270"
+WESTON_DISPLAYS ?= "hdmi-a-1-90"
# Configuration fragments to use in weston.ini.*
# Note that some may be replaced/removed when building the landscape
@@ -63,7 +64,7 @@ do_compile() {
if echo $F | grep '^hdmi-a-1-\(90\|270\)$'; then
F="hdmi-a-1-0"
INVF="hdmi-a-1-180"
- elif echo $F | grep '^virtual-270$'; then
+ elif echo $F | grep '^virtual-90$'; then
F="virtual-0"
INVF="virtual-180"
fi