summaryrefslogtreecommitdiffstats
path: root/meta-agl-core/recipes-graphics/wayland
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-02-17 23:08:04 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-02-27 11:02:42 +0000
commit1cb8084a871a4cad7225f0c774536e72d4ed02b6 (patch)
tree9af14ac3de1458d223da1cfb9459ba755596cdd1 /meta-agl-core/recipes-graphics/wayland
parentc431bbb2f0f5bf0c66d8473344db0aa26d834bfa (diff)
[agl-shell-activator] Decouple due to dependency on grpc
We also need to deal with DEPENDS and agl-shell-activator. The latter is a pure grpc implementation, thus move it to a dynamic layer. Bug-AGL: SPEC-4707 Change-Id: I308104b59333f69dfe416bd3721b11fb7e1b96c4 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/28513 Reviewed-by: Denys Dmytriyenko <denys@konsulko.com> Reviewed-by: Marius Vlad <marius.vlad@collabora.com> Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account
Diffstat (limited to 'meta-agl-core/recipes-graphics/wayland')
-rw-r--r--meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb9
-rw-r--r--meta-agl-core/recipes-graphics/wayland/agl-shell-activator_git.bb22
2 files changed, 7 insertions, 24 deletions
diff --git a/meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb b/meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb
index ea0410aaf..a76da6647 100644
--- a/meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb
+++ b/meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb
@@ -8,7 +8,7 @@ SECTION = "x11"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://COPYING;md5=fac6abe0003c4d142ff8fa1f18316df0"
-DEPENDS = "wayland wayland-protocols wayland-native weston grpc grpc-native \
+DEPENDS = "wayland wayland-protocols wayland-native weston \
${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin', '', d)}"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/agl-compositor.git;protocol=https;branch=${AGL_BRANCH}"
@@ -22,15 +22,20 @@ S = "${WORKDIR}/git"
PACKAGECONFIG ?= ""
PACKAGECONFIG[policy-rba] = "-Dpolicy-default=rba,,librba,librba rba-config"
PACKAGECONFIG[policy-deny-all] = "-Dpolicy-default=deny-all,,"
-PACKAGECONFIG[grpc-proxy] = "-Dgrpc-proxy=true,-Dgrpc-proxy=false"
+PACKAGECONFIG[grpc-proxy] = "-Dgrpc-proxy=true,-Dgrpc-proxy=false,grpc grpc-native,grpc agl-shell-grpc-server"
inherit meson pkgconfig python3native
+PACKAGES =+ "agl-shell-grpc-server"
+
FILES:${PN} = " \
${bindir}/agl-compositor \
${bindir}/agl-screenshooter \
${libdir}/agl-compositor/libexec_compositor.so.0 \
${libdir}/agl-compositor/libexec_compositor.so.0.0.0 \
+"
+
+FILES:agl-shell-grpc-server = " \
${libdir}/agl-compositor/agl-shell-grpc-server \
"
diff --git a/meta-agl-core/recipes-graphics/wayland/agl-shell-activator_git.bb b/meta-agl-core/recipes-graphics/wayland/agl-shell-activator_git.bb
deleted file mode 100644
index bbc936591..000000000
--- a/meta-agl-core/recipes-graphics/wayland/agl-shell-activator_git.bb
+++ /dev/null
@@ -1,22 +0,0 @@
-SUMMARY = " Application that switches/activates other application's windows "
-DESCRIPTION = " A wayland client and a script that talks with the agl-compositor \
-an tells it to display a specific application. Relies on the appid being \
-started (already) by afm-util or the client shell (homescreen/WAM)"
-
-HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/q/project:src%252Fagl-shell-activator"
-SECTION = "x11"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://COPYING;md5=e978448a0d41d826d73890d9c22caf75"
-
-DEPENDS = "wayland wayland-protocols wayland-native agl-compositor grpc grpc-native"
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/agl-shell-activator.git;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "f5aea684ce51fc1c3df13de14bb017ea2b73d39d"
-
-PV = "0.0.10+git${SRCPV}"
-S = "${WORKDIR}/git"
-
-
-inherit meson pkgconfig python3native
-
-FILES:${PN} = " ${bindir}/agl-shell-activator"