summaryrefslogtreecommitdiffstats
path: root/meta-agl-core/recipes-graphics/wayland
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-06-13 16:21:39 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-06-16 10:54:38 +0000
commitc57f7a0610a7702f7057c416ce2b170d71ef001e (patch)
tree01f2e161868a4f1fa5f0e571117cc3c5973c65f6 /meta-agl-core/recipes-graphics/wayland
parent5e3df5ad4fe4a93208110a1ff40c5e3ce09f6269 (diff)
meta-agl-core: fix polkit dependencies
As part of the systemd user session removal, some changes were made to attempt to fix pulling in polkit for core-image-weston, agl-image-weston, and agl-image-compositor so that the compositors would correctly start up in the resulting images. Unfortunately, just gating the dependency on polkit being in DISTRO_FEATURES breaks the usecase of using poky and meta-agl-core with our poky-agl distro configuration without also pulling in the meta-oe layer. This combination is used for testing meta-agl-core on the Yocto Project autobuilder, so that broke and was reported by upstream. To fix this usecase, the polkit dependency logic has been shifted to weston-init and agl-compositor-init via bbappends that are only used when meta-oe is present via our existing BBFILES_DYNAMIC set up. Since the dependency on polkit stems from a combination of the compositor PAM configuration from the -init packages and having systemd, pam, and polkit in DISTRO_FEATURES, this seems more correct, anyways. Other changes: - The explicit pam DISTRO_FEATURES checking that was added in the previous cleanup has been removed; it is actually redundant due to weston and weston-init having checks. Using the .inc file for that from upstream has been added to the agl-compositor and agl-compositor-init recipes to match the weston recipes and make the dependency visible in our tree. - There is no further need for our bbappend to core-image-weston, so it has been removed. Bug-AGL: SPEC-4836 Change-Id: Ia3052023dfb06d1c2190a03c72606ab4b27bbdd2 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/29014 Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-core/recipes-graphics/wayland')
-rw-r--r--meta-agl-core/recipes-graphics/wayland/agl-compositor-init.bb3
-rw-r--r--meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb4
2 files changed, 6 insertions, 1 deletions
diff --git a/meta-agl-core/recipes-graphics/wayland/agl-compositor-init.bb b/meta-agl-core/recipes-graphics/wayland/agl-compositor-init.bb
index a3127a3e5..d8baf91f9 100644
--- a/meta-agl-core/recipes-graphics/wayland/agl-compositor-init.bb
+++ b/meta-agl-core/recipes-graphics/wayland/agl-compositor-init.bb
@@ -4,6 +4,9 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384
inherit systemd
+# Reuse include file from upstream weston since we have the same requirements
+require recipes-graphics/wayland/required-distro-features.inc
+
PACKAGE_ARCH = "${MACHINE_ARCH}"
SRC_URI = "file://agl-compositor.service \
diff --git a/meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb b/meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb
index 46ba662b1..f443fe878 100644
--- a/meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb
+++ b/meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb
@@ -25,6 +25,9 @@ PACKAGECONFIG[grpc-proxy] = "-Dgrpc-proxy=true,-Dgrpc-proxy=false,grpc grpc-nati
inherit meson pkgconfig python3native
+# Reuse include file from upstream weston since we have the same requirements
+require recipes-graphics/wayland/required-distro-features.inc
+
PACKAGES =+ "agl-shell-grpc-server"
FILES:${PN} = " \
@@ -41,7 +44,6 @@ FILES:agl-shell-grpc-server = " \
RDEPENDS:${PN} += " \
agl-compositor-init \
xkeyboard-config \
- ${@bb.utils.filter('DISTRO_FEATURES', 'polkit', d)} \
"
FILES:${PN}-dev += " \