summaryrefslogtreecommitdiffstats
path: root/meta-agl-core/recipes-graphics
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-08-02 17:10:51 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-11-20 00:33:16 +0000
commitbad73bf315325c3428e331984f9d17bb8b2873b3 (patch)
treef1af509d2d534d7232ab63304faf52e549fbaeca /meta-agl-core/recipes-graphics
parent5f1d801530f9b3d7f99826b4cc8cc23df77d1e42 (diff)
Convert to new override syntax
This is effectively a manual cherry-pick and squash of commits: dd6fc5dcaa0a027b7651bb365d5dd0f623498f8f 917a82316bf53ead29d6345a39189d9e4efeef25 20e81c0a9d36660de671dd5ac2e006e31c0e621b from the master branch with additional review and fixups. The intent of these changes is to minimize the effort to backport fixes from the master branch, which has been updated in preparation for the switch to the next Yocto LTS release in early 2022. Bug-AGL: SPEC-4144 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I91c1640c6335d7748a2531d2fe8bf86d2d2aee32 Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/26876 Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-core/recipes-graphics')
-rw-r--r--meta-agl-core/recipes-graphics/rba/librba_1.0.bb8
-rw-r--r--meta-agl-core/recipes-graphics/rba/rba-config.bb2
-rw-r--r--meta-agl-core/recipes-graphics/wayland/Readme.weston-ini-conf12
-rw-r--r--meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb6
-rw-r--r--meta-agl-core/recipes-graphics/wayland/agl-shell-activator_git.bb2
-rw-r--r--meta-agl-core/recipes-graphics/wayland/waltham-transmitter-plugin.bb4
-rw-r--r--meta-agl-core/recipes-graphics/wayland/waltham_%.bbappend4
-rw-r--r--meta-agl-core/recipes-graphics/wayland/waltham_git.bb2
-rw-r--r--meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb30
-rw-r--r--meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bbappend10
-rw-r--r--meta-agl-core/recipes-graphics/wayland/weston-init_aglcore.inc4
-rw-r--r--meta-agl-core/recipes-graphics/wayland/weston_8.0_aglcore.inc10
12 files changed, 47 insertions, 47 deletions
diff --git a/meta-agl-core/recipes-graphics/rba/librba_1.0.bb b/meta-agl-core/recipes-graphics/rba/librba_1.0.bb
index b04774c84..e8b1e0dbc 100644
--- a/meta-agl-core/recipes-graphics/rba/librba_1.0.bb
+++ b/meta-agl-core/recipes-graphics/rba/librba_1.0.bb
@@ -16,9 +16,9 @@ S = "${WORKDIR}/git"
inherit pkgconfig cmake
-FILES_${PN} = "${libdir}/"
-FILES_${PN}-dev = "${libdir}/pkgconfig/librba.pc \
+FILES:${PN} = "${libdir}/"
+FILES:${PN}-dev = "${libdir}/pkgconfig/librba.pc \
${includedir}/ \
"
-INSANE_SKIP_${PN} += "dev-so"
-INSANE_SKIP_${PN}-dev += "dev-elf"
+INSANE_SKIP:${PN} += "dev-so"
+INSANE_SKIP:${PN}-dev += "dev-elf"
diff --git a/meta-agl-core/recipes-graphics/rba/rba-config.bb b/meta-agl-core/recipes-graphics/rba/rba-config.bb
index 17b7a6708..cbed9df0c 100644
--- a/meta-agl-core/recipes-graphics/rba/rba-config.bb
+++ b/meta-agl-core/recipes-graphics/rba/rba-config.bb
@@ -9,7 +9,7 @@ S = "${WORKDIR}"
do_configure[noexec] = "1"
do_compile[noexec] = "1"
-do_install_append() {
+do_install:append() {
install -d ${D}/${sysconfdir}/rba
install -m 0644 ${WORKDIR}/RBAModel.json ${D}/${sysconfdir}/rba
}
diff --git a/meta-agl-core/recipes-graphics/wayland/Readme.weston-ini-conf b/meta-agl-core/recipes-graphics/wayland/Readme.weston-ini-conf
index bb66fd2bb..ee75c7335 100644
--- a/meta-agl-core/recipes-graphics/wayland/Readme.weston-ini-conf
+++ b/meta-agl-core/recipes-graphics/wayland/Readme.weston-ini-conf
@@ -5,7 +5,7 @@ do_configure() function to your bbappend, using machine (e.g. h3ulcb)
overrides (i.e. use the MACHINE name where "machine" is used below):
'''
-do_configure_machine() {
+do_configure:machine() {
echo repaint-window=34 >> ${WORKDIR}/core.cfg
echo transition-duration=300 >> ${WORKDIR}/ivishell.cfg
@@ -14,17 +14,17 @@ do_configure_machine() {
'''
or:
'''
-do_configure_machine() {
+do_configure:machine() {
sed -i -e 's/drm-backend/fbdev-backend/' ${WORKDIR}/core.cfg
}
'''
To add new non-display sections, just list them in SRC_URI and WESTON_FRAGMENTS:
'''
-FILESEXTRAPATHS_prepend_machine := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend:machine := "${THISDIR}/${PN}:"
-SRC_URI_append_machine = " file://foo.cfg"
-WESTON_FRAGMENTS_append_machine = " foo"
+SRC_URI:append:machine = " file://foo.cfg"
+WESTON_FRAGMENTS:append:machine = " foo"
'''
@@ -33,7 +33,7 @@ HDMI-1-A connected screen that needs to be rotated 270 degrees to one
that is rotated 90 degrees, redefine the WESTON_DISPLAYS variable:
'''
-WESTON_DISPLAYS_machine = "hdmi-a-1-90"
+WESTON_DISPLAYS:machine = "hdmi-a-1-90"
'''
Note that the weston-ini-conf recipe automatically generates a landscape
diff --git a/meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb b/meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb
index 4a535107c..79a9915d0 100644
--- a/meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb
+++ b/meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb
@@ -23,7 +23,7 @@ PACKAGECONFIG[policy-deny-all] = "-Dpolicy-default=deny-all,,"
inherit meson pkgconfig python3native
-FILES_${PN} = " \
+FILES:${PN} = " \
${bindir}/agl-compositor \
${bindir}/agl-screenshooter \
${datadir}/${PN}/protocols/agl-shell.xml \
@@ -32,8 +32,8 @@ FILES_${PN} = " \
${libdir}/agl-compositor/libexec_compositor.so.0.0.0 \
"
-RDEPENDS_${PN} += " ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin', '', d)}"
+RDEPENDS:${PN} += " ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin', '', d)}"
-FILES_${PN}-dev += " \
+FILES:${PN}-dev += " \
${libdir}/agl-compositor/libexec_compositor.so \
"
diff --git a/meta-agl-core/recipes-graphics/wayland/agl-shell-activator_git.bb b/meta-agl-core/recipes-graphics/wayland/agl-shell-activator_git.bb
index fe0b61f85..049068341 100644
--- a/meta-agl-core/recipes-graphics/wayland/agl-shell-activator_git.bb
+++ b/meta-agl-core/recipes-graphics/wayland/agl-shell-activator_git.bb
@@ -18,5 +18,5 @@ S = "${WORKDIR}/git"
inherit meson pkgconfig python3native
-FILES_${PN} = " ${bindir}/agl-shell-activator \
+FILES:${PN} = " ${bindir}/agl-shell-activator \
${bindir}/agl-activator "
diff --git a/meta-agl-core/recipes-graphics/wayland/waltham-transmitter-plugin.bb b/meta-agl-core/recipes-graphics/wayland/waltham-transmitter-plugin.bb
index aed96de21..466985f41 100644
--- a/meta-agl-core/recipes-graphics/wayland/waltham-transmitter-plugin.bb
+++ b/meta-agl-core/recipes-graphics/wayland/waltham-transmitter-plugin.bb
@@ -13,5 +13,5 @@ S = "${WORKDIR}/git"
inherit meson pkgconfig python3native
-FILES_${PN} += "${libdir}/*"
-FILES_${PN} += "${bindir}/*"
+FILES:${PN} += "${libdir}/*"
+FILES:${PN} += "${bindir}/*"
diff --git a/meta-agl-core/recipes-graphics/wayland/waltham_%.bbappend b/meta-agl-core/recipes-graphics/wayland/waltham_%.bbappend
index 8d0436a3b..302eba4d2 100644
--- a/meta-agl-core/recipes-graphics/wayland/waltham_%.bbappend
+++ b/meta-agl-core/recipes-graphics/wayland/waltham_%.bbappend
@@ -1,6 +1,6 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
-SRC_URI_append = "\
+SRC_URI:append = "\
file://0001-waltham-Fix-compile-build-error.patch \
file://0002-commandxml-Add-support-wthp_app_id-interface.patch \
file://0001-Use-python3-instead-of-2.patch \
diff --git a/meta-agl-core/recipes-graphics/wayland/waltham_git.bb b/meta-agl-core/recipes-graphics/wayland/waltham_git.bb
index 02ce5c116..da092a5e7 100644
--- a/meta-agl-core/recipes-graphics/wayland/waltham_git.bb
+++ b/meta-agl-core/recipes-graphics/wayland/waltham_git.bb
@@ -13,4 +13,4 @@ S = "${WORKDIR}/git"
inherit autotools pkgconfig
DEPENDS += "libdrm virtual/kernel wayland"
-RDEPENDS_${PN} += "libdrm" \ No newline at end of file
+RDEPENDS:${PN} += "libdrm" \ No newline at end of file
diff --git a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
index b3a5a4712..8842a5a46 100644
--- a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
+++ b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
@@ -63,7 +63,7 @@ do_compile() {
sed -i -e '$ d' ${WORKDIR}/weston.ini.landscape-inverted
}
-do_install_append() {
+do_install:append() {
install -d ${D}${weston_ini_dir}
install -m 0644 ${WORKDIR}/weston.ini.default ${D}${weston_ini_dir}/
install -m 0644 ${WORKDIR}/weston.ini.landscape ${D}${weston_ini_dir}/
@@ -81,28 +81,28 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
ALTERNATIVE_LINK_NAME[weston.ini] = "${weston_ini_dir}/weston.ini"
-RDEPENDS_${PN} = "weston-init"
-RPROVIDES_${PN} = "weston-ini"
-RCONFLICTS_${PN} = "${PN}-landscape"
-ALTERNATIVE_${PN} = "weston.ini"
+RDEPENDS:${PN} = "weston-init"
+RPROVIDES:${PN} = "weston-ini"
+RCONFLICTS:${PN} = "${PN}-landscape"
+ALTERNATIVE:${PN} = "weston.ini"
ALTERNATIVE_TARGET_${PN} = "${weston_ini_dir}/weston.ini.default"
PACKAGE_BEFORE_PN += "${PN}-landscape"
-FILES_${PN}-landscape = "${weston_ini_dir}/weston.ini.landscape"
+FILES:${PN}-landscape = "${weston_ini_dir}/weston.ini.landscape"
-RDEPENDS_${PN}-landscape = "weston-init"
-RPROVIDES_${PN}-landscape = "weston-ini"
-RCONFLICTS_${PN}-landscape = "${PN}"
-ALTERNATIVE_${PN}-landscape = "weston.ini"
+RDEPENDS:${PN}-landscape = "weston-init"
+RPROVIDES:${PN}-landscape = "weston-ini"
+RCONFLICTS:${PN}-landscape = "${PN}"
+ALTERNATIVE:${PN}-landscape = "weston.ini"
ALTERNATIVE_TARGET_${PN}-landscape = "${weston_ini_dir}/weston.ini.landscape"
PACKAGE_BEFORE_PN += "${PN}-landscape-inverted"
-FILES_${PN}-landscape-inverted = "${weston_ini_dir}/weston.ini.landscape-inverted"
+FILES:${PN}-landscape-inverted = "${weston_ini_dir}/weston.ini.landscape-inverted"
-RDEPENDS_${PN}-landscape-inverted = "weston-init"
-RPROVIDES_${PN}-landscape-inverted = "weston-ini"
-RCONFLICTS_${PN}-landscape-inverted = "${PN}"
-ALTERNATIVE_${PN}-landscape-inverted = "weston.ini"
+RDEPENDS:${PN}-landscape-inverted = "weston-init"
+RPROVIDES:${PN}-landscape-inverted = "weston-ini"
+RCONFLICTS:${PN}-landscape-inverted = "${PN}"
+ALTERNATIVE:${PN}-landscape-inverted = "weston.ini"
ALTERNATIVE_TARGET_${PN}-landscape-inverted = "${weston_ini_dir}/weston.ini.landscape-inverted"
diff --git a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bbappend b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bbappend
index 88590c602..c4cf6c152 100644
--- a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bbappend
+++ b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bbappend
@@ -1,12 +1,12 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-WESTON_DISPLAYS_append = "${@bb.utils.contains("DISTRO_FEATURES", "weston-remoting", " remote-output", "", d)}"
-WESTON_DISPLAYS_append = "${@bb.utils.contains("AGL_FEATURES", "waltham-remoting", " transmitter-output", "", d)}"
+WESTON_DISPLAYS:append = "${@bb.utils.contains("DISTRO_FEATURES", "weston-remoting", " remote-output", "", d)}"
+WESTON_DISPLAYS:append = "${@bb.utils.contains("AGL_FEATURES", "waltham-remoting", " transmitter-output", "", d)}"
# For virtual machines and intel-corei7-64 we want to support both the HDMI-A-1
# and Virtual-1 outputs. This allows us to run virtual images on real hardware
# and vice versa.
-WESTON_DISPLAYS_append_qemuall = " virtual-270"
-WESTON_DISPLAYS_append_intel-corei7-64 = " virtual-270"
+WESTON_DISPLAYS:append:qemuall = " virtual-270"
+WESTON_DISPLAYS:append:intel-corei7-64 = " virtual-270"
diff --git a/meta-agl-core/recipes-graphics/wayland/weston-init_aglcore.inc b/meta-agl-core/recipes-graphics/wayland/weston-init_aglcore.inc
index fc6ab5d97..896f1eafb 100644
--- a/meta-agl-core/recipes-graphics/wayland/weston-init_aglcore.inc
+++ b/meta-agl-core/recipes-graphics/wayland/weston-init_aglcore.inc
@@ -1,8 +1,8 @@
SYSTEMD_AUTO_ENABLE = "enable"
-do_install_append() {
+do_install:append() {
# Remove upstream weston.ini to avoid conflict with weston-ini-conf package
rm -f ${D}${sysconfdir}/xdg/weston/weston.ini
}
-RDEPENDS_${PN} += "weston-ini"
+RDEPENDS:${PN} += "weston-ini"
diff --git a/meta-agl-core/recipes-graphics/wayland/weston_8.0_aglcore.inc b/meta-agl-core/recipes-graphics/wayland/weston_8.0_aglcore.inc
index d29d09f7f..d5cd5381a 100644
--- a/meta-agl-core/recipes-graphics/wayland/weston_8.0_aglcore.inc
+++ b/meta-agl-core/recipes-graphics/wayland/weston_8.0_aglcore.inc
@@ -1,14 +1,14 @@
-FILESEXTRAPATHS_append := ":${THISDIR}/weston"
+FILESEXTRAPATHS:append := ":${THISDIR}/weston"
-SRC_URI_append = "\
+SRC_URI:append = "\
file://0005-correctly-tear-down-drm-backend.patch \
"
# Workaround for incorrect upstream definition
PACKAGECONFIG[remoting] = "-Dremoting=true,-Dremoting=false,gstreamer1.0 gstreamer1.0-plugins-base"
PACKAGECONFIG[headless] = "-Dbackend-headless=true"
-PACKAGECONFIG_append = "${@bb.utils.contains('DISTRO_FEATURES', 'weston-remoting', ' remoting', '', d)}"
-PACKAGECONFIG_append = "${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', ' remoting', '', d)}"
+PACKAGECONFIG:append = "${@bb.utils.contains('DISTRO_FEATURES', 'weston-remoting', ' remoting', '', d)}"
+PACKAGECONFIG:append = "${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', ' remoting', '', d)}"
# seat management is only for waltham-transmitter-plugin
-SRC_URI_append = "${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'file://0001-libweston-Migrate-weston_seat_init-release-to-public.patch', '', d)}"
+SRC_URI:append = "${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'file://0001-libweston-Migrate-weston_seat_init-release-to-public.patch', '', d)}"