summaryrefslogtreecommitdiffstats
path: root/meta-agl-core/recipes-platform/images
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-08-02 17:10:51 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-08-23 11:56:42 +0000
commitdd6fc5dcaa0a027b7651bb365d5dd0f623498f8f (patch)
tree428562251f7033e4d44c848e7258243fb9421a94 /meta-agl-core/recipes-platform/images
parent756165e01db655cdbd2788eb134fba79fea7fd90 (diff)
Convert to new override syntax
This is mostly the result of running a slightly customized version of the convert-overrides.py script from poky with additional overrides added. A few minor fixups were done by hand afterwards during a review of the changes. The intent of these changes is to minimize the effort to keep the "next" branch that builds against poky master up to date and tested in preparation for the switch to the next Yocto LTS release in early 2022. Bug-AGL: SPEC-4052 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ia3bf63b7cb1aa1d95ada373d1a3ab56def0a125d Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/26564 Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-core/recipes-platform/images')
-rw-r--r--meta-agl-core/recipes-platform/images/agl-image-boot.bb2
-rw-r--r--meta-agl-core/recipes-platform/images/agl-image-core-autobuilder.bb2
-rw-r--r--meta-agl-core/recipes-platform/images/agl-image-minimal-crosssdk.inc6
-rw-r--r--meta-agl-core/recipes-platform/images/agl-image-minimal.bb2
-rw-r--r--meta-agl-core/recipes-platform/images/agl-image-weston.bb2
5 files changed, 7 insertions, 7 deletions
diff --git a/meta-agl-core/recipes-platform/images/agl-image-boot.bb b/meta-agl-core/recipes-platform/images/agl-image-boot.bb
index 84cdbcf31..6e2b89324 100644
--- a/meta-agl-core/recipes-platform/images/agl-image-boot.bb
+++ b/meta-agl-core/recipes-platform/images/agl-image-boot.bb
@@ -4,6 +4,6 @@ require agl-image-boot.inc
LICENSE = "MIT"
-IMAGE_INSTALL_append = "\
+IMAGE_INSTALL:append = "\
packagegroup-agl-image-boot \
"
diff --git a/meta-agl-core/recipes-platform/images/agl-image-core-autobuilder.bb b/meta-agl-core/recipes-platform/images/agl-image-core-autobuilder.bb
index 866d98177..3a887a5c0 100644
--- a/meta-agl-core/recipes-platform/images/agl-image-core-autobuilder.bb
+++ b/meta-agl-core/recipes-platform/images/agl-image-core-autobuilder.bb
@@ -4,7 +4,7 @@ require agl-image-weston.inc
LICENSE = "MIT"
-IMAGE_INSTALL_append = "\
+IMAGE_INSTALL:append = "\
packagegroup-agl-profile-graphical \
busybox \
psplash \
diff --git a/meta-agl-core/recipes-platform/images/agl-image-minimal-crosssdk.inc b/meta-agl-core/recipes-platform/images/agl-image-minimal-crosssdk.inc
index a69e698a1..8695d8d4b 100644
--- a/meta-agl-core/recipes-platform/images/agl-image-minimal-crosssdk.inc
+++ b/meta-agl-core/recipes-platform/images/agl-image-minimal-crosssdk.inc
@@ -1,5 +1,5 @@
-IMAGE_FEATURES_append = " dev-pkgs"
-IMAGE_INSTALL_append = " kernel-dev kernel-devsrc"
+IMAGE_FEATURES:append = " dev-pkgs"
+IMAGE_INSTALL:append = " kernel-dev kernel-devsrc"
@@ -8,7 +8,7 @@ IMAGE_INSTALL_append = " kernel-dev kernel-devsrc"
# FIXME:
# Always include the test widgets
-#IMAGE_FEATURES_append = " agl-test-wgt"
+#IMAGE_FEATURES:append = " agl-test-wgt"
#
# Required dependencies for app and test builds
#TOOLCHAIN_HOST_TASK += " \
diff --git a/meta-agl-core/recipes-platform/images/agl-image-minimal.bb b/meta-agl-core/recipes-platform/images/agl-image-minimal.bb
index 1fd213d0f..52cc06aeb 100644
--- a/meta-agl-core/recipes-platform/images/agl-image-minimal.bb
+++ b/meta-agl-core/recipes-platform/images/agl-image-minimal.bb
@@ -4,6 +4,6 @@ require agl-image-minimal.inc
LICENSE = "MIT"
-IMAGE_INSTALL_append = "\
+IMAGE_INSTALL:append = "\
packagegroup-agl-image-minimal \
"
diff --git a/meta-agl-core/recipes-platform/images/agl-image-weston.bb b/meta-agl-core/recipes-platform/images/agl-image-weston.bb
index bbb61c922..7e9f8814e 100644
--- a/meta-agl-core/recipes-platform/images/agl-image-weston.bb
+++ b/meta-agl-core/recipes-platform/images/agl-image-weston.bb
@@ -4,6 +4,6 @@ require agl-image-weston.inc
LICENSE = "MIT"
-IMAGE_INSTALL_append = "\
+IMAGE_INSTALL:append = "\
packagegroup-agl-profile-graphical \
"