summaryrefslogtreecommitdiffstats
path: root/meta-agl-flutter/recipes-platform/images/agl-image-flutter-debug.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-06-25 15:39:12 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-06-26 10:42:40 +0000
commitdbb228360317872e7c6fcbd96faaf404535130c3 (patch)
tree361355a3459eb764df0b1a28490615da442fe05d /meta-agl-flutter/recipes-platform/images/agl-image-flutter-debug.bb
parent9c99d6680bc5bd3e14085f2b58301ef52144a937 (diff)
Add meta-agl-flutter
Add meta-agl-flutter layer as it is being moved from meta-agl-devel. The files are copies of the state in meta-agl-devel as of commit 97310e35, with only a minor change to the feature template to adjust the location of the layer for bblayers.conf. Bug-AGL: SPEC-5184 Change-Id: I9a14e4ab3a1b1726b0ccc1dbc112d76864dd106c Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/30016 Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-flutter/recipes-platform/images/agl-image-flutter-debug.bb')
-rw-r--r--meta-agl-flutter/recipes-platform/images/agl-image-flutter-debug.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-agl-flutter/recipes-platform/images/agl-image-flutter-debug.bb b/meta-agl-flutter/recipes-platform/images/agl-image-flutter-debug.bb
new file mode 100644
index 000000000..c9c1f2980
--- /dev/null
+++ b/meta-agl-flutter/recipes-platform/images/agl-image-flutter-debug.bb
@@ -0,0 +1,29 @@
+require recipes-platform/images/agl-image-compositor.bb
+
+SUMMARY = "Example Flutter application debug image for development"
+LICENSE = "MIT"
+
+CLANGSDK = "1"
+
+# NOTES:
+# - the package-management IMAGE_FEATURE and packagegroup-agl-core-devel
+# are explicitly added here to cover the usecase of building without
+# passing agl-devel to aglsetup.sh. This is explicitly a debug image
+# where those are are always desired.
+# - Getting the debug version of the application requires changing
+# the value of FLUTTER_APP_RUNTIME_MODES to include "debug",
+# which is outside the scope of this image recipe.
+
+IMAGE_FEATURES += "ssh-server-openssh package-management dbg-pkgs"
+
+IMAGE_INSTALL += "\
+ packagegroup-agl-core-devel \
+ \
+ weston-ini-conf-landscape \
+ \
+ flutter-auto-verbose-logs \
+ \
+ flutter-engine-sdk-dev \
+ \
+ flutter-gallery \
+"