summaryrefslogtreecommitdiffstats
path: root/meta-agl-kuksa-val/recipes-connectivity/kuksa-val/kuksa-databroker/0001-Remove-protobuf-src-usage.patch
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-06-26 15:22:14 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-06-27 09:53:39 +0000
commit2460f6ac99d834f00dfa6e26546c41eac6cd38c9 (patch)
tree1e9d6714f63bc29f8e31e5007c162e1df3d6406b /meta-agl-kuksa-val/recipes-connectivity/kuksa-val/kuksa-databroker/0001-Remove-protobuf-src-usage.patch
parentdbb228360317872e7c6fcbd96faaf404535130c3 (diff)
Add meta-agl-kuksa-val
Add new meta-agl-kuksa-val layer, and populate it with the base KUKSA.val databroker and VSS schema recipes from meta-agl, as well as the recipes for the Python modules they depend on. Additional changes: - Installation of AGL-specific configuration has been removed from the kuksa-can-provider recipe. It now packages the upstream example/test configuration in a new kuksa-can-provider-conf-example package that can be replaced via the RPROVIDES scheme. Some minor tweaks for paths are made to the upstream .ini file to match FHS expectations. Bug-AGL: SPEC-5136 Change-Id: I3128a223f4fcf16e496cb27e26afcaee0a28979a Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/30040 Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-kuksa-val/recipes-connectivity/kuksa-val/kuksa-databroker/0001-Remove-protobuf-src-usage.patch')
-rw-r--r--meta-agl-kuksa-val/recipes-connectivity/kuksa-val/kuksa-databroker/0001-Remove-protobuf-src-usage.patch133
1 files changed, 133 insertions, 0 deletions
diff --git a/meta-agl-kuksa-val/recipes-connectivity/kuksa-val/kuksa-databroker/0001-Remove-protobuf-src-usage.patch b/meta-agl-kuksa-val/recipes-connectivity/kuksa-val/kuksa-databroker/0001-Remove-protobuf-src-usage.patch
new file mode 100644
index 000000000..c6c2381d6
--- /dev/null
+++ b/meta-agl-kuksa-val/recipes-connectivity/kuksa-val/kuksa-databroker/0001-Remove-protobuf-src-usage.patch
@@ -0,0 +1,133 @@
+From 953c80a2acc2bbb882a2dcbbbf0eae7098cbd1fa Mon Sep 17 00:00:00 2001
+From: Scott Murray <scott.murray@konsulko.com>
+Date: Tue, 18 Jun 2024 15:53:46 -0400
+Subject: [PATCH] Remove protobuf-src usage
+
+The vendoring of a protoc and libprotobuf build that was added in
+commit 890703c9 by using protobuf-src is not really workable with
+OpenEmbedded / Yocto Project, and somewhat undesirable for any
+distribution package builds when it comes to transparency and
+reproducibility. Remove it so that building in OE/YP will work.
+
+Upstream-Status: Pending
+
+Signed-off-by: Scott Murray <scott.murray@konsulko.com>
+---
+ Cargo.lock | 19 -------------------
+ databroker-proto/Cargo.toml | 1 -
+ databroker-proto/build.rs | 1 -
+ lib/Cargo.lock | 19 -------------------
+ 4 files changed, 40 deletions(-)
+
+diff --git a/Cargo.lock b/Cargo.lock
+index eb212b0..fdce813 100644
+--- a/Cargo.lock
++++ b/Cargo.lock
+@@ -162,15 +162,6 @@ version = "1.3.0"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+ checksum = "0c4b4d0bd25bd0b74681c0ad21497610ce1b7c91b1022cd21c80c6fbdd9476b0"
+
+-[[package]]
+-name = "autotools"
+-version = "0.2.7"
+-source = "registry+https://github.com/rust-lang/crates.io-index"
+-checksum = "ef941527c41b0fc0dd48511a8154cd5fc7e29200a0ff8b7203c5d777dbc795cf"
+-dependencies = [
+- "cc",
+-]
+-
+ [[package]]
+ name = "axum"
+ version = "0.6.20"
+@@ -650,7 +641,6 @@ version = "0.4.5"
+ dependencies = [
+ "prost",
+ "prost-types",
+- "protobuf-src",
+ "tonic",
+ "tonic-build",
+ ]
+@@ -2322,15 +2312,6 @@ dependencies = [
+ "prost",
+ ]
+
+-[[package]]
+-name = "protobuf-src"
+-version = "1.1.0+21.5"
+-source = "registry+https://github.com/rust-lang/crates.io-index"
+-checksum = "c7ac8852baeb3cc6fb83b93646fb93c0ffe5d14bf138c945ceb4b9948ee0e3c1"
+-dependencies = [
+- "autotools",
+-]
+-
+ [[package]]
+ name = "quote"
+ version = "1.0.36"
+diff --git a/databroker-proto/Cargo.toml b/databroker-proto/Cargo.toml
+index 9d548b2..2f4a7f1 100644
+--- a/databroker-proto/Cargo.toml
++++ b/databroker-proto/Cargo.toml
+@@ -25,4 +25,3 @@ prost-types = { workspace = true }
+
+ [build-dependencies]
+ tonic-build = { workspace = true, features = ["transport", "prost"] }
+-protobuf-src = "1.1.0"
+diff --git a/databroker-proto/build.rs b/databroker-proto/build.rs
+index d02a006..d3a70ac 100644
+--- a/databroker-proto/build.rs
++++ b/databroker-proto/build.rs
+@@ -12,7 +12,6 @@
+ ********************************************************************************/
+
+ fn main() -> Result<(), Box<dyn std::error::Error>> {
+- std::env::set_var("PROTOC", protobuf_src::protoc());
+ tonic_build::configure()
+ .compile_well_known_types(false)
+ .protoc_arg("--experimental_allow_proto3_optional")
+diff --git a/lib/Cargo.lock b/lib/Cargo.lock
+index 5ba0b78..7dc93f3 100644
+--- a/lib/Cargo.lock
++++ b/lib/Cargo.lock
+@@ -71,15 +71,6 @@ version = "1.3.0"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+ checksum = "0c4b4d0bd25bd0b74681c0ad21497610ce1b7c91b1022cd21c80c6fbdd9476b0"
+
+-[[package]]
+-name = "autotools"
+-version = "0.2.7"
+-source = "registry+https://github.com/rust-lang/crates.io-index"
+-checksum = "ef941527c41b0fc0dd48511a8154cd5fc7e29200a0ff8b7203c5d777dbc795cf"
+-dependencies = [
+- "cc",
+-]
+-
+ [[package]]
+ name = "axum"
+ version = "0.6.20"
+@@ -182,7 +173,6 @@ version = "0.4.5"
+ dependencies = [
+ "prost",
+ "prost-types",
+- "protobuf-src",
+ "tonic 0.11.0",
+ "tonic-build",
+ ]
+@@ -663,15 +653,6 @@ dependencies = [
+ "prost",
+ ]
+
+-[[package]]
+-name = "protobuf-src"
+-version = "1.1.0+21.5"
+-source = "registry+https://github.com/rust-lang/crates.io-index"
+-checksum = "c7ac8852baeb3cc6fb83b93646fb93c0ffe5d14bf138c945ceb4b9948ee0e3c1"
+-dependencies = [
+- "autotools",
+-]
+-
+ [[package]]
+ name = "quote"
+ version = "1.0.36"
+--
+2.44.0
+