summaryrefslogtreecommitdiffstats
path: root/meta-agl-kuksa-val/recipes-devtools/python/python3-anytree_2.9.2.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-11-20 19:14:22 -0500
committerScott Murray <scott.murray@konsulko.com>2024-11-23 20:25:56 +0000
commitd21658f508c70859907f4c1687b623cadaf2c3d3 (patch)
tree66d022dae368d2aee48c826e4dd4d7a9faa2d1ee /meta-agl-kuksa-val/recipes-devtools/python/python3-anytree_2.9.2.bb
parent19d54a057aa6eca348bbf9847d7dd8804006cd4f (diff)
meta-agl-kuksa-val: upgrade to VSS 5.0
Update the vss-tools and vss recipes to upgrade to the 5.0 release. This requires some updates to the supplied Python module recipes for vss-tools, including some new bbappends to enable native support for a few modules. Bug-AGL: SPEC-5299 Change-Id: Idb6a5f4d28a05dc7040a09465f6d903631bcadef Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/30533
Diffstat (limited to 'meta-agl-kuksa-val/recipes-devtools/python/python3-anytree_2.9.2.bb')
-rw-r--r--meta-agl-kuksa-val/recipes-devtools/python/python3-anytree_2.9.2.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-agl-kuksa-val/recipes-devtools/python/python3-anytree_2.9.2.bb b/meta-agl-kuksa-val/recipes-devtools/python/python3-anytree_2.9.2.bb
new file mode 100644
index 000000000..7965ea8df
--- /dev/null
+++ b/meta-agl-kuksa-val/recipes-devtools/python/python3-anytree_2.9.2.bb
@@ -0,0 +1,16 @@
+SUMMARY = "Powerful and Lightweight Python Tree Data Structure"
+HOMEPAGE = "https://github.com/c0fec0de/anytree"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+PYPI_PACKAGE = "anytree"
+
+SRC_URI[sha256sum] = "e02af617d41ede47f922e5deea0e4efc3201c6e7330cfc1265409762e5381283"
+
+inherit pypi python_poetry_core
+
+RDEPENDS:${PN} += " \
+ python3-six \
+"
+
+BBCLASSEXTEND += "native nativesdk"