summaryrefslogtreecommitdiffstats
path: root/meta-agl-kuksa-val/recipes-devtools/python/python3-jsonpath-ng_1.5.3.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-06-26 15:22:14 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-06-27 09:53:39 +0000
commit2460f6ac99d834f00dfa6e26546c41eac6cd38c9 (patch)
tree1e9d6714f63bc29f8e31e5007c162e1df3d6406b /meta-agl-kuksa-val/recipes-devtools/python/python3-jsonpath-ng_1.5.3.bb
parentdbb228360317872e7c6fcbd96faaf404535130c3 (diff)
Add meta-agl-kuksa-val
Add new meta-agl-kuksa-val layer, and populate it with the base KUKSA.val databroker and VSS schema recipes from meta-agl, as well as the recipes for the Python modules they depend on. Additional changes: - Installation of AGL-specific configuration has been removed from the kuksa-can-provider recipe. It now packages the upstream example/test configuration in a new kuksa-can-provider-conf-example package that can be replaced via the RPROVIDES scheme. Some minor tweaks for paths are made to the upstream .ini file to match FHS expectations. Bug-AGL: SPEC-5136 Change-Id: I3128a223f4fcf16e496cb27e26afcaee0a28979a Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/30040 Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-kuksa-val/recipes-devtools/python/python3-jsonpath-ng_1.5.3.bb')
-rw-r--r--meta-agl-kuksa-val/recipes-devtools/python/python3-jsonpath-ng_1.5.3.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-agl-kuksa-val/recipes-devtools/python/python3-jsonpath-ng_1.5.3.bb b/meta-agl-kuksa-val/recipes-devtools/python/python3-jsonpath-ng_1.5.3.bb
new file mode 100644
index 000000000..4c3dfaa94
--- /dev/null
+++ b/meta-agl-kuksa-val/recipes-devtools/python/python3-jsonpath-ng_1.5.3.bb
@@ -0,0 +1,15 @@
+SUMMARY = "A final implementation of JSONPath for Python that aims to be standard compliant, including arithmetic and binary comparison operators and providing clear AST for metaprogramming."
+HOMEPAGE = "https://github.com/h2non/jsonpath-ng"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+PYPI_PACKAGE = "jsonpath-ng"
+
+SRC_URI[sha256sum] = "a273b182a82c1256daab86a313b937059261b5c5f8c4fa3fc38b882b344dd567"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ python3-ply \
+ python3-six \
+"