summaryrefslogtreecommitdiffstats
path: root/meta-agl-kuksa-val/recipes-devtools/python/python3-rich-click_1.8.4.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-11-20 19:14:22 -0500
committerScott Murray <scott.murray@konsulko.com>2024-11-23 20:25:56 +0000
commitd21658f508c70859907f4c1687b623cadaf2c3d3 (patch)
tree66d022dae368d2aee48c826e4dd4d7a9faa2d1ee /meta-agl-kuksa-val/recipes-devtools/python/python3-rich-click_1.8.4.bb
parent19d54a057aa6eca348bbf9847d7dd8804006cd4f (diff)
meta-agl-kuksa-val: upgrade to VSS 5.0
Update the vss-tools and vss recipes to upgrade to the 5.0 release. This requires some updates to the supplied Python module recipes for vss-tools, including some new bbappends to enable native support for a few modules. Bug-AGL: SPEC-5299 Change-Id: Idb6a5f4d28a05dc7040a09465f6d903631bcadef Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/30533
Diffstat (limited to 'meta-agl-kuksa-val/recipes-devtools/python/python3-rich-click_1.8.4.bb')
-rw-r--r--meta-agl-kuksa-val/recipes-devtools/python/python3-rich-click_1.8.4.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-agl-kuksa-val/recipes-devtools/python/python3-rich-click_1.8.4.bb b/meta-agl-kuksa-val/recipes-devtools/python/python3-rich-click_1.8.4.bb
new file mode 100644
index 000000000..e442774a9
--- /dev/null
+++ b/meta-agl-kuksa-val/recipes-devtools/python/python3-rich-click_1.8.4.bb
@@ -0,0 +1,17 @@
+SUMMARY = "A shim around Click that renders help output nicely using Rich."
+HOMEPAGE = "https://github.com/ewels/rich-click"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5372b77c3720be60b7eff9a9a5c0000d"
+
+PYPI_PACKAGE = "rich_click"
+
+SRC_URI[sha256sum] = "0f49471f04439269d0e66a6f43120f52d11d594869a2a0be600cfb12eb0616b9"
+
+inherit pypi python_setuptools_build_meta
+
+RDEPENDS:${PN} += " \
+ python3-click \
+ python3-rich \
+"
+
+BBCLASSEXTEND += "native nativesdk"