summaryrefslogtreecommitdiffstats
path: root/meta-agl-kuksa-val/recipes-support/vss/vss-tools_5.0.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-11-20 19:14:22 -0500
committerScott Murray <scott.murray@konsulko.com>2024-11-23 20:25:56 +0000
commitd21658f508c70859907f4c1687b623cadaf2c3d3 (patch)
tree66d022dae368d2aee48c826e4dd4d7a9faa2d1ee /meta-agl-kuksa-val/recipes-support/vss/vss-tools_5.0.bb
parent19d54a057aa6eca348bbf9847d7dd8804006cd4f (diff)
meta-agl-kuksa-val: upgrade to VSS 5.0
Update the vss-tools and vss recipes to upgrade to the 5.0 release. This requires some updates to the supplied Python module recipes for vss-tools, including some new bbappends to enable native support for a few modules. Bug-AGL: SPEC-5299 Change-Id: Idb6a5f4d28a05dc7040a09465f6d903631bcadef Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/30533
Diffstat (limited to 'meta-agl-kuksa-val/recipes-support/vss/vss-tools_5.0.bb')
-rw-r--r--meta-agl-kuksa-val/recipes-support/vss/vss-tools_5.0.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-agl-kuksa-val/recipes-support/vss/vss-tools_5.0.bb b/meta-agl-kuksa-val/recipes-support/vss/vss-tools_5.0.bb
new file mode 100644
index 000000000..7743efbd7
--- /dev/null
+++ b/meta-agl-kuksa-val/recipes-support/vss/vss-tools_5.0.bb
@@ -0,0 +1,31 @@
+SUMMARY = "COVESA Vehicle Signal Specification tooling."
+HOMEPAGE = "https://github.com/COVESA/vss-tools"
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=9741c346eef56131163e13b9db1241b3"
+
+SRC_URI = "git://github.com/COVESA/vss-tools.git;protocol=https;branch=release/5.0"
+SRCREV = "9ba7f40c0995358a293aab729d57739c3e9b2829"
+
+S = "${WORKDIR}/git"
+
+inherit python_poetry_core
+
+RDEPENDS:${PN} += " \
+ python3-core \
+ python3-ctypes \
+ python3-email \
+ python3-importlib-metadata \
+ python3-json \
+ python3-logging \
+ python3-netclient \
+ python3-pkg-resources \
+ python3-anytree \
+ python3-deprecation \
+ python3-graphql-core \
+ python3-pyyaml \
+ python3-six \
+ python3-pydantic \
+ python3-rich-click \
+"
+
+BBCLASSEXTEND += "native nativesdk"