summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core/recipes-apis
diff options
context:
space:
mode:
authorMatt Porter <mporter@konsulko.com>2018-06-18 21:01:14 -0400
committerMatt Porter <mporter@konsulko.com>2018-06-18 23:21:27 -0400
commit42fe1682b35fb76d6916584bb3f693a6959b6532 (patch)
treef59b987344ca2790ce84a0eb1a8fe07d080f9677 /meta-agl-profile-core/recipes-apis
parentd89ae471de67da6a1d6b392652f3622fb0f7ea4b (diff)
Add bluetooth pbap binding recipe
Add the Bluetooth PBAP binding recipe to the core profile. This brings in bluez obexd as a runtime dependency. Bug-AGL: SPEC-1517 Change-Id: I3de18f7e6453e34eb8b6575a5908691f23ff5809 Signed-off-by: Matt Porter <mporter@konsulko.com>
Diffstat (limited to 'meta-agl-profile-core/recipes-apis')
-rw-r--r--meta-agl-profile-core/recipes-apis/agl-service-bluetooth-pbap/agl-service-bluetooth-pbap_git.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-agl-profile-core/recipes-apis/agl-service-bluetooth-pbap/agl-service-bluetooth-pbap_git.bb b/meta-agl-profile-core/recipes-apis/agl-service-bluetooth-pbap/agl-service-bluetooth-pbap_git.bb
new file mode 100644
index 000000000..e6328b718
--- /dev/null
+++ b/meta-agl-profile-core/recipes-apis/agl-service-bluetooth-pbap/agl-service-bluetooth-pbap_git.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Bluetooth PBAP Service Binding"
+DESCRIPTION = "AGL Bluetooth PBAP Service Binding"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-service-bluetooth-pbap"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-bluetooth-pbap;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+DEPENDS = "glib-2.0 json-c"
+RDEPENDS_${PN} = "bluez5-obex"
+
+inherit cmake aglwgt pkgconfig