summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping-ci_1.0.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-01-13 17:54:12 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-01-14 16:35:52 +0000
commit1d7769b7c0b379e68b46680a6dd3ebc4ab1e71a4 (patch)
treef0bbb91c531b794aa461afdaf70a3f6c066cda0e /meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping-ci_1.0.bb
parent318055748074b44261845d1a0a72901c1f1e6cab (diff)
meta-agl-profile-core: Add dev-mapping-ci recipe
Add a dev-mapping-ci recipe that installs a CI specific version of /etc/dev-mapping.conf for the agl-service-can-low-level binding. Additionally, the now required "j1939" bus mapping has been added to the default dev-mapping recipe's conf file. To enable use of the new recipe, the definition of the variable PREFERRED_RPROVIDER_virtual/low-can-dev-mapping has been updated in poky-agl.conf to enables it based on the AGLCI DISTRO_FEATURE. Bug-AGL: SPEC-3756 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ia980ed5e556bad9097ca0c305d1e26b21b10a9ac Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25908 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping-ci_1.0.bb')
-rw-r--r--meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping-ci_1.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping-ci_1.0.bb b/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping-ci_1.0.bb
new file mode 100644
index 000000000..cbba57308
--- /dev/null
+++ b/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping-ci_1.0.bb
@@ -0,0 +1,18 @@
+SUMMARY = "AGL demo device mapping configuration file"
+DESCRIPTION = "This provides a default dev-mapping.conf file \
+ that defines mapping between kernel device and logical name \
+ used in the low-can binding for the AGL CI setup."
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI += "file://dev-mapping.conf.ci"
+
+inherit allarch
+
+do_install() {
+ install -d ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/dev-mapping.conf.ci ${D}${sysconfdir}/dev-mapping.conf
+}
+
+RPROVIDES_${PN} = "virtual/low-can-dev-mapping"