summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core/recipes-connectivity/bluez5/bluez5_%.bbappend
diff options
context:
space:
mode:
authorMatt Ranostay <matt.ranostay@konsulko.com>2020-02-26 08:23:38 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-03-12 17:14:13 +0000
commitb1c5541c24b1e64d84826df6c0e573ab2c83a4fe (patch)
tree659392803594f3ad897a8b58aac0a0a916f2d79b /meta-agl-profile-core/recipes-connectivity/bluez5/bluez5_%.bbappend
parentcb80cac9d42a0f5477d1833165ac4af334eb2e71 (diff)
bluez: workaround aclmtu issue on OBEX transfers
Default MTU of 310 causes PBAP/OBEX transactions to timeout before completing the entire transfer from coming from paired iOS device. Change this to 930 to avoid timeouts. This is a workaround till a better solution is devised. Bug-AGL: SPEC-3206 Change-Id: I48bdc6107ac9176397bc0137496946c42b1c95d7 Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
Diffstat (limited to 'meta-agl-profile-core/recipes-connectivity/bluez5/bluez5_%.bbappend')
-rw-r--r--meta-agl-profile-core/recipes-connectivity/bluez5/bluez5_%.bbappend3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-agl-profile-core/recipes-connectivity/bluez5/bluez5_%.bbappend b/meta-agl-profile-core/recipes-connectivity/bluez5/bluez5_%.bbappend
index 9ee1db24e..db5b09503 100644
--- a/meta-agl-profile-core/recipes-connectivity/bluez5/bluez5_%.bbappend
+++ b/meta-agl-profile-core/recipes-connectivity/bluez5/bluez5_%.bbappend
@@ -3,6 +3,7 @@ SRC_URI_append = " \
file://bluetooth.conf \
file://tmpdir.conf \
file://obex.service \
+ file://bluetooth.service \
file://0001-obex-report-notification-status-on-incoming-message.patch \
"
@@ -18,5 +19,7 @@ do_install_append() {
install -m 0644 ${WORKDIR}/tmpdir.conf ${D}${systemd_user_unitdir}/obex.service.d/tmpdir.conf
mkdir -p ${D}/etc/systemd/user
ln -sf ${systemd_user_unitdir}/obex.service ${D}/etc/systemd/user/dbus-org.bluez.obex.service
+ mkdir -p ${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/bluetooth.service ${D}${systemd_system_unitdir}
fi
}