summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core/recipes-platform/packagegroups/packagegroup-agl-core-os-commonlibs.bb
diff options
context:
space:
mode:
authorronan <ronan.lemartret@iot.bzh>2020-12-15 21:17:10 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-12-17 13:47:06 +0000
commitc1e048fc05542d859115990312e0753ce2dea72e (patch)
tree358ef537e41ebc97c0f9fb2ee8cd1dc748ba6adb /meta-agl-profile-core/recipes-platform/packagegroups/packagegroup-agl-core-os-commonlibs.bb
parenta39849e1170bc931ca5bbcbae1445fabb8ca25cd (diff)
[RCAR] disable a default config in kernel
The meta-rcar layer activates by default the configuration MTD_RENESAS_RPC_HYPERFLASH in kernel. MTD_RENESAS_RPC_HYPERFLASH is not upstream, it's a meta-rcar specific feature. MTD_RENESAS_RPC_HYPERFLASH feature in the kernel need an firmware update on the board and can be considered (IMHO) as a security issues in production. We need to set DISABLE_RPC_ACCESS to deactivate it. v2 (jsmoeller): Use ?= for DISABLE_RPC_ACCESS . Bug-AGL: SPEC-3674 Signed-off-by: ronan <ronan.lemartret@iot.bzh> Change-Id: Iefaf9ca115d1fb805b0d3766fc0c800b74daecee Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25815 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-profile-core/recipes-platform/packagegroups/packagegroup-agl-core-os-commonlibs.bb')
0 files changed, 0 insertions, 0 deletions
ral.String.Interpol */ .highlight .sx { color: #22bb22; background-color: #f0fff0 } /* Literal.String.Other */ .highlight .sr { color: #008800; background-color: #fff0ff } /* Literal.String.Regex */ .highlight .s1 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Single */ .highlight .ss { color: #aa6600; background-color: #fff0f0 } /* Literal.String.Symbol */ .highlight .bp { color: #003388 } /* Name.Builtin.Pseudo */ .highlight .fm { color: #0066bb; font-weight: bold } /* Name.Function.Magic */ .highlight .vc { color: #336699 } /* Name.Variable.Class */ .highlight .vg { color: #dd7700 } /* Name.Variable.Global */ .highlight .vi { color: #3333bb } /* Name.Variable.Instance */ .highlight .vm { color: #336699 } /* Name.Variable.Magic */ .highlight .il { color: #0000DD; font-weight: bold } /* Literal.Number.Integer.Long */
From 40ff644ac4da90c5cf5239c6ee6051d9bb2b099a Mon Sep 17 00:00:00 2001
From: Daniel Stone <daniels@collabora.com>
Date: Mon, 25 Nov 2019 10:30:11 +0000
Subject: [PATCH] config-parser: Export get_full_path and destroy

Make sure we export the get_full_path() accessor (declared in the
header, used by Weston itself) and the parser's destroy function.

Signed-off-by: Daniel Stone <daniels@collabora.com>
---
 shared/config-parser.c | 2 ++
 1 file changed, 2 insertions(+)

diff --git a/shared/config-parser.c b/shared/config-parser.c
index 35f09f006..94eb24cc1 100644
--- a/shared/config-parser.c
+++ b/shared/config-parser.c
@@ -470,6 +470,7 @@ weston_config_parse(const char *name)
 	return config;
 }
 
+WL_EXPORT
 const char *
 weston_config_get_full_path(struct weston_config *config)
 {
@@ -500,6 +501,7 @@ weston_config_next_section(struct weston_config *config,
 	return 1;
 }
 
+WL_EXPORT
 void
 weston_config_destroy(struct weston_config *config)
 {
-- 
2.21.0