aboutsummaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core/recipes-test/blobsallad/blobsallad_2006-11-14-23-57.bb
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-04-16 22:14:52 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-04-20 17:07:06 +0200
commitbb0882c5dad030f676e424265ebcd869bb3ff899 (patch)
treed95bb2d7ad6b5ac47427f73babe015b0ade02342 /meta-agl-profile-core/recipes-test/blobsallad/blobsallad_2006-11-14-23-57.bb
parent97e5e76efa44f55ee9aaf3998bb3df38b829706c (diff)
Introduce meta-agl-profile-core and meta-agl-profile-graphics
Rework towards agl profiles. This change is part of a series of changes to create the AGL profiles. This set will mainly introduce the 'core' profile. It is setup to be a drop-in change, thus some files were kept in (dummy) locations for now. However, they'll be taken care of in the next changes in this series. The main target of the meta-agl-profile-core layer is to host: - a minimal, bootable image with network and package management enabled -- agl-image-boot - a minimal image with network and packagemanagement and the AGL APIs -- agl-image-minimal The layer meta-agl-profile-graphical is used as superset of these and includes support for egl+wayland+weston. All recipes concerning graphics were moved there. This is not a full profile as we still have to migrate some parts of meta-agl-demo in a follow-up changeset. The roadmap as discussed during the F2F session in Karlsruhe is: - week 16 : core profile and profiles w/o graphics - week 17 : graphical profiles - week 18 : final conversion of the demo image v2: moved agl-login-manager from -graphics to -core (see Jose's comment) v3: moved back after discussion - follow-up in separate changeset Change-Id: Idacb0d1274baac1f63f8d1b850d4b1104ac33918 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-profile-core/recipes-test/blobsallad/blobsallad_2006-11-14-23-57.bb')
-rw-r--r--meta-agl-profile-core/recipes-test/blobsallad/blobsallad_2006-11-14-23-57.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-agl-profile-core/recipes-test/blobsallad/blobsallad_2006-11-14-23-57.bb b/meta-agl-profile-core/recipes-test/blobsallad/blobsallad_2006-11-14-23-57.bb
new file mode 100644
index 000000000..373d4ddc6
--- /dev/null
+++ b/meta-agl-profile-core/recipes-test/blobsallad/blobsallad_2006-11-14-23-57.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = ""
+HOMEPAGE = "http://blobsallad.se/"
+LICENSE = "CLOSED"
+LIC_FILES_CHKSUM = ""
+
+SRC_URI = " \
+ http://blobsallad.se/src/blobsallad-src-${PV}.tar.gz \
+ file://0001-Makefile.patch \
+ file://0002-auto.patch \
+ file://0003-printcleanup.patch \
+ file://0004-bs_main.c.patch"
+
+SRC_URI[md5sum] = "a2e3342cbf0f3a4a9b110af2663bed36"
+SRC_URI[sha256sum] = "cd6309df1929d3e6b7bce1dbecc751849aeaafe17c01e05fd2567dc4267faaa2"
+
+DEPENDS = "cairo virtual/libsdl"
+
+INSANE_SKIP_${PN} = "ldflags"
+
+S = "${WORKDIR}/blobsallad-src"
+
+do_configure () {
+ # Specify any needed configure commands here
+ :
+}
+
+do_compile () {
+ # You will almost certainly need to add additional arguments here
+ oe_runmake SDKROOT=${STAGING_DIR_HOST}
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 blobsallad ${D}${bindir}
+}
+