summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core/recipes-test/fontconfig
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-04-16 22:14:52 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-04-20 17:07:06 +0200
commitbb0882c5dad030f676e424265ebcd869bb3ff899 (patch)
treed95bb2d7ad6b5ac47427f73babe015b0ade02342 /meta-agl-profile-core/recipes-test/fontconfig
parent97e5e76efa44f55ee9aaf3998bb3df38b829706c (diff)
Introduce meta-agl-profile-core and meta-agl-profile-graphics
Rework towards agl profiles. This change is part of a series of changes to create the AGL profiles. This set will mainly introduce the 'core' profile. It is setup to be a drop-in change, thus some files were kept in (dummy) locations for now. However, they'll be taken care of in the next changes in this series. The main target of the meta-agl-profile-core layer is to host: - a minimal, bootable image with network and package management enabled -- agl-image-boot - a minimal image with network and packagemanagement and the AGL APIs -- agl-image-minimal The layer meta-agl-profile-graphical is used as superset of these and includes support for egl+wayland+weston. All recipes concerning graphics were moved there. This is not a full profile as we still have to migrate some parts of meta-agl-demo in a follow-up changeset. The roadmap as discussed during the F2F session in Karlsruhe is: - week 16 : core profile and profiles w/o graphics - week 17 : graphical profiles - week 18 : final conversion of the demo image v2: moved agl-login-manager from -graphics to -core (see Jose's comment) v3: moved back after discussion - follow-up in separate changeset Change-Id: Idacb0d1274baac1f63f8d1b850d4b1104ac33918 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-profile-core/recipes-test/fontconfig')
-rw-r--r--meta-agl-profile-core/recipes-test/fontconfig/fontconfig_%.bbappend17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-agl-profile-core/recipes-test/fontconfig/fontconfig_%.bbappend b/meta-agl-profile-core/recipes-test/fontconfig/fontconfig_%.bbappend
new file mode 100644
index 000000000..c4bebdc1f
--- /dev/null
+++ b/meta-agl-profile-core/recipes-test/fontconfig/fontconfig_%.bbappend
@@ -0,0 +1,17 @@
+PACKAGES =+ "fontconfig-test"
+
+do_install_append() {
+ install -m 755 -d ${D}/${datadir}/fontconfig-test
+ install -m 755 ${S}/test/run-test.sh ${D}/${datadir}/fontconfig-test/
+
+ sed -i -e "s/FCLIST=\.\.\/fc\-list\/fc\-list/FCLIST=\/usr\/bin\/fc\-list/g" -e "s/FCCACHE=\.\.\/fc\-cache\/fc\-cache/FCCACHE=\/usr\/bin\/fc\-cache/g" ${D}/${datadir}/fontconfig-test/run-test.sh
+
+ for x in 4x6.pcf 8x16.pcf out.expected fonts.conf.in; do
+ install -m 644 ${S}/test/$x ${D}/${datadir}/fontconfig-test/
+ done
+}
+
+DEBIAN_NOAUTONAME_fontconfig-test = "1"
+FILES_fontconfig-test = "${datadir}/fontconfig-test/*"
+
+