summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core/recipes-test/packagegroups
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-04-16 22:14:52 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-04-20 17:07:06 +0200
commitbb0882c5dad030f676e424265ebcd869bb3ff899 (patch)
treed95bb2d7ad6b5ac47427f73babe015b0ade02342 /meta-agl-profile-core/recipes-test/packagegroups
parent97e5e76efa44f55ee9aaf3998bb3df38b829706c (diff)
Introduce meta-agl-profile-core and meta-agl-profile-graphics
Rework towards agl profiles. This change is part of a series of changes to create the AGL profiles. This set will mainly introduce the 'core' profile. It is setup to be a drop-in change, thus some files were kept in (dummy) locations for now. However, they'll be taken care of in the next changes in this series. The main target of the meta-agl-profile-core layer is to host: - a minimal, bootable image with network and package management enabled -- agl-image-boot - a minimal image with network and packagemanagement and the AGL APIs -- agl-image-minimal The layer meta-agl-profile-graphical is used as superset of these and includes support for egl+wayland+weston. All recipes concerning graphics were moved there. This is not a full profile as we still have to migrate some parts of meta-agl-demo in a follow-up changeset. The roadmap as discussed during the F2F session in Karlsruhe is: - week 16 : core profile and profiles w/o graphics - week 17 : graphical profiles - week 18 : final conversion of the demo image v2: moved agl-login-manager from -graphics to -core (see Jose's comment) v3: moved back after discussion - follow-up in separate changeset Change-Id: Idacb0d1274baac1f63f8d1b850d4b1104ac33918 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-profile-core/recipes-test/packagegroups')
-rw-r--r--meta-agl-profile-core/recipes-test/packagegroups/packagegroup-agl-test.bb57
1 files changed, 57 insertions, 0 deletions
diff --git a/meta-agl-profile-core/recipes-test/packagegroups/packagegroup-agl-test.bb b/meta-agl-profile-core/recipes-test/packagegroups/packagegroup-agl-test.bb
new file mode 100644
index 000000000..1c3412e84
--- /dev/null
+++ b/meta-agl-profile-core/recipes-test/packagegroups/packagegroup-agl-test.bb
@@ -0,0 +1,57 @@
+SUMMARY = "Utilities for testing of AGL"
+DESCRIPTION = "A set of common packages required by testing AGL for Quality Assurance"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-test \
+ packagegroup-agl-test-ltp \
+ packagegroup-ivi-common-test \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ bc \
+ blobsallad \
+ dbench \
+ ebizzy \
+ ffsb \
+ interbench \
+ iozone3 \
+ iperf \
+ ipv6connect \
+ linpack \
+ linus-stress \
+ lmbench \
+ nbench-byte \
+ rt-tests \
+ stress \
+ "
+# to be added, but needs LICENSE_FLAGS_WHITELIST="non-commercial"
+# netperf
+
+# FTBS, SPEC-316
+# himeno
+# FTBS, SPEC-1384
+# trinity
+
+# packagegroup-agl-test-ltp \
+# ltp \
+#
+
+# Packages for shell commands which are required by LTP
+# readelf, logrotate, vsftpd, crontab, sar, arp, ftp,
+# host, rcp, rlogin, rsh, tcpdump, expect, iptables, dnsmasq,
+# pgrep
+RDEPENDS_packagegroup-agl-test-ltp += " \
+ initscripts-functions bind-utils binutils \
+ cronie dnsmasq expect inetutils-ftp inetutils-rsh \
+ iptables logrotate net-tools sysstat tcpdump vsftpd \
+ "
+
+RDEPENDS_packagegroup-ivi-common-test = " \
+ packagegroup-agl-test \
+ "