summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core/recipes-test
diff options
context:
space:
mode:
authorRomain Forlot <romain.forlot@iot.bzh>2018-07-10 16:51:13 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-08-24 15:56:49 +0000
commita42e4e02ed7b9bfba115e936ea4cb5278a04879e (patch)
treef220c311b774ff7015c4330b1a3e284dd8167f11 /meta-agl-profile-core/recipes-test
parent7356fbd2a413142b560158d7cf1e0cc699996ad4 (diff)
Add the afb-test binding in the devel AGL image
This will build afb-test binding and tests it using PTest. Bug-AGL: SPEC-1439 Change-Id: I75d1bbb0a780ca036ab0d653fdcbacda883122f9 Signed-off-by: Romain Forlot <romain.forlot@iot.bzh>
Diffstat (limited to 'meta-agl-profile-core/recipes-test')
-rw-r--r--meta-agl-profile-core/recipes-test/afb-test/afb-test_git.bb25
-rw-r--r--meta-agl-profile-core/recipes-test/afb-test/files/run-ptest3
2 files changed, 28 insertions, 0 deletions
diff --git a/meta-agl-profile-core/recipes-test/afb-test/afb-test_git.bb b/meta-agl-profile-core/recipes-test/afb-test/afb-test_git.bb
new file mode 100644
index 000000000..e846745d7
--- /dev/null
+++ b/meta-agl-profile-core/recipes-test/afb-test/afb-test_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Binding embedding test framework to test others binding"
+DESCRIPTION = "This make testing binding running with Application Framework binder \
+easier by simply test verb return as well as event reception."
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/app-afb-test"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+SECTION = "apps"
+
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/app-afb-test;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "bc634e0d890f8f3f51205f95187f639f73e864a7"
+
+DEPENDS += "lua"
+RDEPENDS_${PN} += "lua bash"
+RDEPENDS_${PN}-ptest += "af-binder"
+
+PV = "5.99-FF.RC4.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+inherit cmake aglwgt pkgconfig ptest
+
+do_install_append() {
+ install -d ${D}${bindir}
+ install -m 775 ${B}/afm-test ${D}${bindir}/afm-test
+}
+
diff --git a/meta-agl-profile-core/recipes-test/afb-test/files/run-ptest b/meta-agl-profile-core/recipes-test/afb-test/files/run-ptest
new file mode 100644
index 000000000..883939a83
--- /dev/null
+++ b/meta-agl-profile-core/recipes-test/afb-test/files/run-ptest
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+afm-test /usr/AGL/apps/testwgt/aftest-test.wgt