aboutsummaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core
diff options
context:
space:
mode:
authorHenrique Ferreiro <hferreiro@igalia.com>2018-11-23 01:24:41 +0100
committerScott Murray <scott.murray@konsulko.com>2018-12-12 00:15:05 +0000
commit47d8a5d6a7b3dd2f55af49d56f1e3b3437e8cf89 (patch)
tree2f91f02da04520c2c244b59e4f64291115b2bc47 /meta-agl-profile-core
parent6145a724a2bbf784063ea259fdcb3e6b95c8cd88 (diff)
Provide fallback time servers to connman
connman NTP client needs some fallback time servers in case it cannot get one from the DHCP server. Bug-AGL: SPEC-1925 Change-Id: I904f49f7d9428a2cc4e90ccea387bf4892f4d38e Signed-off-by: Henrique Ferreiro <hferreiro@igalia.com> (cherry picked from commit 803f03daebb58b3a26462df35f001637f2ddf9a0)
Diffstat (limited to 'meta-agl-profile-core')
-rw-r--r--meta-agl-profile-core/recipes-connectivity/connman/connman_%.bbappend11
-rw-r--r--meta-agl-profile-core/recipes-connectivity/connman/files/main.conf2
2 files changed, 12 insertions, 1 deletions
diff --git a/meta-agl-profile-core/recipes-connectivity/connman/connman_%.bbappend b/meta-agl-profile-core/recipes-connectivity/connman/connman_%.bbappend
index e41cbe954..57406fa0a 100644
--- a/meta-agl-profile-core/recipes-connectivity/connman/connman_%.bbappend
+++ b/meta-agl-profile-core/recipes-connectivity/connman/connman_%.bbappend
@@ -1,3 +1,12 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-SRC_URI += "file://0001-disable-when-booting-over-nfs.patch"
+SRC_URI += "file://0001-disable-when-booting-over-nfs.patch \
+ file://main.conf \
+"
+
+FILES_${PN} += "${sysconfdir}/connman/main.conf"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/connman
+ install -m 0644 ${WORKDIR}/main.conf ${D}${sysconfdir}/connman
+}
diff --git a/meta-agl-profile-core/recipes-connectivity/connman/files/main.conf b/meta-agl-profile-core/recipes-connectivity/connman/files/main.conf
new file mode 100644
index 000000000..0bfbe09dc
--- /dev/null
+++ b/meta-agl-profile-core/recipes-connectivity/connman/files/main.conf
@@ -0,0 +1,2 @@
+[General]
+FallbackTimeservers=pool.ntp.org