aboutsummaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-10-10 18:51:48 -0400
committerScott Murray <scott.murray@konsulko.com>2019-10-10 22:59:48 +0000
commita738f514ce796b7e974c624a4427dd3eeed7fd81 (patch)
treee09d2fa755c44ed4a0ce0d6ff15b90888b78fb4e /meta-agl-profile-core
parent8a7ddd46275b74779229538e5c79029b412d81d9 (diff)
agl-service-navigation: add RDEPENDS
Add RDEPENDS definition to indicate libjson-c and libdbus-c++ runtime dependency. This fixes a startup problem if libdbus-c++ is not pulled into an image by something else, which will then cause the POI app to crash. Bug-AGL: SPEC-2707 Change-Id: I02b6c120c0fefae972874284c10b6606bab5f647 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'meta-agl-profile-core')
-rwxr-xr-xmeta-agl-profile-core/recipes-apis/agl-service-navigation/agl-service-navigation_git.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-agl-profile-core/recipes-apis/agl-service-navigation/agl-service-navigation_git.bb b/meta-agl-profile-core/recipes-apis/agl-service-navigation/agl-service-navigation_git.bb
index c7a6fce0e..0a2e7d94e 100755
--- a/meta-agl-profile-core/recipes-apis/agl-service-navigation/agl-service-navigation_git.bb
+++ b/meta-agl-profile-core/recipes-apis/agl-service-navigation/agl-service-navigation_git.bb
@@ -15,3 +15,5 @@ PV = "0.1+git${SRCPV}"
S = "${WORKDIR}/git"
inherit cmake aglwgt pkgconfig
+
+RDEPENDS_${PN} += "json-c libdbus-c++"