summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core
diff options
context:
space:
mode:
authorMatt Ranostay <matt.ranostay@konsulko.com>2019-08-23 01:32:50 +0300
committerMatt Ranostay <matt.ranostay@konsulko.com>2019-08-26 22:01:24 +0300
commitb0824355568babf22ab85ec0992a7e938058e492 (patch)
treedef87d50f0242b7c4c1c49a2712273e23d85206d /meta-agl-profile-core
parent647ed1cbae42411b187cab794e495f39cf2ec883 (diff)
connman: add session-policy-local PACKAGECONFIG option
Bug-AGL: SPEC-2772 Change-Id: Id7fe16216bce7e9cf50188a504182aa79a70f9ed Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
Diffstat (limited to 'meta-agl-profile-core')
-rw-r--r--meta-agl-profile-core/recipes-connectivity/connman/connman_%.bbappend3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-agl-profile-core/recipes-connectivity/connman/connman_%.bbappend b/meta-agl-profile-core/recipes-connectivity/connman/connman_%.bbappend
index 8057fbbc7..469345880 100644
--- a/meta-agl-profile-core/recipes-connectivity/connman/connman_%.bbappend
+++ b/meta-agl-profile-core/recipes-connectivity/connman/connman_%.bbappend
@@ -6,6 +6,9 @@ SRC_URI += "file://0001-disable-when-booting-over-nfs.patch \
FILES_${PN} += "${sysconfdir}/connman/main.conf"
+PACKAGECONFIG[session-policy-local] = "--enable-session-policy-local,--disable-session-policy-local,"
+PACKAGECONFIG_append = " session-policy-local"
+
do_install_append() {
install -d ${D}${sysconfdir}/connman
install -m 0644 ${WORKDIR}/main.conf ${D}${sysconfdir}/connman