summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core
diff options
context:
space:
mode:
authorStephane Desneux <stephane.desneux@iot.bzh>2019-07-16 16:39:48 +0000
committerStephane Desneux <stephane.desneux@iot.bzh>2019-07-16 16:59:49 +0000
commitd90dd1a4aa6fb62a69c74e9e824977351ef9f8c4 (patch)
treea4f2be74da416c27a7016a5a277916d38eae9846 /meta-agl-profile-core
parent8611adeb40fcfe033d687fbc02f8699e26e9c49d (diff)
distro-build-manifest: add DIST_BUILD_TS in all manifests
The build timestamp is added to build manifests deployed in target images and SDK. Also, this patch adds a new option '-t|--timestamp' to distro-manifest-generator.sh to let the recipe pass the same timestamp as the one used for the image suffix (in Yocto 2.6/Thud, DATETIME is used). So DIST_BUILD_TS should have the same value as the image version suffix. Bug-AGL: SPEC-2649 Change-Id: I2a9d11b2ce59753bca31ebb8e82d46c224110d68 Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
Diffstat (limited to 'meta-agl-profile-core')
-rw-r--r--meta-agl-profile-core/recipes-core/distro-build-manifest/distro-build-manifest.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-agl-profile-core/recipes-core/distro-build-manifest/distro-build-manifest.bb b/meta-agl-profile-core/recipes-core/distro-build-manifest/distro-build-manifest.bb
index a3b341230..823cc28a1 100644
--- a/meta-agl-profile-core/recipes-core/distro-build-manifest/distro-build-manifest.bb
+++ b/meta-agl-profile-core/recipes-core/distro-build-manifest/distro-build-manifest.bb
@@ -47,6 +47,7 @@ python do_compilestep1 () {
do_compilestep2 () {
rc=99
+ timestamp=${DATETIME}
outfile=${B}/build-info
if [ -x "${DISTRO_MANIFEST_GENERATOR}" -a -f "${DISTRO_SETUP_MANIFEST}" ]; then
rc=0
@@ -57,7 +58,7 @@ do_compilestep2 () {
ext=""
fi
for mode in deploy target sdk; do
- ${DISTRO_MANIFEST_GENERATOR} -m $mode -f $format -s ${B}/bbinfo-${mode} ${DISTRO_SETUP_MANIFEST} >${outfile}-${mode}${ext}
+ ${DISTRO_MANIFEST_GENERATOR} -m $mode -f $format -t $timestamp -s ${B}/bbinfo-${mode} ${DISTRO_SETUP_MANIFEST} >${outfile}-${mode}${ext}
rc=$?
if [ $rc -ne 0 ]; then
break
@@ -91,6 +92,9 @@ do_compilestep1[vardeps] += " ${BUILD_MANIFEST_FIELDS_DEPLOY}"
do_compilestep1[vardeps] += " ${BUILD_MANIFEST_FIELDS_TARGET}"
do_compilestep1[vardeps] += " ${BUILD_MANIFEST_FIELDS_SDK}"
+# avoid errors "ERROR: When reparsing .../distro-build-manifest/distro-build-manifest.bb.do_compile, the basehash value changed from .... to .... . The metadata is not deterministic and this needs to be fixed."
+do_compilestep2[vardepsexclude] = "DATETIME"
+
# combine the two steps
python do_compile() {
bb.build.exec_func("do_compilestep1",d)