summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-02-10 13:58:29 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-02-17 18:24:55 +0000
commitf54138fb4bdb79154ad3dc450c30fc9be765d6a5 (patch)
treec8f877eba47fa90a830e97f93a286eb10cf71395 /meta-agl-profile-core
parent1744b527b6ea0eb105f20cf7b722a7e02406126f (diff)
Update to YP dunfell 3.1.5
Changes include: - Backport gstreamer 1.16.2 vs 1.16.3 workaround for rcar3 (originally for SPEC-3706 in master, now updated per SPEC-3803). - Add 1.16.% wildcard version of meta-rcar-gen3-adas Kingfisher support layer gstreamer1.0-plugins-bad bbappend. The issue is the same as with the main meta-rcar-gen3 BSP layer bbappends mentioned above, but this particular bbappend has been disabled in the newer BSP in master/koi, so they did not need a fix. - Add override of PREFERRED_VERSION_libdrm for rcar3 to quiet warnings about 2.4.100 not being available, which are caused by dunfell 3.1.5 bringing an update to 2.4.101. - Pin Raspberry Pi kernel version to 4.19. meta-raspberrypi upstream has switched their default kernel to 5.4 on their dunfell branch, but that significant of a change is not desirable in a AGL point release. - Remove now upstreamed systemd patch. Bug-AGL: SPEC-3793, SPEC-3803 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ia678b8f56f35026a62a9f6ab40f9727b10756ad6 Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/26042 Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-profile-core')
-rw-r--r--meta-agl-profile-core/recipes-core/systemd/systemd/0001-fix-udevd-seclabel-parsing.patch34
-rw-r--r--meta-agl-profile-core/recipes-core/systemd/systemd_%.bbappend1
2 files changed, 0 insertions, 35 deletions
diff --git a/meta-agl-profile-core/recipes-core/systemd/systemd/0001-fix-udevd-seclabel-parsing.patch b/meta-agl-profile-core/recipes-core/systemd/systemd/0001-fix-udevd-seclabel-parsing.patch
deleted file mode 100644
index 29165b58e..000000000
--- a/meta-agl-profile-core/recipes-core/systemd/systemd/0001-fix-udevd-seclabel-parsing.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-Fix udevd SECLABEL token parsing
-
-The udevd rules parsing rewrite in v243 broke SECLABEL parsing,
-with the result being that udevd crashes when it parses a line
-containing a SECLABEL token. Fix the handling of the attribute
-of SECLABEL tokens when parsing, and add a check to prevent
-crashes if the attribute is missing.
-
-Upstream-Status: Pending
-
-Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-
-diff --git a/src/udev/udev-rules.c b/src/udev/udev-rules.c
-index efea16e5c5..3e757ccb06 100644
---- a/src/udev/udev-rules.c
-+++ b/src/udev/udev-rules.c
-@@ -918,7 +918,7 @@ static int parse_token(UdevRules *rules, const char *key, char *attr, UdevRuleOp
- op = OP_ASSIGN;
- }
-
-- r = rule_line_add_token(rule_line, TK_A_SECLABEL, op, value, NULL);
-+ r = rule_line_add_token(rule_line, TK_A_SECLABEL, op, value, attr);
- } else if (streq(key, "RUN")) {
- if (is_match || op == OP_REMOVE)
- return log_token_invalid_op(rules, key);
-@@ -1927,6 +1927,8 @@ static int udev_rule_apply_token_to_event(
- _cleanup_free_ char *name = NULL, *label = NULL;
- char label_str[UTIL_LINE_SIZE] = {};
-
-+ if (!token->data)
-+ break;
- name = strdup((const char*) token->data);
- if (!name)
- return log_oom();
diff --git a/meta-agl-profile-core/recipes-core/systemd/systemd_%.bbappend b/meta-agl-profile-core/recipes-core/systemd/systemd_%.bbappend
index 242b3d39c..96c4dc35c 100644
--- a/meta-agl-profile-core/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-agl-profile-core/recipes-core/systemd/systemd_%.bbappend
@@ -1,7 +1,6 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI += "\
- file://0001-fix-udevd-seclabel-parsing.patch \
file://0002-network-add-CAN-Termination-tristate-option.patch \
file://e2fsck.conf \
file://canbus-can.network \