summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2018-06-04 20:57:30 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-06-06 06:32:28 +0000
commitad34efe7bc84ae83af9e08695f633e8792130707 (patch)
tree818576c888e8294f8baba2a320b318398700d61b /meta-agl-profile-core
parentb43165328658087277b667152fdbc04fe07cba08 (diff)
agl-service-radio: Rework 4A support
Updates for changes to the binding to directly support 4A: - the over-ride of the output sink is no longer required - building now always requires gstreamer-1.0 - pulseaudio is now only required when building for non-4A - set HAVE_4A_FRAMEWORK when building for 4A Change-Id: If98abbb27ed4f6b04a3102956dfc2923bc7ec2db Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'meta-agl-profile-core')
-rw-r--r--meta-agl-profile-core/recipes-apis/agl-service-radio/agl-service-radio_git.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/meta-agl-profile-core/recipes-apis/agl-service-radio/agl-service-radio_git.bb b/meta-agl-profile-core/recipes-apis/agl-service-radio/agl-service-radio_git.bb
index 0e913af15..34f734a5c 100644
--- a/meta-agl-profile-core/recipes-apis/agl-service-radio/agl-service-radio_git.bb
+++ b/meta-agl-profile-core/recipes-apis/agl-service-radio/agl-service-radio_git.bb
@@ -2,19 +2,21 @@ SUMMARY = "Radio Service Binding"
DESCRIPTION = "AGL Radio Service Binding"
HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-service-radio"
SECTION = "apps"
-
-
LICENSE = "Apache-2.0 & GPLv2+"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+PV = "1.0+git${SRCPV}"
+
SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-radio;protocol=https;branch=${AGL_BRANCH}"
SRCREV = "${AGL_APP_REVISION}"
-PV = "1.0+git${SRCPV}"
S = "${WORKDIR}/git"
# build-time dependencies
-DEPENDS = "rtl-sdr glib-2.0 pulseaudio alsa-lib"
+DEPENDS = "rtl-sdr glib-2.0 gstreamer1.0"
+DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'agl-audio-4a-framework', '' , 'pulseaudio', d)}"
inherit cmake aglwgt pkgconfig
+
+EXTRA_OECMAKE += "${@bb.utils.contains('DISTRO_FEATURES', 'agl-audio-4a-framework', '-DHAVE_4A_FRAMEWORK=1' , '', d)}"