summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-demo/recipes-connectivity/bluez5/bluez5_%.bbappend
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-04-24 15:13:18 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-04-28 00:28:55 +0200
commit4ac99c3a1447119363935fb986f5d9c05f032362 (patch)
treed4fdce1f65606af5111e6e4d5d21b198de9f2bf2 /meta-agl-profile-demo/recipes-connectivity/bluez5/bluez5_%.bbappend
parentbb0882c5dad030f676e424265ebcd869bb3ff899 (diff)
2nd part of the layer/profile rework [1/2]
Main goal of this is to move the agl-service-* bindings into the core and to unify common recipes like wayland/weston into meta-agl-profile-graphical. As a placeholder for recipes is meta-agl-profile-demo which are being reshuffled. TLDR: agl-service move to meta-agl-profile-core. wayland/weston moves to meta-agl-profile-graphical. This patchset needs the 2nd patchset of the series to build (meta-agl-demo). Bug-AGL: SPEC-145 , SPEC-876 , SPEC-877 v2: rebase including udiscs patches from meta-agl-demo Change-Id: I5e33f72d01707fa8b826d382bccaca3addcbbc47 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-profile-demo/recipes-connectivity/bluez5/bluez5_%.bbappend')
-rw-r--r--meta-agl-profile-demo/recipes-connectivity/bluez5/bluez5_%.bbappend7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-agl-profile-demo/recipes-connectivity/bluez5/bluez5_%.bbappend b/meta-agl-profile-demo/recipes-connectivity/bluez5/bluez5_%.bbappend
index ffb9d5b53..c5afa875f 100644
--- a/meta-agl-profile-demo/recipes-connectivity/bluez5/bluez5_%.bbappend
+++ b/meta-agl-profile-demo/recipes-connectivity/bluez5/bluez5_%.bbappend
@@ -1,6 +1,13 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
SRC_URI_append = " file://bluetooth.conf"
+APPLY_v522 = "${@str('no' if '${PV}' != '5.22' else 'yes')}"
+
+SRC_URI_append = "\
+ file://0001_fix_compile_issue_when_using_in_c++.patch;apply=${APPLY_v522} \
+"
+
+
do_install_append() {
install -m 0644 ${WORKDIR}/bluetooth.conf ${D}${sysconfdir}/dbus-1/system.d/bluetooth.conf
}