aboutsummaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-graphical-qt5
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-06-06 17:11:46 -0400
committerScott Murray <scott.murray@konsulko.com>2019-06-06 17:12:49 -0400
commit186d92daea4cfbb61dc9dcc296b73a9f8477a0d9 (patch)
tree742ab5e522970e09b2868b40f1e8eaf202e2e77a /meta-agl-profile-graphical-qt5
parent20602b4c6194c114b108a0e9e1c9b104bf18f79b (diff)
meta-agl-profile-graphical*: Add qtaglextras and dependencies
Add qtaglextras to meta-agl-profile-graphical-qt5, and its dependencies libhomescreen and agl-service-homescreen to meta-agl-profile-graphical. This is required to fix building the cluster demo SDK now that qtaglextras has been added to packagegroup-qt5-toolchain-target. These changes are a partial backport of the move of the contents of meta-hmi-framework in master / Halibut. Bug-AGL: SPEC-2484 Change-Id: I94493c65d2253ceb2204b34a8ad216910851a54b Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'meta-agl-profile-graphical-qt5')
-rw-r--r--meta-agl-profile-graphical-qt5/recipes-qt/qtaglextras/qtaglextras_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-agl-profile-graphical-qt5/recipes-qt/qtaglextras/qtaglextras_git.bb b/meta-agl-profile-graphical-qt5/recipes-qt/qtaglextras/qtaglextras_git.bb
new file mode 100644
index 000000000..a874a9cfb
--- /dev/null
+++ b/meta-agl-profile-graphical-qt5/recipes-qt/qtaglextras/qtaglextras_git.bb
@@ -0,0 +1,28 @@
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE-2.0.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+DEPENDS += "qtbase qtdeclarative qtquickcontrols2 qlibwindowmanager libhomescreen"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/qtaglextras;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "2fe96de41a540477d425403cf3a59ec6f5871521"
+
+PV = "5.8.0+git${SRCPV}"
+S = "${WORKDIR}/git/"
+
+inherit qmake5
+
+PACKAGES += "${PN}-mkspecs"
+
+FILES_${PN}-mkspecs = "\
+ ${OE_QMAKE_PATH_QT_ARCHDATA}/mkspecs \
+"
+
+FILES_${PN}-dev += " \
+ ${OE_QMAKE_PATH_LIBS}/lib*${SOLIBSDEV} \
+ ${OE_QMAKE_PATH_LIBS}/pkgconfig \
+ ${OE_QMAKE_PATH_LIBS}/cmake/* \
+ ${OE_QMAKE_PATH_LIBS}/*.prl \
+ ${OE_QMAKE_PATH_LIBS}/*.la \
+ ${OE_QMAKE_PATH_DATA}/* \
+ ${OE_QMAKE_PATH_HEADERS}/* \
+"