aboutsummaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-graphical/recipes-graphics/libhomescreen/libhomescreen_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-06-06 17:11:46 -0400
committerScott Murray <scott.murray@konsulko.com>2019-06-06 17:12:49 -0400
commit186d92daea4cfbb61dc9dcc296b73a9f8477a0d9 (patch)
tree742ab5e522970e09b2868b40f1e8eaf202e2e77a /meta-agl-profile-graphical/recipes-graphics/libhomescreen/libhomescreen_git.bb
parent20602b4c6194c114b108a0e9e1c9b104bf18f79b (diff)
meta-agl-profile-graphical*: Add qtaglextras and dependencies
Add qtaglextras to meta-agl-profile-graphical-qt5, and its dependencies libhomescreen and agl-service-homescreen to meta-agl-profile-graphical. This is required to fix building the cluster demo SDK now that qtaglextras has been added to packagegroup-qt5-toolchain-target. These changes are a partial backport of the move of the contents of meta-hmi-framework in master / Halibut. Bug-AGL: SPEC-2484 Change-Id: I94493c65d2253ceb2204b34a8ad216910851a54b Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'meta-agl-profile-graphical/recipes-graphics/libhomescreen/libhomescreen_git.bb')
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/libhomescreen/libhomescreen_git.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-agl-profile-graphical/recipes-graphics/libhomescreen/libhomescreen_git.bb b/meta-agl-profile-graphical/recipes-graphics/libhomescreen/libhomescreen_git.bb
new file mode 100644
index 000000000..1c9a38ca8
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-graphics/libhomescreen/libhomescreen_git.bb
@@ -0,0 +1,26 @@
+SUMMARY = "AGL Home Screen Library"
+DESCRIPTION = "libhomescreen"
+HOMEPAGE = "http://docs.automotivelinux.org"
+LICENSE = "Apache-2.0"
+SECTION = "libs"
+
+BBCLASSEXTEND = " nativesdk"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = "af-binder json-c"
+
+inherit cmake
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/src/libhomescreen.git;protocol=https;branch=${AGL_BRANCH} \
+ file://org.agl.statusbar.conf \
+ "
+SRCREV = "d01f3c61041ff7b8d2d942f99680407ee10320bc"
+S = "${WORKDIR}/git"
+
+do_install_append() {
+ mkdir -p ${D}${sysconfdir}/dbus-1/session.d
+ install -m 0644 ${WORKDIR}/org.agl.statusbar.conf ${D}${sysconfdir}/dbus-1/session.d
+}
+
+RDEPENDS_${PN} = "agl-service-homescreen"